Bug Hunting Session
Bug 125118 - shift-click for absolute reference when entering formulas
Summary: shift-click for absolute reference when entering formulas
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Enhancements
  Show dependency treegraph
 
Reported: 2019-05-04 16:57 UTC by DV
Modified: 2019-05-12 07:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
just a picture of what I mean (12.64 KB, image/png)
2019-05-04 17:00 UTC, DV
Details
better picture - ignore first (17.17 KB, image/png)
2019-05-04 17:04 UTC, DV
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DV 2019-05-04 16:57:46 UTC
Description:
It would be nice to shift-click on a cell and have it entered as an absolute reference, vs. going back and changing them by typing in the $ sign.

ctrl-click does a similar function where it inserts the cell with a comma before it.

Steps to Reproduce:
1.  click cell, type equals
2. select desired cell with mouse click

Actual Results:
relative reference

Expected Results:
absolute reference


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 DV 2019-05-04 17:00:31 UTC
Created attachment 151181 [details]
just a picture of what I mean
Comment 2 DV 2019-05-04 17:04:29 UTC
Created attachment 151182 [details]
better picture - ignore first
Comment 3 Usama 2019-05-05 07:20:20 UTC
I personally think that it would be a useful feature. adding UX team to the CC list.
Comment 4 Heiko Tietze 2019-05-06 06:35:42 UTC
Yes, great idea. However, shift+click selects a range, eg. B1:C2, whereas ctrl+click adds a single cell to the selection and thereby the semicolon, eg. B1;C2. Alt+click is occupied by the window manager on many desktop environments. So how about modifying the ctrl/shift+click behavior with alt in order to get the same as before but with absolute references?
Comment 5 Eike Rathke 2019-05-08 11:11:34 UTC
You mean Alt+Shift+Click like Shift+Click but with absolute references, and Alt+Ctrl+Click like Ctrl+Click but with absolute references? Might be doable, but IMHO too cumbersome to type and hold button down as well, I wouldn't use it. Much easier is to use existing functionality, select the cell/range and before moving on hit F4, which "absolutes" the currently selected cell/range in the formula expression. One can even toggle through.
Comment 6 Heiko Tietze 2019-05-08 11:17:42 UTC
DV, A1 -> $A$1 -> A$1 -> $A1 (it's not selective so A1:B2 toggles completely). Is that sufficient for you?
Comment 7 DV 2019-05-11 19:17:52 UTC
Heiko, Eike, ty.   Your suggestion is sufficient.  I've made a donation to the TDF, I'm really amazed at the development in LibreOffice!

On a laptop with no native F keys I think it would be easier to Alt+Shift+Click due to the natural position of the fingers.

If possible, could someone link me to the file in github and line where I'd be able to play with this in the source? it seems like a fun little project.
Comment 8 Heiko Tietze 2019-05-12 07:33:44 UTC
Glad you are happy with LibreOffice. Take a look at Tools > Customize > Keyboard about changing the default key bindings. See also https://help.libreoffice.org/6.2/en-US/text/shared/01/06140200.html?&DbPAR=SHARED&System=UNIX