Bug Hunting Session
Bug 125128 - Option's AutoCaption preference should show Above as default position of table captions (again)
Summary: Option's AutoCaption preference should show Above as default position of tabl...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.5 target:6.3.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Options-Dialog-Writer Caption
  Show dependency treegraph
 
Reported: 2019-05-06 04:59 UTC by Thomas Lendo
Modified: 2019-05-27 12:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
How it looks in LibreOffice 6.3 master (89.85 KB, image/png)
2019-05-23 10:16 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2019-05-06 04:59:00 UTC
This is a follow-up bug of bug 40457 "Place captions above tables by default" and bug 115032 where this issue was already fixed in LibO 6.0 and 6.1.

The default preference in Tools > Options > Writer > AutoCaption should show "Above" as position of table captions instead of "Below". (But for images it should remain "Below".)


Tested with
Version: 6.3.0.0.alpha0+ (x64)
Build ID: db39336550ff547bcb7ca15793b12291c913ab42
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-29_23:46:36
Locale: de-AT (de_AT); UI-Language: en-US
Comment 1 Thomas Lendo 2019-05-06 05:06:02 UTC
Adding Julien Nabet and Heiko Tietze as they were also involved in bug 115032.
Comment 2 Dieter Praas 2019-05-22 20:01:32 UTC
I confirm it with

Version: 6.3.0.0.alpha1+ (x64)
Build ID: e92dcfdc7bd7b237e0bee26ff226a102d9e8e766
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-14_00:00:57
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 3 Heiko Tietze 2019-05-23 08:36:01 UTC
On a fresh build it does place the caption above. So cannot confirm.

Version: 6.3.0.0.alpha1+
Build ID: b004b7f3c1a28ebab1823bdbe38660b6c44483b1
CPU threads: 8; OS: Linux 5.1; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-05-23 09:55:35 UTC Comment hidden (obsolete)
Comment 5 Dieter Praas 2019-05-23 10:10:40 UTC
Xisco, I confirm your steps, but the bug is about the options dialog

Steps to reproduce:
1. Open Options => AutoCaption
2. Default setting for table caption is below (should be above)
Comment 6 Xisco Faulí 2019-05-23 10:16:13 UTC
Created attachment 151621 [details]
How it looks in LibreOffice 6.3 master

oh, sorry, you're right. How it looks in master with a clean profile

Version: 6.3.0.0.alpha1+
Build ID: e3015d7021e689c71c2ed8e5dd01a74d832c84f0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Xisco Faulí 2019-05-23 10:21:41 UTC
Indeed, this is a recent regression, bisecting...
Comment 8 Xisco Faulí 2019-05-23 10:33:31 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3bd103064ba719013471d9664ea2c1f207b84d90

author	Caolán McNamara <caolanm@redhat.com>	2018-12-11 20:30:52 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-12-12 21:07:12 +0100
commit	3bd103064ba719013471d9664ea2c1f207b84d90 (patch)
tree	b15086268b4858614f19b746e67b870945de1b0b
parent	27995e638e1582b443befa93bc5dfd5970a38ef2 (diff)
weld SwCaptionOptPage

Bisected with: bibisect-linux64-6.3

Adding Cc: to Caolán McNamara
Comment 9 Caolán McNamara 2019-05-23 12:08:44 UTC
The previous code doesn't look right either though. In 6.1

if (m_pPosBox->IsEnabled())
    m_pPosBox->SelectEntryPos(pOpt->GetPos());
else
    m_pPosBox->SelectEntryPos(0);

select position 0 if its disabled, leave it as the default if it is enabled.

Things start off disabled, so its 0 starting off and the option pos is ignored, but on changing entries the settings are saved, so if you cursor away from the first entry, then the entry 0 get saved as the default for the next visit.

So on initial visit

tables is disabled and shows "above", enable it and it shows "below". Cancel to not save changes and revisit

tables is disabled, click on frame, click on table again, it shows "above", enable it and it sticks as "above". Because the change away from frame and back to table has saved the "above" position in
Comment 10 Caolán McNamara 2019-05-23 12:52:27 UTC
https://gerrit.libreoffice.org/#/c/72846/ to change the default for Tables to above in the settings reserved for these defaults
Comment 11 Commit Notification 2019-05-23 19:13:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/6d7a32ffd1bd1530ac9bf38d10c89fe7cd598f87%5E%21

Resolves: tdf#125128 set Tables as "above" by default

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-05-23 19:13:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ca86d9c5e10ad7ce88d121dc8d9145058aaad782%5E%21

Resolves: tdf#125128 set Tables as "above" by default

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2019-05-27 12:10:22 UTC
Verified in

Version: 6.3.0.0.alpha1+
Build ID: 53325b40b557cc84d8d21c1baa0ef8d3bfc00ab8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!