Bug 125134 - Not possible to use named ranges in external spreadsheet
Summary: Not possible to use named ranges in external spreadsheet
Status: RESOLVED DUPLICATE of bug 72594
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-06 12:49 UTC by Balvie
Modified: 2019-05-08 20:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
named range pointing to another spreadsheet (52.77 KB, image/png)
2019-05-06 17:05 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Balvie 2019-05-06 12:49:51 UTC
I have problems doing a vlookup in an external sheet.

Up to now I need to refer as:
VLOOKUP(C15,'file:///C:/.....ods'#$pricelist.$B$10:$D$82,2,0))
and the price as:
VLOOKUP(C15,'file:///C:/.....ods'#$pricelist.$B$10:$D$82,3,0))

I'd like to use a named range for this, something like:
VLOOKUP(C15,'file:///C:/.....ods'#pricetable,2,0))
VLOOKUP(C15,'file:///C:/.....ods'#pricetable,3,0))

I would expect that this should be possible. Is there something I have missed?

Is there any documentation about the scope and precise syntax of using a named range?
Comment 1 Oliver Brinzing 2019-05-06 17:05:42 UTC
Created attachment 151208 [details]
named range pointing to another spreadsheet

i don't think, this is possible.
but you can create a named range pointing to another sheets
Comment 2 raal 2019-05-07 17:11:20 UTC
Not possible  -  see bug 60170
Comment 3 m.a.riosv 2019-05-07 20:22:09 UTC
But seems a dup of tdf#72594

*** This bug has been marked as a duplicate of bug 72594 ***
Comment 4 Balvie 2019-05-08 20:09:02 UTC
Now that it is explained, its clear for me how it works. The method of a named range created in the local file is okay for me.
Issue may be closed (do not know how to do that).
Thanks for helping and answering.