Download it now!
Bug 125184 - Missing connectors in last version
Summary: Missing connectors in last version
Status: RESOLVED DUPLICATE of bug 121649
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks: DOC-Shapes
  Show dependency treegraph
 
Reported: 2019-05-09 06:51 UTC by MatteoCTB
Modified: 2019-05-16 09:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Connectors are ok in 6.0.7.3 version (295.92 KB, image/jpeg)
2019-05-09 06:53 UTC, MatteoCTB
Details
Connectors are missing in 6.2.3.2 version (275.94 KB, image/jpeg)
2019-05-09 06:54 UTC, MatteoCTB
Details
Connector are missing in 6.3.0.0 version (279.76 KB, image/jpeg)
2019-05-09 06:56 UTC, MatteoCTB
Details
The document with problems (11.67 KB, application/vnd.oasis.opendocument.text)
2019-05-09 06:58 UTC, MatteoCTB
Details
The document with problem 2 (26.50 KB, application/vnd.oasis.opendocument.text)
2019-05-09 11:51 UTC, MatteoCTB
Details
Correct dot document with problem (26.50 KB, application/msword)
2019-05-11 17:08 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MatteoCTB 2019-05-09 06:51:27 UTC
Description:
I have a document with connectors inside. When I open it with 6.0.7.3 version (or older), it is ok. But when I open the same document with 6.2.3.2 or 6.3.0.0, the connectors are missing.

Steps to Reproduce:
1. Open the document
2.
3.

Actual Results:
The connectors in document are missing

Expected Results:
Show me the connectors as in 6.0.7.3 version


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 MatteoCTB 2019-05-09 06:53:08 UTC
Created attachment 151260 [details]
Connectors are ok in 6.0.7.3 version
Comment 2 MatteoCTB 2019-05-09 06:54:10 UTC
Created attachment 151261 [details]
Connectors are missing in 6.2.3.2 version
Comment 3 MatteoCTB 2019-05-09 06:56:34 UTC
Created attachment 151262 [details]
Connector are missing in 6.3.0.0 version
Comment 4 MatteoCTB 2019-05-09 06:58:15 UTC
Created attachment 151263 [details]
The document with problems
Comment 5 Regina Henschel 2019-05-09 11:23:13 UTC
Are you sure you have attached the correct file? I have tried various versions from LO 4, LO 5 and LO 6. In none of them I see connectors.
Comment 6 MatteoCTB 2019-05-09 11:51:06 UTC
Created attachment 151272 [details]
The document with problem 2
Comment 7 MatteoCTB 2019-05-09 11:52:23 UTC
I don't understand...
I tried to attach a new file with the problem
Comment 8 Regina Henschel 2019-05-09 14:04:43 UTC
The now attached document is no valid ODF document at all. How do you generate the document.
Comment 9 MatteoCTB 2019-05-09 14:19:57 UTC
Honestly I don't know. I'm sorry but I didn't create it.
It's an old document. It was perfect, but when I update to new version, the connectors have disappeared.
Comment 10 Regina Henschel 2019-05-09 17:54:43 UTC
The file is a Word.8 document template and should have the extension "dot". Therefore it will not "open" in LibreOffice, but a document "Untitled 1" will be generated from it.

I can confirm the missing connectors.

It is OK in Version: 6.1.2.0.0+ (x64)
Build ID: 2f52a8e0f1098a51631434129707cfb0b60fecb3
CPU threads: 8; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-1, Time: 2018-09-14_00:42:50
Locale: en-US (en_US); Calc: CL

and broken in Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (en_US); Calc: CL

MatheoCTB: You should open the document in an older LibreOffice Version and save it as ODF template.
Comment 11 Roman Kuznetsov 2019-05-11 17:08:48 UTC
Created attachment 151310 [details]
Correct dot document with problem

I confirm problem in 6.1.4 but not in 6.0.7

And I can't open this dot file in 6.2 and more later version -> another bug
Comment 12 Xisco Faulí 2019-05-16 09:30:35 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=52bbb04f1e39b2d778275c91f77b6c0714ecd0d0 which is the same as in bug 121649.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 121649 ***