Bug 125223 - Right version number in Help/About...
Summary: Right version number in Help/About...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2019-05-11 19:57 UTC by Sebők Gábor
Modified: 2019-06-22 12:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebők Gábor 2019-05-11 19:57:15 UTC
Description:
No matteris it developer or alpha build, there shoul the RIGHT VERSION NUMBER shown. On my computer are more, than one version installed and need it for testing purposes.

Actual Results:
Shows Help/About... the last released version number.

Expected Results:
Shows the right version.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-05-13 14:26:56 UTC
Sebők, please attach screenshot your Help->About dialog and write more clear and detail what is wrong with version
Comment 2 Sebők Gábor 2019-05-14 16:34:31 UTC
(In reply to Roman Kuznetsov from comment #1)
> Sebők, please attach screenshot your Help->About dialog and write more clear
> and detail what is wrong with version

Here you are:

https://drive.google.com/open?id=1YbnmB041RL8gkDUao-wy6BTgbcKnbT8e
This is 6.3.3.0 alpha2 build.

Gábor
Comment 3 Roman Kuznetsov 2019-05-14 17:11:01 UTC
(In reply to Sebők Gábor from comment #2)
> (In reply to Roman Kuznetsov from comment #1)
> > Sebők, please attach screenshot your Help->About dialog and write more clear
> > and detail what is wrong with version
> 
> Here you are:
> 
> https://drive.google.com/open?id=1YbnmB041RL8gkDUao-wy6BTgbcKnbT8e
> This is 6.3.3.0 alpha2 build.
> 
> Gábor

There is no 6.3.3 alpha 2 build anyway
There is 6.3 alpha 0 now
Are you sure you know version for LibreOffice?

Imho it is not a bug
Comment 4 Sebők Gábor 2019-05-15 14:37:55 UTC
(In reply to Roman Kuznetsov from comment #3)
> (In reply to Sebők Gábor from comment #2)
> > (In reply to Roman Kuznetsov from comment #1)
> > > Sebők, please attach screenshot your Help->About dialog and write more clear
> > > and detail what is wrong with version
> > 
> > Here you are:
> > 
> > https://drive.google.com/open?id=1YbnmB041RL8gkDUao-wy6BTgbcKnbT8e
> > This is 6.3.3.0 alpha2 build.
> > 
> > Gábor
> 
> There is no 6.3.3 alpha 2 build anyway
> There is 6.3 alpha 0 now
> Are you sure you know version for LibreOffice?
> 
> Imho it is not a bug

Yes, I wrote wrong. This is alpha 0, the filename of MSI file is:

 libo-master_2019-05-10_22.42.41_LibreOfficeDev_6.3.0.0.alpha0_Win_x86.msi
Comment 5 Sebők Gábor 2019-06-05 08:08:59 UTC
The problem is still existing in case of 6.4.0.0 too, I think, that status cannot be RESOLVED!

Look at this:
https://drive.google.com/open?id=194F6rwB2IaZ1_ZCb9vFQsR56Zp7nxdmj
Comment 6 Xisco Faulí 2019-06-10 14:00:33 UTC
I'm sorry but I don't understand what is the problem here.

Do you mean it says it's LibreOffice 6.2.0.3 while the current version you're using is 6.3.0.0 ?
Comment 7 Sebők Gábor 2019-06-10 16:37:34 UTC
Yes, you understand it right! The problem also is existing in 6.4.0.0:

https://drive.google.com/file/d/194F6rwB2IaZ1_ZCb9vFQsR56Zp7nxdmj/view?usp=sharing

Gábor
Comment 8 Xisco Faulí 2019-06-10 17:32:36 UTC
That's really weird. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?
Comment 9 Sebők Gábor 2019-06-10 20:21:36 UTC
After user-profi reset the problem didn't disappear:

https://drive.google.com/file/d/16yCo5fZRPV3Z7_11yzOTyyfIoxKiXL9_/view?usp=sharing

In Hungarian it means: "Last known working profile settings".

Gábor
Comment 10 QA Administrators 2019-06-11 03:02:11 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2019-06-11 07:33:45 UTC
Expand the 'Speciális' option...
Comment 12 Aron Budea 2019-06-11 10:33:07 UTC
It seems you also have a LibreOffice release build installed. The daily builds install with the name LibreOfficeDev, therefore you need to run that application, and not LibreOffice.
Comment 13 Sebők Gábor 2019-06-11 19:50:57 UTC
Could you help me, wish build should I deploy?

https://drive.google.com/file/d/1mxy3_EYBZ3UbtF99oZmqxryXnV8otKl9/view?usp=sharing

Cheers,
Gábor
Comment 14 QA Administrators 2019-06-12 03:00:04 UTC Comment hidden (obsolete)
Comment 15 Xisco Faulí 2019-06-12 14:53:00 UTC
(In reply to Sebők Gábor from comment #13)
> Could you help me, wish build should I deploy?
> 
> https://drive.google.com/file/d/1mxy3_EYBZ3UbtF99oZmqxryXnV8otKl9/
> view?usp=sharing
> 
> Cheers,
> Gábor

You can choose one from the list depending on your OS -> https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases

Closing as RESOLVED NOTABUG
Comment 16 Sebők Gábor 2019-06-20 00:01:06 UTC
It works only in case when the application ITSELF offers new version to deploy. When I install LO from daily builds directory

https://dev-builds.libreoffice.org/daily/

it DOESN'T work!

Gábor
Comment 17 Sebők Gábor 2019-06-20 00:01:52 UTC Comment hidden (obsolete)
Comment 18 Aron Budea 2019-06-20 01:46:20 UTC
Are you running LibreOfficeDev application of the daily build?
Comment 19 Sebők Gábor 2019-06-21 19:37:43 UTC
No, it's definitely NOT a developer build!
Comment 20 Aron Budea 2019-06-21 20:35:42 UTC
Then you haven't installed and/or aren't running the correct application. Please check if you have LibreOfficeDev installed. If not, install it. Then run LibreOfficeDev.
Comment 21 Sebők Gábor 2019-06-22 12:57:26 UTC
:)
It works!
:)