Bug 125249 - LibreOffice Writer renders text as pixelated, thin, not crisp
Summary: LibreOffice Writer renders text as pixelated, thin, not crisp
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2019-05-13 04:08 UTC by christopher_lee_1_fan
Modified: 2019-06-02 15:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of text in Calibri 11 on LibreOffice Writer (48.93 KB, image/png)
2019-05-13 04:19 UTC, christopher_lee_1_fan
Details
Screenshot of text in Calibri 11 on Microsoft Word 2019 (80.49 KB, image/jpeg)
2019-05-13 04:19 UTC, christopher_lee_1_fan
Details
Screenshot of text in Calibri 25 on LibreOffice Writer (67.15 KB, image/png)
2019-05-13 04:20 UTC, christopher_lee_1_fan
Details
Screenshot of text in Calibri 25 on Microsoft Word 2019 (113.27 KB, image/jpeg)
2019-05-13 04:21 UTC, christopher_lee_1_fan
Details
Screenshot of text in Times New Roman 12 on LibreOffice Writer (51.03 KB, image/png)
2019-05-13 04:21 UTC, christopher_lee_1_fan
Details
Screenshot of text in Times New Roman 12 on Microsoft Word 2019 (84.42 KB, image/jpeg)
2019-05-13 04:22 UTC, christopher_lee_1_fan
Details
Screenshot of text in Times New Roman 25 on LibreOffice Writer (71.66 KB, image/png)
2019-05-13 04:22 UTC, christopher_lee_1_fan
Details
Screenshot of text in Times New Roman 25 on Microsoft Word 2019 (113.09 KB, image/jpeg)
2019-05-13 04:23 UTC, christopher_lee_1_fan
Details
Screenshot of text in Times New Roman 100 on LibreOffice Writer (57.10 KB, image/png)
2019-05-13 04:23 UTC, christopher_lee_1_fan
Details
Screenshot of text in Times New Roman 100 on Microsoft Word 2019 (85.36 KB, image/jpeg)
2019-05-13 04:24 UTC, christopher_lee_1_fan
Details
Some computer specs (42.13 KB, text/plain)
2019-05-13 04:33 UTC, christopher_lee_1_fan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christopher_lee_1_fan 2019-05-13 04:08:59 UTC
Description:
LibreOffice Writer does not render text properly. Characters show up as pixelized, thinner than normal, not crispy. This is especially relative to the same text typed in other programs, such as Microsoft Word 2019, Google Docs, and iCloud Pages. This issue occurs regardless of whether antialiasing and OpenGL are enabled. Problems with font rendering have been reported multiple times (here, here, and here, to name a few).

Steps to Reproduce:
1.Create a new LibreOffice Writer document.
2.Set the zoom factor at 100%.
3.Use common typefaces, such as Calibri and Times New Roman, at small (12 pt) and large (25 pt) fonts.
4.Type anything in English. Preferably, make it a big block of text so the effect is seen more clearly.
5.(Optional): Repeat the same steps above in Microsoft Word 2007 or above. Then compare.

Actual Results:
Writing looks pixelated, thinner than normal, kerning is irregular, is not crispy.

Expected Results:
Words and letters should look clear, crispy, and with regular kerning, from 100% zoom. As it already happens in other word processors like Microsoft Word. 


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.2.3.2 (x64)
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 christopher_lee_1_fan 2019-05-13 04:19:20 UTC
Created attachment 151328 [details]
Screenshot of text in Calibri 11 on LibreOffice Writer
Comment 2 christopher_lee_1_fan 2019-05-13 04:19:55 UTC
Created attachment 151329 [details]
Screenshot of text in Calibri 11 on Microsoft Word 2019
Comment 3 christopher_lee_1_fan 2019-05-13 04:20:31 UTC
Created attachment 151330 [details]
Screenshot of text in Calibri 25 on LibreOffice Writer
Comment 4 christopher_lee_1_fan 2019-05-13 04:21:01 UTC
Created attachment 151331 [details]
Screenshot of text in Calibri 25 on Microsoft Word 2019
Comment 5 christopher_lee_1_fan 2019-05-13 04:21:38 UTC
Created attachment 151332 [details]
Screenshot of text in Times New Roman 12 on LibreOffice Writer
Comment 6 christopher_lee_1_fan 2019-05-13 04:22:04 UTC
Created attachment 151333 [details]
Screenshot of text in Times New Roman 12 on Microsoft Word 2019
Comment 7 christopher_lee_1_fan 2019-05-13 04:22:52 UTC
Created attachment 151334 [details]
Screenshot of text in Times New Roman 25 on LibreOffice Writer
Comment 8 christopher_lee_1_fan 2019-05-13 04:23:19 UTC
Created attachment 151335 [details]
Screenshot of text in Times New Roman 25 on Microsoft Word 2019
Comment 9 christopher_lee_1_fan 2019-05-13 04:23:54 UTC
Created attachment 151336 [details]
Screenshot of text in Times New Roman 100 on LibreOffice Writer
Comment 10 christopher_lee_1_fan 2019-05-13 04:24:22 UTC
Created attachment 151337 [details]
Screenshot of text in Times New Roman 100 on Microsoft Word 2019
Comment 11 christopher_lee_1_fan 2019-05-13 04:33:11 UTC
Created attachment 151338 [details]
Some computer specs
Comment 13 Dieter Praas 2019-06-02 15:01:17 UTC
(In reply to christopher_lee_1_fan from comment #12)
> Links to other reports of the same issue:
> https://bugs.documentfoundation.org/show_bug.cgi?id=122457

Christopher, thank you for reporting thebug. Please explain, why it is not  duplicate of bug 122457. I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' after giving an explanation or change status to RESOLVED DUPLICATE of bug 122457.