Bug Hunting Session
Bug 125284 - Turkish locale ruins LibreOffice Base
Summary: Turkish locale ruins LibreOffice Base
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Database-Firebird-Default
  Show dependency treegraph
 
Reported: 2019-05-14 12:16 UTC by no_more_clouds
Modified: 2019-08-23 20:02 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Firebird embedded db error (18.07 KB, image/png)
2019-05-21 13:02 UTC, no_more_clouds
Details

Note You need to log in before you can comment on or make changes to this bug.
Description no_more_clouds 2019-05-14 12:16:49 UTC
Description:
Hi there,

1-) I have freshly installed Kubuntu 19.04 (which comes with LİbreOffice 6.2.2.2) on my system with US English language pack and everything worked well. 

2-) Then for some reason I tried to update system's language to Turkish and Kubuntu 19.04 downloaded and installed required language pack as it seems. So when I tried to create/open libreoffice database and get this error. No more connection any embeeded firebird database. 
Other parts of LO works well only Base is problematic.

firebird_sdbc error:
*/usr/lib/x86_64-linux-gnu/firebird/3.0/plugins.conf: illegal line <Module = $(dir_plugins)/udr_engine>
caused by
'isc_create_database'

3-) Then I wiped the hard disk and freshly installed Kubuntu 19.04 with Turkish language pack. So I get the same error of above.

4-) I downgraded to Kubuntu 18.04.. same error. Nothing changed. Turkish language pack ruins LibreOffice Base. 

System summary
Kubuntu 19.04
Sürüm: 6.2.2.2
İnşa No: 1:6.2.2-0ubuntu2
İşlemci süreçleri: 4; İşletim Sistemi:Linux 5.0; UI gerçekleyici: varsayılan; VCL: kde5; 
Yerel: tr-TR (tr_TR.UTF-8); Arayüz Dili: tr-TR
Calc: threaded

Steps to Reproduce:
1. Install LO with system (Kubuntu 18.04, 19.04) with Turkish Lang Pack
2. Or install the above systems with US English Lang pack and then try to upgrade/change to Turkish.  

Actual Results:
LO Base doesn't connect to db. Gives error. 

Expected Results:
Should works as per with English Lang Pack


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Roman Kuznetsov 2019-05-15 10:39:53 UTC
Muhammet, may be you can check it?
Comment 2 no_more_clouds 2019-05-21 13:02:26 UTC
Created attachment 151557 [details]
Firebird embedded db error
Comment 3 no_more_clouds 2019-05-21 13:15:01 UTC
Thank you for your inretest about the case.

I have read my post again and found that I should supply more information about the error.

When I attempt to create a new db (embedded firebird, local) LO Base creates the db without error. I can browse the database objects (tables, reports etc.) through the object panel. But when I try to create any table, query or any db object, then the error happens.

Thanks
Comment 4 Alex Thurgood 2019-06-12 15:40:05 UTC
Sounds to me like a problem that is specific to the Ubuntu packages...which would be NOTOURBUG
Comment 5 Xisco Faulí 2019-06-13 13:29:20 UTC
Dear Reporter,
Does it work if you download and install LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
Comment 6 Caolán McNamara 2019-08-23 13:16:58 UTC
Amazingly I can confirm this for our own Fedora packages too. Most odd
Comment 7 Caolán McNamara 2019-08-23 13:19:40 UTC
Ah, its the locale rather than the language pack, which is less startling
Comment 8 Caolán McNamara 2019-08-23 14:41:45 UTC
I think the turkish i takes another victim
Comment 9 Caolán McNamara 2019-08-23 16:25:20 UTC
This seems to only affect the distro builds because the bundled build looks for the config in /usr/local/firebird and its not there, so no attempt to substitute config values is done. (But if I copy my system ones in there, then the same problem exists for the bundled version).

The problem is that the "dir_sampleDb" doesn't match via strncasecmp "DIR_SAMPLEDB" under a Turkish locale because the lowercase of I isn't i, so the subst fails and the whole database creation fails.

https://github.com/FirebirdSQL/firebird/pull/221 is my simple suggestion to get around it, but it needs to be patched firebird side, so distros would have to apply that, or whatever is the final solution, to use system firebird with LibreOffice
Comment 10 Commit Notification 2019-08-23 20:00:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7bc3da4ff0a6fda621340a4ded79f7ed4ce31d85%5E%21

Resolves: tdf#125284 config entries not substituted under Turkish locale

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2019-08-23 20:02:53 UTC
This only affects the --with-system-firebird so it doesn't affect the vanilla builds, just the distro ones. I've stashed a patch above which can be applied to distro firebird to get this to work under a Turkish/Azeri locale