Bug 125339 - Table is deleted after acceding the table
Summary: Table is deleted after acceding the table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected, regression
: 124803 (view as bug list)
Depends on:
Blocks: Database-Tables
  Show dependency treegraph
 
Reported: 2019-05-17 13:16 UTC by Xisco Faulí
Modified: 2019-05-20 09:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-05-17 13:16:46 UTC
Steps to reproduce:
1. Open attachment 138551 [details] from bug 114596
2. Enter the database to Tools > Options > Base > Databases (Name: TestDB)
3. Open the *.odt-file of the folder.
4. Click on later
5. Put data into tho only field for text and press Enter
6. Close the document
7. Open the document again 

-> Error is prompted: There exists no table named 'TestTabelle'. Indeed, the table is gone if we check in the ddbb

Reproduced in

Version: 6.3.0.0.alpha1+
Build ID: 4c2034b808fed4f9dfd715d8a4813e788a7e97a4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-05-17 13:18:04 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=306758ab3e06f7c730bb1625c2f3fcce7a912fa3

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-04-05 15:40:27 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-04-08 11:46:03 +0200
commit	306758ab3e06f7c730bb1625c2f3fcce7a912fa3 (patch)
tree	a677004940b62b90b6df01641189efcceb36978f
parent	e610999b99d14675342649c21f5100e0d12a795c (diff)
tdf#117066 Saving ODT document with ~1500 bookmarks is slow, part 5

Bisected with: bibisect-linux64-6.3

Adding Cc: to Noel Grandin
Comment 2 Xisco Faulí 2019-05-17 13:27:11 UTC
Actually there is an easier way to reproduce the problem:

1. Open the database
2. Go to table
3. Click on Later
-> The table is there. it has 12 entries if open.
4. Close Base
5. Open the ddbb again
6. Go to table
7. Click on later

-> Table is gone or if it's there, it has no entries.
Comment 3 Xisco Faulí 2019-05-17 13:33:19 UTC
*** Bug 124803 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2019-05-19 07:34:20 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e8dc04cb5d5df84955d86d304b2b039551c77ad0%5E%21

tdf#125339 Base, Table is deleted after accessing the table

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2019-05-20 09:15:18 UTC
Verified in

Version: 6.3.0.0.alpha1+
Build ID: 9c7fac47aacb0877c7d212217089a680400c1377
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Noel Grandin, thanks for fixing this issue!!