Bug 125382 - Crash when check a "Personal Letter" on Letter Wizard
Summary: Crash when check a "Personal Letter" on Letter Wizard
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.1
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2019-05-20 08:12 UTC by baffclan
Modified: 2019-06-27 09:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bt Windows (windbg) (47.85 KB, text/plain)
2019-05-20 15:56 UTC, Julien Nabet
Details
bt with debug symbols (gtk3) (43.14 KB, text/plain)
2019-05-23 18:44 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2019-05-20 08:12:47 UTC
Description:
Crash when check a "Personal Letter" on Letter Wizard


Steps to Reproduce:
1. Start LibO 6.3.0.0.alpha1
2. Nenu -> File -> Wizards -> Letter...
3. Appear Letter Wizard Dialog
4. Check Personal Letter


Actual Results:
Crash a LibO.

Expected Results:
No crash a LibO.


Reproducible: Always


User Profile Reset: No



Additional Info:
repro:
Version: 6.3.0.0.alpha1 (x64)
Build ID: 547edd20e527fb02900f6174973770d26306e2e7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded

Version: 6.3.0.0.alpha1+ (x64)
Build ID: 3f5f67c68ae42cd14c08341b597e0331358a0d3f
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-19_01:20:17
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded

no repro:
Version: 6.2.4.2 (x64)
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-05-20 09:10:03 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e18359445fabad9ba1a704600e9ee327112cc6ae

author	Bjoern Michaelsen <bjoern.michaelsen@libreoffice.org>	2019-04-14 13:33:35 +0200
committer	Björn Michaelsen <bjoern.michaelsen@libreoffice.org>	2019-05-05 22:27:54 +0200
commit	e18359445fabad9ba1a704600e9ee327112cc6ae (patch)
tree	62203ab19612761fac0091096c1345190a6fcd19
parent	74ac288132de7046ce25eb4539be6b9a25138399 (diff)
[API CHANGE] SwXTextField: no more SwModify/SwClient
- fix unittest assuming the double-insertion of annotation
  throwing an IllegalArgumentException was intentional
- remove SwModify/SwClient in SwXTextField
- also: add basic C++ api test

Bisected with: bibisect-linux64-6.3

Adding Cc: to Bjoern Michaelsen
Comment 2 Julien Nabet 2019-05-20 15:56:10 UTC
Created attachment 151538 [details]
bt Windows (windbg)

On Win10 with master sources updated today, I could reproduce this.
Comment 3 Julien Nabet 2019-05-23 18:44:24 UTC
Created attachment 151636 [details]
bt with debug symbols (gtk3)

On pc Debian x86-64 with master sources updated today, I could reproduce this too.
Comment 4 Commit Notification 2019-06-26 09:06:45 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/36defda96fc62cef1e1ffb725f6768d54b0d9cd0%5E%21

tdf#125382: Check if pDoc is not null

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-06-26 09:52:35 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/7133af309a810d9caea0cd05cea4f784aac7456b%5E%21

tdf#125382: Check if pDoc is not null

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 baffclan 2019-06-27 09:05:58 UTC
Cannot reproduce with 6.4.0.0.alpha0+ (x64).

Version: 6.4.0.0.alpha0+ (x64)
Build ID: ae823e4633a76d13cebc6432b9e44b9b2862326b
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-26_23:06:07
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded

thanks for fixing this!
Comment 7 Xisco Faulí 2019-06-27 09:08:53 UTC
(In reply to baffclan from comment #6)
> Cannot reproduce with 6.4.0.0.alpha0+ (x64).
> 
> Version: 6.4.0.0.alpha0+ (x64)
> Build ID: ae823e4633a76d13cebc6432b9e44b9b2862326b
> CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-26_23:06:07
> Locale: ja-JP (ja_JP); UI-Language: en-US
> Calc: threaded
> 
> thanks for fixing this!

Thanks for checking.
Setting to VERIFIED!