Download it now!
Bug 125437 - Libreoffice crashes when restarting after setting opencl & restart
Summary: Libreoffice crashes when restarting after setting opencl & restart
Status: RESOLVED DUPLICATE of bug 122846
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OpenCL Options-Dialog
  Show dependency treegraph
 
Reported: 2019-05-21 23:29 UTC by MM
Modified: 2019-05-22 11:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["Dialog::Execute()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MM 2019-05-21 23:29:27 UTC
Description:
LO crashes when restarting after setting opencl on (or off) & press restart after apply.


Steps to Reproduce:
- Start LO
- Goto options > opencl
- Turn opencl on or off, depends whether it's off / on.
- Press 'Apply'
- Press 'Restart now'


Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: Yes



Additional Info:
It only happens when pressing 'apply / restart now' and -not- when pressing 'ok / restart now

Version: 6.2.3.2 (x64)
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 3; OS: Windows 6.1; UI render: GL; VCL: win
Comment 1 Roman Kuznetsov 2019-05-22 10:48:25 UTC
don't repro in

Version: 6.3.0.0.alpha1+
Build ID: 6d6277f23337c8eae9acabdf830e33fcc3ee9923
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

MM, do you have any crash report?
Comment 2 Roman Kuznetsov 2019-05-22 11:11:24 UTC
hm, I can repro in

Версия: 6.2.4.2
ID сборки: 2412653d852ce75f65fbfa83fb7e7b669a126d64
Потоков ЦП: 4; ОС:Windows 6.1; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык UI: ru-RU
Calc: threaded

crashreport.libreoffice.org/stats/crash_details/dc23a536-1a2f-41a4-91b8-e98940b92aee

Xisco, can we find fix for it in master, because I can't repro it in 6.3 now
Comment 3 Xisco Faulí 2019-05-22 11:28:28 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2019-05-22 11:29:23 UTC
(In reply to Xisco Faulí from comment #3)
> only win,
> Can't reproduce it in
> 
> Version: 6.2.5.0.0+
> Build ID: 6c3ceaf3e4d59c658d0f9e4e1b22204be25f74e2
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded

wrong, it's reproducible on linux as well...
Comment 5 Xisco Faulí 2019-05-22 11:42:29 UTC
In Master it got fixed by myself in https://cgit.freedesktop.org/libreoffice/core/commit/?id=e961e08a3277158d4e3074bfacb8599296d2fa75
The problem is that the commit is done on top of https://cgit.freedesktop.org/libreoffice/core/commit/?id=2b6bd096f5bd9d250e4590d7150190086ad282b2 which is not backported to libreoffice-6-2.
We will have to live with it...

*** This bug has been marked as a duplicate of bug 122846 ***