Download it now!
Bug 125458 - TEMPLATES: Useless message when using a specific template
Summary: TEMPLATES: Useless message when using a specific template
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Templates
  Show dependency treegraph
 
Reported: 2019-05-23 11:01 UTC by TorrAB
Modified: 2019-06-04 16:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (85.81 KB, image/png)
2019-05-31 20:41 UTC, TorrAB
Details
screenshot (17.40 KB, image/png)
2019-05-31 20:43 UTC, TorrAB
Details
template (15.08 KB, application/vnd.oasis.opendocument.text-template)
2019-05-31 20:47 UTC, TorrAB
Details
template (18.72 KB, application/vnd.oasis.opendocument.text-template)
2019-05-31 20:50 UTC, TorrAB
Details
template (13.93 KB, application/vnd.oasis.opendocument.text-template)
2019-06-02 13:46 UTC, TorrAB
Details
template (14.00 KB, application/vnd.oasis.opendocument.text-template)
2019-06-02 13:47 UTC, TorrAB
Details
screenshot showing TP depends on Livret (20.10 KB, image/png)
2019-06-04 14:08 UTC, TorrAB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TorrAB 2019-05-23 11:01:51 UTC
Description:
In Writer, get at templates: ~f, n, m (or ^$n); right-click any template, get 'Confirmation: The template has been modified…' Why? I am trying to modify it; just show it 'as is'.


Steps to Reproduce:
1.In Writer, get at templates: ~f, n, m (or ^$n)

2.right-click any template
3.

Actual Results:
get dialogue: 'Confirmation: The template has been modified…'

Expected Results:
I am trying to modify the template; just show it 'as is'.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-05-24 07:06:23 UTC
Hello,
When you get that dialog, is because you are modifying a file which is based on the template. If you want to modify the template itself, do it from the template manager.
Closing as RESOLVED NOTABUG
Comment 2 TorrAB 2019-05-29 19:20:40 UTC
'do it from the template manager'.
	I did: the manager gave me the template list; I right-clicked a template, chose Edit from the popped menu, and… got the (confusing) Confirmation dialogue! (I understand a document is based on a template but… is a template based on itself?)
Comment 3 Xisco Faulí 2019-05-30 10:59:23 UTC
Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 4 TorrAB 2019-05-31 20:41:10 UTC
Created attachment 151818 [details]
screenshot
Comment 5 TorrAB 2019-05-31 20:43:07 UTC
Created attachment 151819 [details]
screenshot
Comment 6 TorrAB 2019-05-31 20:47:40 UTC
Created attachment 151820 [details]
template
Comment 7 TorrAB 2019-05-31 20:50:00 UTC
Created attachment 151821 [details]
template
Comment 8 Dieter 2019-06-01 10:05:38 UTC
I tried to reproduce as follows

1. Save attachment 151820 [details] and attachment 151821 [details]. both templates depend on another template
2. Open Writer
3. Open one of the attachments
4. LO asks to accept change of the underlying template => accept
5. Save document and reopen
6. LO will ask you again

Expected result: shouldn't happen

TorrAB, can you confirm those steps? I haven't tested, if this ocurs only with your template or with every template that depends on another template.
Comment 9 TorrAB 2019-06-02 13:46:06 UTC
Created attachment 151851 [details]
template
Comment 10 TorrAB 2019-06-02 13:47:34 UTC
Created attachment 151852 [details]
template
Comment 11 Dieter 2019-06-02 16:19:28 UTC
I can open templates from comment 9 and 10 without any problems. Since they don't depend on another template, this confirms my assumption from comment 8. 

What do you think, Torr AB?
Comment 12 TorrAB 2019-06-02 22:44:45 UTC
It seems I forgot to send the comment accompanying the last 2 attachments:
	If I try to edit TP.ott (modified 2015-03-23; attached), LO does not ask me to confirm, even though it's based on Livret (attached), which has been modified 2019-02-26. It seems that date checking is inconsistent.
	Anyway, a template, regardless of how it was made —from scratch, a document, or another template —should be an absolute base, independent of any other.
Comment 13 Dieter 2019-06-03 07:06:10 UTC
(In reply to TorrAB from comment #12)
> If I try to edit TP.ott (modified 2015-03-23; attached), LO does not ask me to confirm, even though it's based on Livret (attached)

TP.ott doesn't depend on another template (template entry is empty in File => Properties)
Comment 14 TorrAB 2019-06-04 14:08:01 UTC
Created attachment 151907 [details]
screenshot showing TP depends on Livret
Comment 15 Dieter 2019-06-04 14:20:43 UTC
(In reply to TorrAB from comment #14)
> Created attachment 151907 [details]
> screenshot showing TP depends on Livret

Sorry, I've made a mistake. You're right. So I can confirm your bug report with the specific documents from comment 4 and 5, but I don't know, if this is a general problem => I changed bug summary an set status to NEW (hope you agree)
Comment 16 TorrAB 2019-06-04 16:25:18 UTC
OK. Do we agree that a template, regardless of how it was made —from scratch, a document, or another template —should be an absolute base, independent of any other? If so, no effort should be made to find why the current date checking is faulty, as no date checking is required.