Bug Hunting Session
Bug 125469 - FILEOPEN DOCX Inline images separated by line-break overlap
Summary: FILEOPEN DOCX Inline images separated by line-break overlap
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Images Writer-Page-Break
  Show dependency treegraph
 
Reported: 2019-05-23 20:20 UTC by Richard Sinden
Modified: 2019-06-07 16:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX exhibiting issue (895.97 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-05-23 20:20 UTC, Richard Sinden
Details
MSOffice Rendering (678.59 KB, application/pdf)
2019-05-23 20:20 UTC, Richard Sinden
Details
LibreOffice Rendering (598.90 KB, application/pdf)
2019-05-23 20:21 UTC, Richard Sinden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Sinden 2019-05-23 20:20:08 UTC
Created attachment 151642 [details]
DOCX exhibiting issue

I have a DOCX file that was generated using Telerik's RadFlowDocument library. It contains several pages of images (containing charts) each separated by a line-break, with a page-break at the end of each set of images. This renders without a problem in each version of MS Word (2012 to 2019) that I have tried. 
In LibreOffice, these images all appear overlapped as if the line-break starts the subsequent image a few pixels below the previous one. The page-breaks seem to be completely ignored.
I've attached a DOCX that exhibits the behaviour and PDFs showing MS Office's rendering vs LibreOffice's.
Comment 1 Richard Sinden 2019-05-23 20:20:44 UTC
Created attachment 151643 [details]
MSOffice Rendering
Comment 2 Richard Sinden 2019-05-23 20:21:24 UTC
Created attachment 151644 [details]
LibreOffice Rendering
Comment 3 Dieter Praas 2019-06-07 09:19:57 UTC
I confirm it with

Version: 6.3.0.0.beta1 (x64)
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded

in comparison with MS Word 2016
Comment 4 Dieter Praas 2019-06-07 09:22:38 UTC
No repro with

Version: 6.1.6.3 (x64)
Build-ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL
Comment 5 Xisco FaulĂ­ 2019-06-07 16:35:55 UTC
This is not a regression.
I can reproduce the problem in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

Depending on the zoom level, it's displayed better or worse, but it has never worked as in MSO