Bug 125501 - Several function names not translated in French
Summary: Several function names not translated in French
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-26 12:15 UTC by Jean-Baptiste Faure
Modified: 2019-05-30 15:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2019-05-26 12:15:44 UTC
Description:
FINDB, REPLACEB and SEARCHB function names are not translated in the French localization of LO 6.1 and LO 6.2 while, according to Pootle, French translation of the UI in complete.
So it seems that these three function names have not been tagged as translatable.

Steps to Reproduce:
1.Open Calc with the French UI
2.look at the functions list in the sidebar
3.

Actual Results:
you see FINDB, REPLACEB and SEARCHB 

Expected Results:
something with French words


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Jacques Guilleron 2019-05-27 17:48:59 UTC
Hello Jean-Baptiste,
Sorry for this long absence due to some health concerns.

I reproduce with LO 6.1.0.0.beta2
Build ID: 0f4d2060bc90b4008fbc8e6d9a49ec7eeea60b78
Threads CPU : 2; OS : Windows 6.1; UI Render : GL; 
Locale : fr-FR (fr_FR); Calc: CL 
and
LO 6.3.0.0.alpha1 Build ID: 547edd20e527fb02900f6174973770d26306e2e7
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; VCL: win; 
Locale : fr-FR (fr_FR); Langue IHM : fr-FR
Calc: CL
Changing Locale Shows theses Fonctions translated. I get for example:
	   Italian	Spanish		                German
SEARCH	   CERCA/CERCAB	HALLAR/HALLARB			SUCHEN/SUCHENB
FIND/FINDB TROVA/TROVAB	ENCONTRAR/ENCONTRARB		FINDEN/FINDENB

Jacques
Comment 2 Jean-Baptiste Faure 2019-05-28 07:25:17 UTC
Hello Jacques,

Thank you very much for your feedback. I am very sorry, I should have checked better. FINDB, SEARCHB and REPLACEB were translated as is in French for LO 6.1 and LO 6.2.
Based on translations for FIND, SEARCH and REPLACE, I just changed the translations in TROUVEB, CHERCHEB and REMPLACERB, in 6.1, 6.2 and master.

Best regards. JBF
Comment 3 Xisco Faulí 2019-05-30 11:01:51 UTC
Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.
Comment 4 Jean-Baptiste Faure 2019-05-30 15:27:33 UTC
In fact the bug was on my side: for some reason these function names were kept not translated in Pootle. I have modified the summary accordingly.

Fixed now in Pootle for 6.1, 6.2 and master.

Best regards. JBF