Bug Hunting Session
Bug 125531 - Empty CMIS properties dialog
Summary: Empty CMIS properties dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.4.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicUI
: 126756 (view as bug list)
Depends on:
Blocks: CMIS Dialog
  Show dependency treegraph
 
Reported: 2019-05-27 20:11 UTC by Thorsten Wagner
Modified: 2019-09-15 14:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (33.91 KB, image/png)
2019-05-27 20:11 UTC, Thorsten Wagner
Details
Screenshot of CMIS dialog with right-handed scrollbar (98.68 KB, image/png)
2019-06-01 10:34 UTC, Thorsten Wagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Wagner 2019-05-27 20:11:05 UTC
Description:
Without CMIS properties related dialog within document properties is empty. Only a grabled scrollbar is shown (see screenshot).

Steps to Reproduce:
(1) Open any LO application, e.g. Writer

(2) Open File / Properties dialog and select CMIS properties tab

Actual Results:
An empty dialog with a grabled scrollbar is shown

Expected Results:
A message indicating no CMIS properties is shown, scrollbar is not shown or shown at full height


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Thorsten Wagner 2019-05-27 20:11:27 UTC
Created attachment 151712 [details]
Screenshot
Comment 2 Julien Nabet 2019-05-27 20:18:19 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
=> I put it at NEW.

Xisco/Heiko: is it a bug, an enhancement, ...? Thought it may interest UX people.
Comment 3 Heiko Tietze 2019-05-28 10:58:39 UTC
I'd say enhancement. What bothers me is the small object at top left. Best solution is IMHO to hide CMIS when the document is not stored remotely.
Comment 4 Julien Nabet 2019-05-28 11:45:37 UTC
Code pointer:
https://opengrok.libreoffice.org/xref/core/sfx2/source/dialog/dinfdlg.cxx?r=da92911d#1145

I tried this:
diff --git a/sfx2/source/dialog/dinfdlg.cxx b/sfx2/source/dialog/dinfdlg.cxx
index ec3f57656ab9..87d1adbb1c38 100644
--- a/sfx2/source/dialog/dinfdlg.cxx
+++ b/sfx2/source/dialog/dinfdlg.cxx
@@ -1142,7 +1142,8 @@ SfxDocumentInfoDialog::SfxDocumentInfoDialog( vcl::Window* pParent,
     m_nDocInfoId = AddTabPage("general", SfxDocumentPage::Create);
     AddTabPage("description", SfxDocumentDescPage::Create);
     AddTabPage("customprops", SfxCustomPropertiesPage::Create);
-    AddTabPage("cmisprops", SfxCmisPropertiesPage::Create);
+    if (rInfoItem.GetCmisProperties().hasElements())
+        AddTabPage("cmisprops", SfxCmisPropertiesPage::Create);
     AddTabPage("security", SfxSecurityPage::Create);
 }

+ remove assert here:
diff --git a/sfx2/source/dialog/tabdlg.cxx b/sfx2/source/dialog/tabdlg.cxx
index 79e2ad750ada..bc349c8d9c13 100644
--- a/sfx2/source/dialog/tabdlg.cxx
+++ b/sfx2/source/dialog/tabdlg.cxx
@@ -562,8 +562,6 @@ bool SfxTabDialog::StartExecuteAsync( VclAbstractDialog::AsyncContext &rCtx )
 
 void SfxTabDialog::Start_Impl()
 {
-    assert(m_pImpl->aData.size() == m_pTabCtrl->GetPageCount()
-            && "not all pages registered");
     sal_uInt16 nActPage = m_pTabCtrl->GetPageId( 0 );
 
     // load old settings, when exists

It doesn't work. Cmis tab still appears but you can't select it.
Comment 5 Thorsten Wagner 2019-05-30 22:48:02 UTC
Scroll bar artefact has been replaced by a right handed full size scroll bar. Setting status to resolved / works for me.
Comment 6 Heiko Tietze 2019-06-01 07:39:01 UTC
(In reply to Thorsten Wagner from comment #5)
> Scroll bar artefact has been replaced by a right handed full size scroll
> bar. Setting status to resolved / works for me.

You likely want to resolve bug 101443 and not the CMIS issue. :-)
Comment 7 Thorsten Wagner 2019-06-01 10:33:20 UTC
No, behaviour of CMIS dialog has changed (see screenshot). Please set issue to resolved if this is the intended behaviour.
Comment 8 Thorsten Wagner 2019-06-01 10:34:13 UTC
Created attachment 151825 [details]
Screenshot of CMIS dialog with right-handed scrollbar
Comment 9 Heiko Tietze 2019-06-01 11:19:56 UTC
The scrollbar might be a bit better but it is still pointless to show the tab. And for me the dialog has a tiny but focused control at top left. Better we hide the tab completely.
Comment 10 Thorsten Wagner 2019-06-01 22:38:44 UTC
I totally agree. Furthermore the order of buttons within dialog boxes has changed (see screenshots). Is this behaviour intended?
Comment 11 Xisco Faulí 2019-08-08 11:26:55 UTC
*** Bug 126756 has been marked as a duplicate of this bug. ***
Comment 12 Martin Srebotnjak 2019-08-08 14:11:57 UTC
This is not a desired behaviour, it makes user think something is broken.

Maybe it would be best to make the tab in the tab bar grayed out, non-clickable?

Or, instead of the empty tab/scrollable window display a simple explanation:
To set CMIS properties here, the document must be first shared remotely on the network.
(or something similar)

Probably this is a documentation issue as well, not just UX?
Comment 13 Commit Notification 2019-09-12 21:31:28 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0701a1838280d4fa9c54ca39f1a5297fe4857a16%5E%21

Resolves tdf#125531 - Empty CMIS properties dialog

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-09-15 14:25:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/bcaeebd98a697d6bcf891990c3b13de5da1790e7%5E%21

Related: tdf#125531 use RemoveTabPage for removing a tab page

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.