Bug 125556 - FILEOPEN: URL fragment leaked from one object to another when importing Powerpoint ppt file
Summary: FILEOPEN: URL fragment leaked from one object to another when importing Power...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-05-28 13:58 UTC by Vittal Aithal
Modified: 2019-06-07 16:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A PowerPoint with two links (154.00 KB, application/vnd.ms-powerpoint)
2019-05-28 13:58 UTC, Vittal Aithal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vittal Aithal 2019-05-28 13:58:06 UTC
Created attachment 151743 [details]
A PowerPoint with two links

The attached PowerPoint has two hyperlinks:

The topmost blue box links to "file:///#pdfoverlay-aa-123456-tc"

The "Hyperlink 2" text links to "https://libreoffice.org/"

Opening the file in LibreOffice 6.2.4.2 on Mac and the blue box is linked to "file:///" and the second link is "https://libreoffice.org/#pdfoverlay-aa-123456-tc" - the URL fragment has been moved from the first link to the second link.

Expected behaviour is to do as PowerPoint does and keep the fragment with the link.
Comment 1 Durgapriyanka 2019-05-28 15:34:35 UTC
Thank you for reporting the bug. I can confirm the bug present in 

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

But, I couldn't reproduce the bug in 
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

There is no moment in the URL fragment from the first link to the second link.
Comment 2 Xisco Faulí 2019-06-06 11:27:30 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4245454d0c3d6df2d0e0a75aed6f22f0a26ce3e2

author	Noel Grandin <noel.grandin@collabora.co.uk>	2018-02-28 15:50:29 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2018-03-05 12:44:32 +0100
commit 4245454d0c3d6df2d0e0a75aed6f22f0a26ce3e2 (patch)
tree c7e708889fed58868c9f31fa4fc4bbb6d44171e3
parent 05a195ffca41bc3883627b9503ade8cdd0b6d909 (diff)
loplugin:useuniqueptr in SdrPowerPointImport

Bisected with: bibisect-linux64-6.1

Adding Cc: to Noel Grandin
Comment 3 Commit Notification 2019-06-06 19:18:36 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e6adec29beadb83ebd3941275b99e2dd1be02f61%5E%21

tdf#125556 URL fragment leaked from one object..

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2019-06-06 19:18:48 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/a927744c3ec8e5ed0c3990ae25993e888272eda8%5E%21

tdf#125556 URL fragment leaked from one object..

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-06-07 07:24:42 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3309893de4e99a7d89fb1e9b4616631b1f040df0%5E%21

tdf#125556 URL fragment leaked from one object..

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-06-07 16:19:53 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 6b911ae9eb9484bebbdc1323210020486f5ef33f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Noel Grandin, thanks for fixing this issue!