Bug 125654 - Calc: Unstable font in Calc cells for LO 6.3
Summary: Calc: Unstable font in Calc cells for LO 6.3
Status: RESOLVED DUPLICATE of bug 125054
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-03 11:00 UTC by Lars Jødal
Modified: 2019-06-04 06:24 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Jødal 2019-06-03 11:00:49 UTC
Description:
In the development version 6.3.0.0.Alpha1 of LO Calc, the font in the cells seems to spuriously change between Liberation Serif (not the chosen font) and Liberation Sans (the standard font). It appears that the Serif font is used upon editing, and sometimes but not always changes to the (correct) Sans font at the end of editing.

Steps to Reproduce:
1. Open a new Calc document in LO 6.3
2. Notice the chosen font. Standard is Liberation Sans (no serifs, looks somewhat like the Arial font).
3. Enter something in any cell.

Actual Results:
During entering, the font will be Liberation Serif (with serifs, looks somewhat like Times New Roman). Upon leaving the cell, the cell contents may or may not change font to the correct Liberation Sans. 

Expected Results:
Cell contents should be shown in the chosen font, Liberation Sans.


Reproducible: Always


User Profile Reset: No



Additional Info:
If a cell with text wrongly in font Liberation Serif is chosen, then the menu bar continues showing the font as Liberation Sans. If the content is edited (F2), menu bar changes to showing the actual "Liberation Serif", but only while editing. 

Version: 6.3.0.0.alpha1 (x64)
Build ID: 547edd20e527fb02900f6174973770d26306e2e7
CPU tråde: 4; Styresystem: Windows 10.0; Gengiver af brugergrænseflade: Standard; VCL: win; 
Lokalisering: da-DK (da_DK); Sprog for brugergrænseflade: da-DK
Calc: threaded
Comment 1 Lars Jødal 2019-06-03 11:11:22 UTC
Further finding: The font change seems to depend on the cell contents. Apparently, numbers always gets converted to the correct Liberation Sans font upon leaving the cell. Some texts do get converted, others not. As an example, "meat" remains in Serif font, while "tema" gets converted to Sans.
Comment 2 Ming Hua 2019-06-03 19:28:50 UTC
I believe this is a duplicate of bug 125054, and has already been fixed.

Lars, would you please download the newly released 6.3.0 Beta1 and test again?
Comment 3 Lars Jødal 2019-06-04 06:23:09 UTC

*** This bug has been marked as a duplicate of bug 125054 ***
Comment 4 Lars Jødal 2019-06-04 06:24:25 UTC
Thanks for pointing out the duplicate and the availability of beta1. I can confirm that the bug is solved in LO 6.3.0.0.beta1