Bug Hunting Session
Bug 125670 - Crash in: OutputDevice::InitClipRegion on Slide show
Summary: Crash in: OutputDevice::InitClipRegion on Slide show
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-06-03 19:51 UTC by Laurent BP
Modified: 2019-11-08 10:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["OutputDevice::InitClipRegion"]


Attachments
Test file which crash (302.35 KB, application/vnd.oasis.opendocument.presentation)
2019-06-03 19:51 UTC, Laurent BP
Details
Update version without Master pages (53.78 KB, application/vnd.oasis.opendocument.presentation)
2019-06-03 20:28 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2019-06-03 19:51:03 UTC
Created attachment 151888 [details]
Test file which crash

This bug was filed from the crash reporting server and is br-fde3ca17-ae27-4188-b318-8f18d26545fc.
=========================================

Steps to reproduce
1. Open attached file
2. F5 to launch slide

Actual behavior
Crash

File contains only 1 grouped object, with 3 objects: title, bitmap of chart and a yellow bar
No crash if object is ungrouped.
No crash if color is modified of yellow bar
No crash if one of the 3 sub-object is removed

Crash with:
- Version: 6.0.7.2
Build ID: 78c12ce5f2b8960f18b204a7ea82f971769f1679
Threads CPU : 8; OS : Linux 4.15; UI Render : par défaut; VCL: gtk2; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 1 Laurent BP 2019-06-03 20:28:07 UTC
Created attachment 151889 [details]
Update version without Master pages
Comment 2 Laurent BP 2019-06-03 20:29:10 UTC
Crash with Version: 6.2.4.2
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
Threads CPU : 8; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 3 MM 2019-06-03 22:35:29 UTC
Confirmed on windows 7 x64 with Version: 6.2.4.2 (x64)
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU threads: 3; OS: Windows 6.1; UI render: default; VCL: win

crashreport.libreoffice.org/stats/crash_details/fc4b2310-70ee-4462-aa7c-3563953cec45
Comment 4 Xisco Faulí 2019-06-04 14:48:46 UTC
Reproduced back to

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default;
Comment 5 Xisco Faulí 2019-06-04 15:12:32 UTC
Regression introduced by:

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2015-09-28 12:51:02 +0200
committer	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2015-09-28 17:02:09 +0200
commit	d76c5aa78f0b9004c6719dcc4d2be052c0703ba5 (patch)
tree	2f3c82ebe3fdd4c1ef72155f52154573eaf35055
parent	ac84e4ff6135d51461122e0e1b5b39614b3e6eca (diff)
don't allocate (by eraseing) an un-initialized 1x1 virtual device
Comment 6 Commit Notification 2019-06-06 16:16:32 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/710f3c63af2d8bee7d5e860614145799a3f0e491%5E%21

tdf#125670 just check gradient clipping on drawing

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-06-07 11:11:16 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 6b911ae9eb9484bebbdc1323210020486f5ef33f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Jan-Marek Glogowski, thanks for fixing this issue!!
Comment 8 Jan-Marek Glogowski 2019-06-07 11:13:36 UTC
I see a major slowdown with gtk3 due to this fix, that's why there is currently no backport, as caolan wanted to look into this first.
Comment 9 Xisco Faulí 2019-06-07 11:17:20 UTC
(In reply to Jan-Marek Glogowski from comment #8)
> I see a major slowdown with gtk3 due to this fix, that's why there is
> currently no backport, as caolan wanted to look into this first.

ok, good to know. I haven't seen any slowdown with the version mentioned so far...
Comment 10 Jan-Marek Glogowski 2019-06-07 11:21:38 UTC
(In reply to Xisco Faulí from comment #9)
> (In reply to Jan-Marek Glogowski from comment #8)
> > I see a major slowdown with gtk3 due to this fix, that's why there is
> > currently no backport, as caolan wanted to look into this first.
> 
> ok, good to know. I haven't seen any slowdown with the version mentioned so
> far...

For me startup and shutdown of LO take much longer with the presentation. Just start it from the console and compare kde5. Maybe it's just a local problem.

Same when quitting. But I just have an N5000, so normal HW might not be that affected.
Comment 11 Xisco Faulí 2019-06-07 11:29:32 UTC
Actually I've found another related issue.
If I launch LibreOffice with SAL_USE_VCLPLUGIN=gen all toolbars are grey
Comment 12 Caolán McNamara 2019-06-21 12:23:25 UTC
I don't see a performance difference locally, but does https://gerrit.libreoffice.org/#/c/74505/ make a difference to your startup/shutdown ?
Comment 13 Jan-Marek Glogowski 2019-06-21 14:01:26 UTC
(In reply to Caolán McNamara from comment #12)
> I don't see a performance difference locally, but does
> https://gerrit.libreoffice.org/#/c/74505/ make a difference to your
> startup/shutdown ?

So I tried to reproduce my findings and couldn't. There is a general strange difference for kde5 and gtk3, which I don't understand, as both backends use cairo. For 10 runs of OOO_EXIT_POST_STARTUP with the fix and the attached crash document I get:

* gtk3: avarage real 8.000 user 4.297 sys 0.557
* kde5: avarage real 4.42 user 2.96 sys 1.29

Avarage from the (fixed) script from https://stackoverflow.com/questions/17601539/calculate-the-average-of-several-time-commands-in-linux

My fix: grep "^real" /tmp/mtime.$$ | awk ...
Comment 14 Commit Notification 2019-06-21 14:55:33 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7ba891c85ae06c0806fe2349202da84b50ca6cbd%5E%21

Related: tdf#125670 avoid possible performance issues for the general case

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-06-21 15:01:38 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/6047d537b5ea8f13f7e8d4739621c866af1d13fb%5E%21

tdf#125670 just check gradient clipping on drawing

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-06-21 20:59:53 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/12cf9256fba688df367a2be7db17e0ed3d24c73c%5E%21

tdf#125670 just check gradient clipping on drawing

It will be available in 6.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-06-22 12:26:36 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/24c21375f9983428cabf46407943a2b2daa5a8f0%5E%21

tdf#125670 check graphics before output cliprect

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2019-06-22 13:23:49 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/cb7b343666c75f031093a5ab7f19873f054991d1%5E%21

tdf#125670 check graphics before output cliprect

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2019-06-25 07:52:36 UTC
Verfied again in

Version: 6.4.0.0.alpha0+
Build ID: 52800731baf9fcb88e54d60de5585640c8f97f7b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 20 Commit Notification 2019-06-25 15:20:09 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-5":

https://git.libreoffice.org/core/+/961f487b0ad6160b45bd688078a09b40c9345444%5E%21

tdf#125670 just check gradient clipping on drawing

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.