Bug 125690 - Sort not functional in Base Reports defined with old report designer
Summary: Sort not functional in Base Reports defined with old report designer
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected) release
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on: 58911
  Show dependency treegraph
Reported: 2019-06-04 15:41 UTC by pebro
Modified: 2023-06-07 03:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

sample file (319.24 KB, application/vnd.sun.xml.base)
2019-06-04 15:52 UTC, pebro

Note You need to log in before you can comment on or make changes to this bug.
Description pebro 2019-06-04 15:41:48 UTC
I used OpenOffice in the past, and sorting worked in Base while reporting.
I am currently using LibreOffice. In the file itself, the results are not sorted alphabetically when you make a Report. :(
The previous version of LibreOffice also did not sort (I do not remember the version number).
Sorry, my english is not good.
Po polsku:
Dawniej używałem OpenOffice i w Base podczas robienia raportów działało sortowanie.
Obecnie używam LibreOffice W tam samym pliku podczas robienia Raportu wyniki nie są sortowane alfabetycznie. :(
Wcześniejsza wersja LibreOffice też nie sortowała (nie pamiętam nr wersji).

Steps to Reproduce:

Actual Results:
no sorting

Expected Results:
sorting ;)

Reproducible: Always

User Profile Reset: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: pl
Module: FormDesign
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 pebro 2019-06-04 15:52:45 UTC
Created attachment 151913 [details]
sample file

1. open the file
2. Report (Raporty)
3. _zbiorcze_(nie do druku)
   Report is not sorting, but in OpenOffice was sorting
Comment 2 Alex Thurgood 2019-06-05 12:36:39 UTC
@pebro: how were these reports designed ?

If I try to open the report in Edit mode (right mouse button click on a report name and choose Edit), the Report Designer does not open, instead a Writer document is opened.

Did you use some other report designer tool to make these reports ?
I'm thinking that you used the old non-Java report designer which produced Writer documents instead of an XML definition that is stored in the ODB file.

I have tried so far in LO6152, LO6222, LO6073, with the same results.
Comment 3 Alex Thurgood 2019-06-05 12:43:05 UTC
The old C++ report designer code was removed, leaving only the possibility to read older versions of reports, hence the Writer documents being opened. However, this does not allow one to redefine the report using the report designer tool, or inspect its properties.
Comment 4 pebro 2019-06-05 16:24:25 UTC
Yes, this Report was made in the old OpenOffice program.
I checked, the report has been done correctly again (sorts). It is a pity that LO is not 100% compatible with OO.
Comment 5 QA Administrators 2019-06-06 02:55:25 UTC Comment hidden (obsolete)
Comment 6 Alex Thurgood 2019-06-06 07:49:10 UTC
@pebro : thanks !

I should have been more precise - on Linux, due to the way packaging of the various components is managed by the various distributions, you can still have the old report designer functionality if you don't install the report-builder package (or if you forcibly remove it, if it was installed by default).

However, you can't do this on either macOS or Windows, where the Java report builder code was moved from being an extension to an integrated part of the LibreOffice build release.

This leads to a situation where you can't re-edit previously created reports made with the older report designer code.

Thus, this bug is at least related to bug 58911 and bug 61950.

1) Unfortunately, I am not in a position to test, as macOS doesn't provide for access to the old report designer wizard.

2) It is doubtful that the old legacy code is going to be fixed, even if the bug somehow manages to get confirmed.
Comment 7 Robert Großkopf 2019-06-06 17:56:07 UTC
Have tested this one with LO and AOO 4.1.6 on OpenSUSE 15. 
The report, defined through the legacy-report-engine, isn't shown sorted by the first column in LO
AOO will show this report sorted, but I can't look for the reason, because the whole AOO will crash very often on OpenSUSE 15.

Don't know if this bug will be fixed, if it is created with a module, which isn't implemented for editing this kind of reports in LO any more.
Comment 8 pebro 2019-06-06 18:35:08 UTC
> It is doubtful that the old legacy code is going to be fixed, even if the bug somehow manages to get confirmed.

Alex Thurgood and  Robert Großkopf  thank you for explaining, although it is not satisfying.
Comment 9 Robert Großkopf 2019-06-06 18:46:49 UTC
(In reply to pebro from comment #8)

> Alex Thurgood and  Robert Großkopf  thank you for explaining, although it is
> not satisfying.

Hi pebro,

if you have a version of LO (or AOO) where you are able to edit or create this kind of report try to change the datasource for the report to a view of the data. The data you are using should be sorted through this viel from the database so it will also be sorted in the report, which follows only the datasource, not an internal sorting-order.

... You could also connect me through private mail and I will try to help you to change the reports to reports of the build-in reportbuilder of LO.
Comment 10 QA Administrators 2021-06-06 05:26:12 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2023-06-07 03:13:06 UTC
Dear pebro,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team