Download it now!
Bug 125698 - LibreOffice Writer crash while opening password protected ODT document after update from 6.2.3.2 to 6.2.4.2
Summary: LibreOffice Writer crash while opening password protected ODT document after ...
Status: RESOLVED DUPLICATE of bug 125715
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-05 09:25 UTC by opensuse.lietuviu.kalba
Modified: 2019-06-05 15:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["ld-2.22.so"]


Attachments
dump files in ZIP archive (138.67 KB, application/zip)
2019-06-05 09:25 UTC, opensuse.lietuviu.kalba
Details
ODT document for testing. Password is 123 (12.42 KB, application/vnd.oasis.opendocument.text)
2019-06-05 11:53 UTC, opensuse.lietuviu.kalba
Details
JAVA settings (46.48 KB, image/png)
2019-06-05 12:25 UTC, opensuse.lietuviu.kalba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description opensuse.lietuviu.kalba 2019-06-05 09:25:59 UTC
Created attachment 151922 [details]
dump files in ZIP archive

I have ODT document with password protection. 
After update to LibreOffice 6.2.4.2, I can no longer open this document – LibreOffice Writer crash after entering password.
Removing ~/.config/libreoffice/4 directory does not help.

It worked fine with LibreOffice 6.2.3.2.

I updated LibreOffice from

Versija: 6.2.3.2
Darinio identifikatorius: aecc05fe267cc68dde00352a451aa867b3b546ac
Procesoriaus gijos: 4; OS:Linux 4.4; Sąsajos pateikimas: numatytasis; VCL: kde4; 
Lokalė: lt-LT (lt_LT.UTF-8); UI-Language: lt-LT
Calc: threaded

to

Versija: 6.2.4.2
Darinio identifikatorius: 2412653d852ce75f65fbfa83fb7e7b669a126d64
Procesoriaus gijos: 4; OS:Linux 4.4; Sąsajos pateikimas: numatytasis; VCL: kde4; 
Lokalė: lt-LT (lt_LT.UTF-8); UI-Language: lt-LT
Calc: threaded

both are from LibreOffice site RPM packages.


LibreOffice proposes to send crash report to LibreOffice site but fails to do so. It restarts automatically and crash if I select Writer (Calc start fine) and proposes to send crash report (but fails to do so). Its loop. Seems there is other bug in crash report system. Thus I attach crash DMP files here as ZIP archive.
Comment 1 Xisco Faulí 2019-06-05 10:33:44 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 opensuse.lietuviu.kalba 2019-06-05 11:53:02 UTC
Created attachment 151935 [details]
ODT document for testing. Password is 123

Dokument created with LibreOffice 6.2.3.2, crash if trying to open with LibreOffice 6.2.4.2
Comment 3 opensuse.lietuviu.kalba 2019-06-05 11:59:40 UTC
Presumably crash information is this:
crashreport.libreoffice.org/stats/crash_details/98227944-ba95-4e7f-aac5-9aceb3ce0c9b

(I successed to send after downgrading to LibreOffice 6.2.3.2, though I can reproduce in 6.2.3.2: LibreOffice 6.2.3.2 noticed that there was some reports from previous usage of LibreOffice 6.2.4.2)
Comment 4 opensuse.lietuviu.kalba 2019-06-05 12:07:41 UTC
LibreOffice used /usr/lib64/jvm/jre-1.8.0-openjdk/ 
I can reproduce after deselecting  "Use a Java runtime environment" also.
Comment 5 opensuse.lietuviu.kalba 2019-06-05 12:25:58 UTC
Created attachment 151937 [details]
JAVA settings

Sorry, 6.2.4.2 showed /usr/lib64/jvm/java-1.8.0-openjdk-1.8.0/jre path indeed.
I still can reproduce with /usr/java/jre1.8.0_181-amd64 also.
Comment 6 Xisco Faulí 2019-06-05 14:52:47 UTC
I can't reproduce it in

Versión: 6.2.4.2
Id. de compilación: 2412653d852ce75f65fbfa83fb7e7b669a126d64
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded
Comment 7 Xisco Faulí 2019-06-05 14:56:29 UTC
You're using KDE4, Do you reproduce it if launch LibreOffice from commandline with 'SAL_USE_VCLPLUGIN=gtk3 soffice' ? and what about SAL_USE_VCLPLUGIN=kde5 soffice ?
Comment 8 opensuse.lietuviu.kalba 2019-06-05 15:17:40 UTC
I use KDE 5.8.7 with KF 5.32, Qt 5.6.2.
Somehow this openSUSE Leap 42.3 system selects KDE4 VLC instead of KDE5 automatically.

I CAN reproduce this bug with:
> SAL_USE_VCLPLUGIN=kde5 soffice
/opt/libreoffice6.2/program/soffice.bin: /lib64/libdbus-1.so.3: no version information available (required by /opt/libreoffice6.2/program/libmergedlo.so)
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0xce003be
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0xce003be
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0xce003be
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0xce003be

Crash information is this: 
http://crashreport.libreoffice.org/stats/crash_details/c10f0e37-b50d-4b55-a65c-2eac2da4fc91
Indeed, although I pass "SAL_USE_VCLPLUGIN=kde5", I see "VCL: kde4" in LibreOffice About dialog

The same with:
> SAL_USE_VCLPLUGIN=qt5 soffice                                                                                                                                                                                      
/opt/libreoffice6.2/program/soffice.bin: /lib64/libdbus-1.so.3: no version information available (required by /opt/libreoffice6.2/program/libmergedlo.so)                                                                         
X Error: BadMatch (invalid parameter attributes) 8                                                                                                                                                                                
  Major opcode: 42 (X_SetInputFocus)                                                                                                                                                                                              
  Resource id:  0xce003d6                                                                                                                                                                                                         
X Error: BadMatch (invalid parameter attributes) 8                                                                                                                                                                                
  Major opcode: 42 (X_SetInputFocus)                                                                                                                                                                                              
  Resource id:  0xce003d6                                                                                                                                                                                                         
X Error: BadMatch (invalid parameter attributes) 8                                                                                                                                                                                
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0xce003d6
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0xce003d6

http://crashreport.libreoffice.org/stats/crash_details/0cba4c68-c1db-4335-b869-051cce7ff07c
although I pass "SAL_USE_VCLPLUGIN=qt5", I see "VCL: kde4" in LibreOffice About dialog. Maybe this is because my system is aging (I will soon upgrade to from openSUSE Leap 42.3 to openSUSE Leap 15.1)...


I can NOT reproduce this bug with:
> SAL_USE_VCLPLUGIN=gtk3 soffice
/opt/libreoffice6.2/program/soffice.bin: /lib64/libdbus-1.so.3: no version information available (required by /opt/libreoffice6.2/program/libmergedlo.so)
/opt/libreoffice6.2/program/soffice.bin: /lib64/libdbus-1.so.3: no version information available (required by /opt/libreoffice6.2/program/libmergedlo.so)


P.S. "/opt/libreoffice6.2/program/soffice.bin: /lib64/libdbus-1.so.3: no version information available (required by /opt/libreoffice6.2/program/libmergedlo.so)
" is just warning message.
Comment 9 Xisco Faulí 2019-06-05 15:28:06 UTC
KDE4 support has been dropped in LibreOffice master.
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 10 opensuse.lietuviu.kalba 2019-06-05 15:41:03 UTC
If I force to downgrade only one package – libobasis6.2-kde-integration – 
from 6.2.4.2 to 6.2.3.2 version, I can NOT reproduce bug.
All other LibreOffice packages are for 6.2.4.2.
Comment 11 Xisco Faulí 2019-06-05 15:52:40 UTC
(In reply to opensuse.lietuviu.kalba from comment #10)
> If I force to downgrade only one package – libobasis6.2-kde-integration – 
> from 6.2.4.2 to 6.2.3.2 version, I can NOT reproduce bug.
> All other LibreOffice packages are for 6.2.4.2.

Please, follow this comment: https://bugs.documentfoundation.org/show_bug.cgi?id=125715#c2
Comment 12 Xisco Faulí 2019-06-05 15:56:29 UTC
it seems the root cause is the same as in bug 125715

*** This bug has been marked as a duplicate of bug 125715 ***