Bug 125722 - CTRL+A doesn't affect same parts of a document like CTRL+X
Summary: CTRL+A doesn't affect same parts of a document like CTRL+X
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Form-Controls
  Show dependency treegraph
 
Reported: 2019-06-05 17:37 UTC by Telesto
Modified: 2021-06-29 06:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.95 KB, application/vnd.oasis.opendocument.text)
2019-06-05 17:37 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-06-05 17:37:35 UTC
Description:
Some form items will disappear after cut, but won't be pasted

Steps to Reproduce:
1. Open the attached file
2. Press CTRL+A & CTRL+X
3. CTRL+N & CTRL+V


Actual Results:
Label field & Option button gone

Expected Results:
Label field & option button should be pasted too


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 93477d1a963e38e3319013e43835a8ffef200972
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-02_10:16:52
Locale: it-IT (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Telesto 2019-06-05 17:37:51 UTC
Created attachment 151946 [details]
Example file
Comment 2 Dieter 2019-06-06 06:48:48 UTC
Telesto, I ran some tests. The general rule seems to be: CTRL+A always marks all form controls before the last paragraph mark. So copy and paste seems to work correctly (I assume, that this is the intended behaviour).

So I would change bug summary to: CTRL+A doesn't affect same parts of a document like CTRL+X. Do you agree?

Version: 6.3.0.0.beta1 (x64)
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded
Comment 3 Dieter 2019-07-11 18:00:23 UTC
(In reply to Dieter Praas from comment #2)
> So I would change bug summary to: CTRL+A doesn't affect same parts of a
> document like CTRL+X. Do you agree?

Telesto: Kindly reminder to my question

=> NEEDINFO
Comment 4 Dieter 2021-05-16 17:22:50 UTC Comment hidden (obsolete)
Comment 5 Dieter 2021-05-16 17:23:23 UTC
Telesto, you should know, that you can't confirm your own bugs.
=> UNCONFIRMED
Comment 6 Telesto 2021-05-17 07:05:03 UTC
(In reply to Dieter from comment #5)
> Telesto, you should know, that you can't confirm your own bugs.
> => UNCONFIRMED

I read comment 3 as confirm, but ...
Comment 7 geraldg 2021-06-29 06:23:51 UTC
Hi all,

tested in LO 7.2.0.0.beta1 (Linux KDE neon).
Works well.