Bug 125789 - SHAPE: Can't select shape when I click on it
Summary: SHAPE: Can't select shape when I click on it
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Shapes
  Show dependency treegraph
 
Reported: 2019-06-07 15:54 UTC by Dieter Praas
Modified: 2019-07-26 09:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter Praas 2019-06-07 15:54:40 UTC
Steps to reproduce:

1. Insert shape in a document
2. Click in the shape

Result: Nothing happens
Expected result: I can select it

Behaviour in
Version: 6.3.0.0.beta1 (x64)
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded

But not in
Version: 6.2.4.2 (x64)
Build-ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 1 Xisco Faulí 2019-06-07 16:10:52 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: 6b911ae9eb9484bebbdc1323210020486f5ef33f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

nor in gen. Actually when you insert a shape it's already selected. Deselecting and click on it works as expected...
Comment 2 Xisco Faulí 2019-06-07 16:11:11 UTC
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 3 Aron Budea 2019-06-07 19:14:37 UTC
No repro for me, either.

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 95462a02a3aee1e3e7f9aa8fc50ba25fee3fa592
CPU threads: 4; OS: Windows 6.1; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-03_07:09:38
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 4 Dieter Praas 2019-06-08 06:58:02 UTC
Still the same problem in master

Version: 6.4.0.0.alpha0+ (x64)
Build ID: b170256fb6ebaf774b02b89835b19d9f3a1afb89
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-07_03:30:35
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 5 Julien Nabet 2019-06-08 08:40:23 UTC
Dieter: could you check you got last version of your graphic driver then give a try to OpenGL part of  https://wiki.documentfoundation.org/QA/FirstSteps?
Comment 6 Dieter Praas 2019-06-08 10:37:12 UTC
(In reply to Julien Nabet from comment #5)
> Dieter: could you check you got last version of your graphic driver then
> give a try to OpenGL part of 
> https://wiki.documentfoundation.org/QA/FirstSteps?

Update of graphic driver doesn't solve the problem.
To disable OpenGL doesn't solve the problem

When I select shape using the navigator, selection get's lost when I try to open context menue with right click.
Comment 7 Dieter Praas 2019-07-26 09:02:22 UTC
Corrupted user profile => RESOLVED WORKSFORME