Bug 125808 - A pivot table cannot be created from a registered data source
Summary: A pivot table cannot be created from a registered data source
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.4.1 rc
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords: bibisected, bisected, regression
: 126038 126156 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-06-09 05:46 UTC by pierre-yves samyn
Modified: 2019-06-29 15:55 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2019-06-09 05:46:30 UTC
Description:
When creating pivot table from registered data source you can select the database/type/source but the available fields list empty.

Steps to Reproduce:
1. File> New> Spreadsheet
2. Data> Pivot Table> Create> Data source registered in LibreOffice> Ok
3. Dialog opens, 
4. Select Database: Bibliography> Type: Table> Data source: biblio> Ok
5. Dialog "layout" opens

Actual Results:
Available Fields list empty

Expected Results:
Available Fields list *not* empty


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Reproducible (whether or not OpenGL  enabled) with other user sources (firebird, hsqldb...) on windows 7/64, Windows10, linux mint

Version: 6.2.4.2 (x64)
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; VCL: win; 
Locale : fr-FR (fr_FR); Langue IHM : fr-FR
Calc: threaded


Version: 6.3.0.0.alpha1+ (x64)
Build ID: f5b9590fc06811a9dff550c6998d1d1088507e23
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-05-23_22:33:02
Locale: fr-FR (fr_FR); UI-Language: en-US
Calc: threaded

Also reproduce on Ask FR:

- https://ask.libreoffice.org/fr/question/195028/tableau-croise-dynamique-vide-apres-mise-a-jour-624/?comment=196865#post-id-196865 (the pivot tables made with an earlier version open empty)

- https://ask.libreoffice.org/fr/question/196831/pourquoi-base-ne-renvoie-aucune-donnee-dans-calc/


NOT reproducible (works ok) with 
Version: 6.2.2.2 (x64)
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; VCL: win; 
Locale : fr-FR (fr_FR); Langue IHM : fr-FR
Calc: threaded
Comment 1 tim 2019-06-09 10:25:49 UTC
I have the same problem with Version: 6.2.4.2
Build ID: 1:6.2.4-0ubuntu0.19.04.1
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: x11; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

I have a lot of pivot tables that all worked in 6.2.3.  None now return any data at all from my registered base file. All pivot tables are empty.

This is critical for me so I have had to revert back.
Comment 2 Jacques Guilleron 2019-06-09 13:31:53 UTC
Hi Pierre-Yves,

I reproduce with
LO 6.3.0.0.alpha1 Build ID: 547edd20e527fb02900f6174973770d26306e2e7
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; VCL: win; 
Locale : fr-FR (fr_FR); Langue IHM : fr-FR Calc: CL
and
LO 6.3.0.0.alpha0+ Build ID: f6a64f9bdce16cc18bb086b0de894fba7e1538c3
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-US (fr_FR); UI-Language: en-US Calc: CL
but not with
LO 6.2.0.0.alpha0+ Build ID: 1aa37aa6bee19099b57555a6d839992b054aa405
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-23_10:17:54
Locale: fr-FR (fr_FR); Calc: threaded
I set status to NEW, Keywords to BibisertRequest and regression.

Have a fine day,

Jacques
Comment 3 Oliver Brinzing 2019-06-09 15:04:32 UTC
bisect was not clear (see below), but this may have started with:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/5dfc4fd2af11322dfbface30fd66c1ce553a0703

commit 5dfc4fd2af11322dfbface30fd66c1ce553a0703	[log]
author	Caolán McNamara <caolanm@redhat.com>Thu Apr 11 12:05:07 2019 +0100
committerCaolán McNamara <caolanm@redhat.com>	Thu Apr 11 22:18:01 2019 +0200
tree c3fad34763839cabf487a8e432ede52641737700
parent 86c1b5ff8f66747a3d4cebe6e2e0d1892db9ba9a [diff]

weld ScDbNameDlg

Change-Id: I676909cbb4067ce69d5327403dd25cc80c4cbc4b
Reviewed-on: https://gerrit.libreoffice.org/70593
Tested-by: Jenkins
Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Tested-by: Caolán McNamara <caolanm@redhat.com>

    include/vcl/weld.hxx[diff]
    sc/source/ui/dbgui/dbnamdlg.cxx[diff]
    sc/source/ui/inc/dbnamdlg.hxx[diff]
    sc/source/ui/inc/reffact.hxx[diff]
    sc/source/ui/view/reffact.cxx[diff]
    sc/source/ui/view/tabvwshc.cxx[diff]
    sc/uiconfig/scalc/ui/definedatabaserangedialog.ui[diff]
    solenv/sanitizers/ui/modules/scalc.suppr[diff]
    vcl/source/app/salvtables.cxx[diff]
    vcl/unx/gtk3/gtk3gtkinst.cxx[diff]

10 files changed


/cygdrive/d/sources/bibisect/bibisect-win32-6.3
$ git bisect bad 8fa644f5359d6e64d1a62da93854b1d05de6fcea is the first bad commit
commit 8fa644f5359d6e64d1a62da93854b1d05de6fcea
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Apr 12 10:18:47 2019 -0700

    source sha:74288f5af28de3d14044c951e7e5d62bb2e22301

    source sha:74288f5af28de3d14044c951e7e5d62bb2e22301
    source sha:238cadd315901cbacfd9304bb1205e9f53f13eae
    source sha:9be7991df15da9d4d954eeac1ec342ad1a2b7467

:040000 040000 8aee00d3194f127ea6c44d49fd77fe5c335ede77 98051d196d55092c53e5fbe947f0a841650e43ce M      instdir

/cygdrive/d/sources/bibisect/bibisect-win32-6.3
$ git bisect log
# bad: [372443375a2bb8112bf4ba80227b1eda1e016d62] source sha:5cfac16dbd4af456a7fb6d52c8953c69a72ba2ba
# good: [ea94942caaf195b8d8b2d5c2abb523359ab390e7] source sha:a20a2d7e0d28658f2d9089da076961a599833a28
git bisect start 'master' 'oldest'
# good: [2a07bec0b090e7b40d3bf5f1bead03bdb259e744] source sha:8193e697d286595aa62859011761adeb002244e3
git bisect good 2a07bec0b090e7b40d3bf5f1bead03bdb259e744
# bad: [6438444348ad80162bbcbfafa4702696e88e96cf] source sha:14214e40c06b3b89e9c495c1c6adffbfd294adaa
git bisect bad 6438444348ad80162bbcbfafa4702696e88e96cf
# good: [d65b8c00480c91cc85f323ac78e19bbbaaa8d204] source sha:7331800888122916ca4973052a03412c8bcf088f
git bisect good d65b8c00480c91cc85f323ac78e19bbbaaa8d204
# good: [6c0d54b76e1792b21c3df60876e61405f14edc05] source sha:2e0e7a15f66f5cb55f2a424fae6a9050c2c7f9ca
git bisect good 6c0d54b76e1792b21c3df60876e61405f14edc05
# good: [f5439f41df401333015dd91d3c0407a34a4c58b1] source sha:88e17ec42b60004b95fbe44b4100c83eddbaf4e6
git bisect good f5439f41df401333015dd91d3c0407a34a4c58b1
# good: [eed83818b4c546e621e69438ad2f8977c0e4b2b9] source sha:9575aa3bba055258977d9a013889aa3acbaecb6a
git bisect good eed83818b4c546e621e69438ad2f8977c0e4b2b9
# good: [18c87f8bd48845f018130c9a7eb1838fbbfacc85] source sha:5a816c4241c98b97d464007f25657b946eb29005
git bisect good 18c87f8bd48845f018130c9a7eb1838fbbfacc85
# good: [9800a74383fff2ac48c650489548eac8e16fc27e] source sha:ad7302b5a62bbf382fb7e900cedfa317a4bf57d8
git bisect good 9800a74383fff2ac48c650489548eac8e16fc27e
# bad: [458c062dd5514e5871ebaf01190b0ea38c808666] source sha:3c115ccb0cfc8a474587bf4f35156a68948ec1f5
git bisect bad 458c062dd5514e5871ebaf01190b0ea38c808666
# bad: [60df95a72b8e0b07a1ecb6955732b725292482ba] source sha:9c68b368b51d78baccf31b2c09e992f6595f4ed4
git bisect bad 60df95a72b8e0b07a1ecb6955732b725292482ba
# bad: [7baa7d0628c3ee363f601fa06852194f28a780ac] source sha:735964c39097ff952fcaffee6b35c79e210c019c
git bisect bad 7baa7d0628c3ee363f601fa06852194f28a780ac
# bad: [7aef9ec7dfdc45ce0a93a18818dcd19f11509658] source sha:c498e548ee45430b31cb63df17818ba39771ef7c
git bisect bad 7aef9ec7dfdc45ce0a93a18818dcd19f11509658
# bad: [8fa644f5359d6e64d1a62da93854b1d05de6fcea] source sha:74288f5af28de3d14044c951e7e5d62bb2e22301
git bisect bad 8fa644f5359d6e64d1a62da93854b1d05de6fcea
# first bad commit: [8fa644f5359d6e64d1a62da93854b1d05de6fcea] source sha:74288f5af28de3d14044c951e7e5d62bb2e22301


$ git log 8fa644f5359d6e64d1a62da93854b1d05de6fcea
commit 8fa644f5359d6e64d1a62da93854b1d05de6fcea
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Apr 12 10:18:47 2019 -0700

    source sha:74288f5af28de3d14044c951e7e5d62bb2e22301

    source sha:74288f5af28de3d14044c951e7e5d62bb2e22301
    source sha:238cadd315901cbacfd9304bb1205e9f53f13eae
    source sha:9be7991df15da9d4d954eeac1ec342ad1a2b7467

commit 9800a74383fff2ac48c650489548eac8e16fc27e
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Apr 12 10:15:41 2019 -0700

    source sha:ad7302b5a62bbf382fb7e900cedfa317a4bf57d8

    source sha:ad7302b5a62bbf382fb7e900cedfa317a4bf57d8

commit 3bbc1dfa082283e7a716293365d5de6e20a9a0c7
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Apr 12 09:49:54 2019 -0700

    source sha:5dfc4fd2af11322dfbface30fd66c1ce553a0703

    source sha:5dfc4fd2af11322dfbface30fd66c1ce553a0703

commit 58bf0af912b64cf2b5bec3cf19d7aff56cdbbe52
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Apr 12 09:36:40 2019 -0700

    source sha:86c1b5ff8f66747a3d4cebe6e2e0d1892db9ba9a

    source sha:86c1b5ff8f66747a3d4cebe6e2e0d1892db9ba9a

commit f19b8cc32732436cb3b7c433ec36304bad203fa5
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Apr 12 09:35:34 2019 -0700

    source sha:e74bbefcd7048723b0cf2a3a775e2d84bf171591
Comment 4 Caolán McNamara 2019-06-11 08:41:44 UTC
I think 238cadd315901cbacfd9304bb1205e9f53f13eae "dpcache : use case-insensitive normalization of" is more likely the contender
Comment 5 Caolán McNamara 2019-06-11 08:46:25 UTC
maybe it should have been like https://gerrit.libreoffice.org/#/c/73806/
Comment 6 Commit Notification 2019-06-11 12:12:55 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3a6f6aa7f338c053781a9d19ce8b74d0b3791d03%5E%21

Resolves: tdf#125808 empty labels in pivot table from registered data source

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 tim 2019-06-11 12:23:43 UTC
(In reply to Commit Notification from comment #6)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/+/
> 3a6f6aa7f338c053781a9d19ce8b74d0b3791d03%5E%21
> 
> Resolves: tdf#125808 empty labels in pivot table from registered data source
> 
> It will be available in 6.4.0.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

I would test in a day or 2, but there are no 6.4 version around yet for linux (deb) at present (indeed no new daily versions since the end of May as far as I can tell).

I ran 6.2.3 from here and that was OK. (To get a working ubuntu version I had to go back to 6.2.2, but that's an ubuntu ppa release issue, not a Libreoffice problem.)
Comment 8 Caolán McNamara 2019-06-11 13:15:29 UTC
backports in gerrit to 6-3 and 6-2
Comment 9 tim 2019-06-11 14:12:40 UTC
(In reply to Caolán McNamara from comment #8)
> backports in gerrit to 6-3 and 6-2
Sorry, you'll have to explain that to me.  I am an ordinary user.  What/where is "gerrit"?
Comment 10 Caolán McNamara 2019-06-11 15:32:15 UTC
Its not directed at you, it directed at anyone who might ask, on seeing that this bug is "fixed" for 6.4.0, why it is not fixed in 6.2.X and 6.2.Y and it indicates that the fix has been proposed for those releases within "gerrit" our tool for managing that process (https://gerrit.libreoffice.org) among other things.

Sit tight, there will be other indications added to this bug over the next day or two which will show in what versions the fix will land.
Comment 11 tim 2019-06-11 15:53:01 UTC
(In reply to Caolán McNamara from comment #10)
> Its not directed at you, it directed at anyone who might ask, on seeing that
> this bug is "fixed" for 6.4.0, why it is not fixed in 6.2.X and 6.2.Y and it
> indicates that the fix has been proposed for those releases within "gerrit"
> our tool for managing that process (https://gerrit.libreoffice.org) among
> other things.
> 
> Sit tight, there will be other indications added to this bug over the next
> day or two which will show in what versions the fix will land.
OK - thanks.
Comment 12 Commit Notification 2019-06-11 19:49:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/696084d9dc0f6681a9a5e0fd1ed5143dc90fbdf1%5E%21

Resolves: tdf#125808 empty labels in pivot table from registered data source

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-06-12 07:50:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/6feaa8cab9e63a1f13a5bb272aad992f9a5b58ae%5E%21

Resolves: tdf#125808 empty labels in pivot table from registered data source

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Jacques Guilleron 2019-06-12 12:51:39 UTC
Hi all,

Works as expected with
LO 6.4.0.0.alpha0+ (x86) Build ID: d6ee728dfe2b346217acc5a0d231c7b62e8e61ae
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-12_01:18:12
Locale: fr-FR (fr_FR); UI-Language: en-US Calc: CL

Thank you, Caolán.
Comment 15 tim 2019-06-15 09:40:19 UTC
Works also for me on ubuntu 19.04:

Version: 6.2.5.0.0+
Build ID: 4ca3ac84912ab387b27d3f6c1a288a1ba12eb730
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-06-14_12:10:21
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

Thanks for the quick fix.
Comment 16 Julien Nabet 2019-06-21 13:58:22 UTC
*** Bug 126038 has been marked as a duplicate of this bug. ***
Comment 17 Oliver Brinzing 2019-06-29 15:55:25 UTC
*** Bug 126156 has been marked as a duplicate of this bug. ***