Download it now!
Bug 125816 - The active document should NEVER move, despite toolbars appearing/disappearing
Summary: The active document should NEVER move, despite toolbars appearing/disappearing
Status: RESOLVED DUPLICATE of bug 124835
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-09 20:17 UTC by Octavio Alvarez
Modified: 2019-06-11 21:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Octavio Alvarez 2019-06-09 20:17:36 UTC
Description:
Some toolbars appear and disappear depending on the current context. This makes the active document to jump around (tested under Impress but also seen in Draw).

When tested under a fresh profile the problem is just hidden away because of the default settings, but LibreOffice allows us to show and move toolbars around. I like using the Text Formatting toolbar instead of the side pane, as I find it way more intuitive than the side pane. However, having that toolbar shown makes using Impress extremely frustrating.

The steps to reproduce have been prepared for a use case under a fresh, unmodified setup: the table toolbar.

The quick solution I propose is to prevent toolbars from disappearing when in docked state. A more definitive solution would involve doing the quickfix and then adding a "contextual" toolbar that shows whatever toolbar is appropriate for the current context, but never disappearing.

Steps to Reproduce:
1. Start Impress with a fresh profile.

2. Create a table.

3. Alternate between clicking on the table and clicking outside of the slide but within the workspace.

Actual Results:
The presentation (the slide) jumps. It jumps vertically if the toolbar is horizontally docked or it jumps horizontally if the toolbar is vertically docked.

It is a moving target for my mouse pointer.

Expected Results:
The presentation (the slide) should not jump.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.1.5.2
Build ID: 1:6.1.5-1
CPU threads: 4; OS: Linux 5.1; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group threaded

(I don't know if OpenGL is enabled).
Comment 1 V Stuart Foote 2019-06-09 23:02:28 UTC

*** This bug has been marked as a duplicate of bug 106846 ***
Comment 2 Octavio Alvarez 2019-06-10 03:54:53 UTC
I am setting it back to UNCONFIRMED because this is not a duplicate of bug 106846.

Bug 106846 talks about a specific way of enhancing the current UX regarding context-sensitivity of bars by implementing a new feature.

This issue specifically talks about a bug that exists right now and it should be fixed, as opposed to an enhancement to implement.

My current proposal is a simple fix (granted, a temporary fix) and way different from the new feature requested on 106846. Even if I proposed a definitive proposal, the main idea is the buggy part, not the definitive proposal.

Marking this as a duplicate of an enhancement dismisses the fact that a bug exists and behavior is *currently* broken.

Please verify the bug and acknowledge it so we can mark this issue as NEW.
Comment 3 V Stuart Foote 2019-06-10 05:04:29 UTC
Fine we'll pick the other topic it duplicates--bug 124835

Nothing new here, inherited from OOo...

*** This bug has been marked as a duplicate of bug 124835 ***
Comment 4 Octavio Alvarez 2019-06-11 21:04:04 UTC
(In reply to V Stuart Foote from comment #3)
> Fine we'll pick the other topic it duplicates--bug 124835
> 
> Nothing new here, inherited from OOo...
> 
> *** This bug has been marked as a duplicate of bug 124835 ***

Thank you, much better.