Bug 125829 - Allow display of duplicate contents in a pivot table
Summary: Allow display of duplicate contents in a pivot table
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Pivot-Chart
  Show dependency treegraph
 
Reported: 2019-06-10 12:54 UTC by Markus Elfring
Modified: 2019-09-27 06:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Elfring 2019-06-10 12:54:39 UTC
I have tried the software “LibreOffice Calc 6.2.4.2-821.3” (Build-ID: 20(Build:2)) out again.
I have noticed then that a default formatting is applied where repeated values are omitted from data groups in a pivot table. This group display can occasionally be appropriate.
But if I would like to sort the provided data by the computed metrics (instead of the leading columns), omitted contents are problematic.
Comment 1 m.a.riosv 2019-06-10 22:07:39 UTC
Please provide a sample file, with notes about what you want achieve.
Comment 2 Markus Elfring 2019-06-11 08:37:54 UTC
Which information do you find unclear from my feature request?

Will any pivot table formatting options become better explained?
https://help.libreoffice.org/6.2/en-US/text/scalc/01/12090102.html
Comment 3 Markus Elfring 2019-06-11 09:24:05 UTC
(In reply to m.a.riosv from comment #1)

I suggest to take another look at information sources like the following.

* https://bug-attachments.documentfoundation.org/attachment.cgi?id=111856

* Cannot repeat items labels on a pivot table
  https://bugs.documentfoundation.org/show_bug.cgi?id=87972

* https://wiki.documentfoundation.org/ReleaseNotes/5.0#Calc

* https://help.libreoffice.org/6.2/en-US/text/scalc/01/12090106.html


Can the display of a repeated item “label” be occasionally triggered also by clicking on a context menu entry for a specific data group?
Comment 4 Xisco Faulí 2019-08-06 14:43:19 UTC
Thank you for reporting the bug.
Unfortunately without clear steps to reproduce it, we cannot track down the origin of the problem.
Please provide a clearer set of step-by-step instructions on how to reproduce the problem.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the steps are provided
Comment 5 Markus Elfring 2019-08-06 14:59:00 UTC
(In reply to Xisco Faulí from comment #4)

Why do you find the situation still unclear after it was explained already in previous information sources?
Comment 6 Xisco Faulí 2019-08-06 15:01:49 UTC
a file ( asked for in comment 1 ) and the steps to reproduce it are still missing.
Comment 7 Markus Elfring 2019-08-06 15:04:37 UTC
(In reply to Xisco Faulí from comment #6)

The linked information sources contain expected data, don't they?
Comment 8 Buovjaga 2019-08-18 11:28:40 UTC
(In reply to Markus Elfring from comment #7)
> (In reply to Xisco Faulí from comment #6)
> 
> The linked information sources contain expected data, don't they?

Markus: in several reports, you have repeatedly refused to provide things that are asked for you. Instead, you reply with questions, evading the core of the topic. Do you respect the work of the quality assurance team? If yes, you have to help us, when we make requests. We are not on some bureaucratic power trip. We genuinely need you to respond in order to move forward.
Comment 9 Markus Elfring 2019-08-18 12:32:22 UTC
(In reply to Buovjaga from comment #8)

Please read previous release notes once more.
https://wiki.documentfoundation.org/ReleaseNotes/5.0#Calc
Comment 10 QA Administrators 2019-08-19 07:09:24 UTC Comment hidden (obsolete)
Comment 11 Thomas Lendo 2019-08-20 21:47:18 UTC
Markus, most people writing here are working in their free time and are volunteers. The QA team want to ensure that bug reports have all the information that is necessary for developers to understand what's going an and what is desired.

When writing a bug report please do so as if the reader of your report has no deep knowledge about what you are saying. For this also the 'steps to reproduce' are necessary (1. Open Calc, 2. Open the attached file/create a table with xyz and so on) with a clear statement what the actual behavior is and what the behavior should be. These steps are important too to verify an implemented feature if it's fixed or only partially fixed or not.

Also linking other webpages instead of writing information here in the report isn't perfect as webpages can change or vanish and then the bug report isn't fully understandable in some years.

If you want a better product, please answer the questions. Otherwise there is no chance to fix anything. Our free time is precious like yours and we don't want loose time with questions over questions and you don't want be frustrated with people that don't fully understand.
Comment 12 Xisco Faulí 2019-09-26 10:44:39 UTC
Putting to NEEDINFO until a file is provided.
Comment 13 Markus Elfring 2019-09-26 10:51:14 UTC
(In reply to Xisco Faulí from comment #12)

Do you still miss any information from previous release notes (and available bug reports)?
https://wiki.documentfoundation.org/ReleaseNotes/5.0#Calc
Comment 14 Xisco Faulí 2019-09-26 11:02:34 UTC
(In reply to Markus Elfring from comment #13)
> (In reply to Xisco Faulí from comment #12)
> 
> Do you still miss any information from previous release notes (and available
> bug reports)?
> https://wiki.documentfoundation.org/ReleaseNotes/5.0#Calc

Please, read comment 11
Comment 15 Markus Elfring 2019-09-26 11:20:17 UTC
(In reply to Xisco Faulí from comment #14)

Please take contents from provided links better into account.
Comment 16 Xisco Faulí 2019-09-26 11:26:22 UTC
(In reply to Markus Elfring from comment #15)
> (In reply to Xisco Faulí from comment #14)
> 
> Please take contents from provided links better into account.

we can keep it like this forever...
The request from our side is clear since comment 1 < Please provide a sample file, with notes about what you want achieve. >, until the file is provided, no further actions will be taken in this report...
Comment 17 Markus Elfring 2019-09-26 11:30:08 UTC
(In reply to Xisco Faulí from comment #16)

> Please provide a sample file, with notes about what you want achieve.

These data are already provided by the referenced information sources.
Why does it seem to be so hard to notice this also for my clarification attempt?
Comment 18 QA Administrators 2019-09-27 03:05:28 UTC Comment hidden (obsolete)
Comment 19 m.a.riosv 2019-09-27 06:39:15 UTC
More simple, closed, no more time to lose for nothing.