Download it now!
Bug 125838 - add ability to merge textboxes and content into one: editing PDF imports
Summary: add ability to merge textboxes and content into one: editing PDF imports
Status: RESOLVED DUPLICATE of bug 32249
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-10 18:25 UTC by Justin L
Modified: 2019-06-21 18:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Bertha-G1-TG-Sample.pdf: example pdf where many textboxes could be combined. (1.19 MB, application/pdf)
2019-06-10 18:25 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2019-06-10 18:25:05 UTC
Created attachment 152083 [details]
Bertha-G1-TG-Sample.pdf: example pdf where many textboxes could be combined.

For working with publisher files in LibreOffice, the formatting is preserved much better when importing a PDF rather than a .PUB file. The main drawback, however, is that each line of a paragraph is imported as a separate text box. This makes any editing nearly impossible.

Currently you can choose multiple boxes, then right click and choose "Shapes > Combine" or "Shapes > Merge" but that turns them into a non-editable image / graphic box and loses the ability to edit the text. What is requested however is to combine the text boxes and keep it editable.

There are some OOo/AOO feature requests that ask for a button to merge multiple text boxes:
http://www.openoffice.org/issues/show_bug.cgi?id=59551
http://bz.apache.org/ooo/show_bug.cgi?id=95387

Here is a workaround from the apache bug report above that uses a macro to combine the text boxes into one text box: https://ask.libreoffice.org/en/question/178518/get-selected-text-boxes-and-combine-into-one/?answer=178571#post-id-178571
Comment 1 Justin L 2019-06-21 18:29:39 UTC

*** This bug has been marked as a duplicate of bug 32249 ***