Bug 125935 - UI: Format -> Page Style -> Header/Footer -> Edit -> Title: Click-twice should close the drop down list
Summary: UI: Format -> Page Style -> Header/Footer -> Edit -> Title: Click-twice shoul...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Linux (All)
: medium trivial
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.0.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: GTK3 Page-Style-Dialog
  Show dependency treegraph
 
Reported: 2019-06-15 10:25 UTC by Kevin Suo
Modified: 2019-06-25 15:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2019-06-15 10:25:56 UTC
Steps to Reproduce:
1. Go to Format -> Page Style -> Header/Footer -> Edit -> Title.
2. Click twice on the drop-down list.

Current Result:
The first click opens the drop-down list, but the second click does not close it.

Expected Result:
The second click close the drop-down list.

Version: 6.3.0.0.alpha0+
Build ID:23338100720a76420e302f02b876b3708a95cdda
CPU 线程:4; 操作系统:Linux 4.18; UI 渲染:默认; VCL: gtk3; 
Locale: zh-CN (zh_CN.UTF-8); UI-Language: zh-CN
Calc: threaded

and the current master.
Comment 1 Roman Kuznetsov 2019-06-15 21:08:02 UTC
don't repro in

Version: 6.4.0.0.alpha0+
Build ID: 427e292e93c95d9c2bd009b429fc62798454bbaa
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Kevin can you update your LibreOffice to 6.3 beta1, reset user profile and try retest it?
Comment 2 Kevin Suo 2019-06-16 00:21:17 UTC
(In reply to Roman Kuznetsov from comment #1)
As I said, the most recent version I reproduce is yesterday's master build, and the earliest version I tested is 6.3.0 alpha+.

By the way, I am using Ubuntu 18.04 LTS.
Comment 3 raal 2019-06-16 08:18:21 UTC
Confirm with Version: 6.4.0.0.alpha0+
Build ID: ee4823e16e5fece068ee123b9c3e29834cd38763
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 4 raal 2019-06-16 08:23:12 UTC
It works with SAL_USE_VCLPLUGIN=gen , adding Caolán to cc
Comment 5 Kevin Suo 2019-06-17 05:38:05 UTC
Bibisected using the bibisect-linux-64-6.3 repo:

97a795f466be47b790bc66dc940d989143aa2b2f is the first bad commit
commit 97a795f466be47b790bc66dc940d989143aa2b2f
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Apr 9 00:54:46 2019 +0200

    source sha:319c0b2433bb8dd405ed1630dd464ed2b11afefb

commit 319c0b2433bb8dd405ed1630dd464ed2b11afefb
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Mon Apr 8 12:29:04 2019 +0100

    weld calc header/footer dialog

------

$ git bisect log
# bad: [7658d1b86471d0ff3eb802ac99ccf7b3528fee0b] source sha:64faea31f7d05e46fe5c91f87381ec7abae90174
# good: [cbe79d197e743d9c38dd1c13c781212e7834bfab] source sha:a20a2d7e0d28658f2d9089da076961a599833a28
git bisect start 'master' 'oldest'
# good: [20fb89d87555df6fffd460ef70898c001ba74f0c] source sha:e5e1eca721ec35d51c41985e3020909ab956bdc5
git bisect good 20fb89d87555df6fffd460ef70898c001ba74f0c
# good: [64ce88e7e7cf253cda2815e6c47cedb8803d6cc0] source sha:5355f0d691cdefcebec25a555344d5cd78605c71
git bisect good 64ce88e7e7cf253cda2815e6c47cedb8803d6cc0
# bad: [e4a86389cedf390a8608aab41af65ad51717aeeb] source sha:98272c886b9f7df1670f4ba38d951fc5937a8e89
git bisect bad e4a86389cedf390a8608aab41af65ad51717aeeb
# good: [c2bb72c13adbcf0a5ccd3dae62588462f06ac86f] source sha:9e772cffcf373620114f005993c56c38e7ac84f2
git bisect good c2bb72c13adbcf0a5ccd3dae62588462f06ac86f
# bad: [5b3140c0738c0d3dc3d7e2e4d29eaed8a208afcc] source sha:3d7a67cdd465956206f881304bbcbaf47ccfcd83
git bisect bad 5b3140c0738c0d3dc3d7e2e4d29eaed8a208afcc
# good: [41a42b6bd6d79315efde13ec6e66dd3082694710] source sha:817e3447053d1a7465a5cf547b4eb39fc46b4d59
git bisect good 41a42b6bd6d79315efde13ec6e66dd3082694710
# bad: [930e5f465c95a66cca84fbc6d8ecea7e7629a8e6] source sha:23dc2e99b433f63992fee76555ae321edb5104a3
git bisect bad 930e5f465c95a66cca84fbc6d8ecea7e7629a8e6
# good: [6ecf72338294870c3cf604c3153e7b09a5e09747] source sha:766425e2c58a00480feb3e30d9114df50a8e03a1
git bisect good 6ecf72338294870c3cf604c3153e7b09a5e09747
# good: [9510ad69aeaa2f590af38ab9c2f991f18b3b981d] source sha:2fb6e8365c6792422c10c56e2c976b781c194b77
git bisect good 9510ad69aeaa2f590af38ab9c2f991f18b3b981d
# bad: [708d52a6013cd508f9d1abbcab98ef2d9bcf9319] source sha:a496096b4ecc4ffb45bc7dc25753c970bf5ca487
git bisect bad 708d52a6013cd508f9d1abbcab98ef2d9bcf9319
# bad: [d16c4d65bbd492abbd1f7fa8a4ebddf89d5a8d93] source sha:de8ea47ecdaa33934e47a6ee9bfa742698311534
git bisect bad d16c4d65bbd492abbd1f7fa8a4ebddf89d5a8d93
# bad: [120622f2b7f9312862e5cce83efb45c7cd59a54e] source sha:623d7a94a57860b0b227e6ebad6d0d3fcaf11333
git bisect bad 120622f2b7f9312862e5cce83efb45c7cd59a54e
# bad: [97a795f466be47b790bc66dc940d989143aa2b2f] source sha:319c0b2433bb8dd405ed1630dd464ed2b11afefb
git bisect bad 97a795f466be47b790bc66dc940d989143aa2b2f
# first bad commit: [97a795f466be47b790bc66dc940d989143aa2b2f] source sha:319c0b2433bb8dd405ed1630dd464ed2b11afefb
Comment 6 Caolán McNamara 2019-06-17 10:38:31 UTC
I have no problem in my version (gtk3-3.24.8) but I do see that the menubutton doesn't have can.focus set like it should, perhaps that's also causing the problem described here
Comment 7 Caolán McNamara 2019-06-17 10:39:03 UTC
https://gerrit.libreoffice.org/#/c/74156/
Comment 8 Commit Notification 2019-06-17 13:05:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/bb6333fb1ef0c360e87d90924a2540c96acbd504%5E%21

Related: tdf#125935 allow focus in MenuButton

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-06-17 13:06:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/766175aac45abc3f4807311bd0b4d505c46d1295%5E%21

Related: tdf#125935 allow focus in MenuButton

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2019-06-17 13:08:14 UTC
Does that make a difference ?
Comment 11 Kevin Suo 2019-06-20 02:30:02 UTC
(In reply to Caolán McNamara from comment #10)

No, the bug still exists in:
版本: 6.4.0.0.alpha0+
Build ID: 1e6dec4b4313212a3bdc6bb06155fd65e795368b
CPU 线程: 4; 操作系统: Linux 4.18; UI 渲染: 默认; VCL: gtk3; 
区域语言: zh-CN (zh_CN.UTF-8); UI-Language: zh-CN
Calc: threaded
Comment 12 Caolán McNamara 2019-06-20 08:21:54 UTC
in writer, tools->chapter numbering, there is a button "Load/Save" which is similar to this button, does that one have the same problem for you ?
Comment 13 Kevin Suo 2019-06-20 11:10:35 UTC
(In reply to Caolán McNamara from comment #12)

No, that one in Writer works with no problem.
Comment 14 Kevin Suo 2019-06-20 11:11:36 UTC
(In reply to Caolán McNamara from comment #12)

What else can I do to debug this issue? Does a dbg-util version help?
Comment 15 Caolán McNamara 2019-06-20 13:43:01 UTC
I wonder if the tooltip is causing a problem there
Comment 16 Caolán McNamara 2019-06-21 09:31:32 UTC
Installed Ubuntu 18.04 in a vm and it seems the problem is because the menu pops down and the button is near the end of the notebook page, if it pops upwards the problem doesn't happen
Comment 17 Commit Notification 2019-06-21 11:00:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/91420d722f841e9f3bd98fe7a654ad597b8a2711%5E%21

Resolves: tdf#125935 open menu at bottom of page upwards

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2019-06-21 11:00:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ed69cf9c90fb70fb3c997cc33adbfc4d9e21702b%5E%21

Resolves: tdf#125935 open menu at bottom of page upwards

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2019-06-25 15:19:48 UTC
@Kevin Suo, could you please double check this issue is fix for you in a master build ?