Bug Hunting Session
Bug 125966 - LO 6.2.4.2 crashes upon startup
Summary: LO 6.2.4.2 crashes upon startup
Status: RESOLVED DUPLICATE of bug 126351
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-17 13:12 UTC by Orly
Modified: 2019-08-09 11:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Orly 2019-06-17 13:12:45 UTC
Description:
CentOS 7 (Linux 3.10.0-957.21.2.el7.x86_64) on Lenovo IdeaPad U410 with KDE 4.14.18

LibreOffice 6.2.3.2 was OK.

After updating to 6.2.4.2, LO wouldn't start anymore.All I got was the splash logo bouncing (KDE), then nothing.
To make sure, I uninstalled that version, re-downloaded 6.2.4.2 (with the french help and language packs) and re-installed it afresh... only to get the same result.
Removing (de-installing) 6.2.4.2 then installing 6.2.3.2 got me back to a working LO.
All installs where from rpm using yum.


Steps to Reproduce:
1. Remove previous version or update
2. Start LibreOffice
3.

Actual Results:
Crashed. soffice.bin at 710 (dmesg).
See backtrace.log in additional information below.

Expected Results:
LibreOffice would open...


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
warning: Currently logging to gdbtrace.log.  Turn the logging off and on to make the new setting effective.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Detaching after fork from child process 6754.

Program received signal SIGSEGV, Segmentation fault.
0x0000000000000710 in ?? ()
#0  0x0000000000000710 in ?? ()
#1  0x00007ffff7dea8f3 in _dl_init_internal () from /lib64/ld-linux-x86-64.so.2
#2  0x00007ffff7def4ce in dl_open_worker () from /lib64/ld-linux-x86-64.so.2
#3  0x00007ffff7dea704 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#4  0x00007ffff7deeabb in _dl_open () from /lib64/ld-linux-x86-64.so.2
#5  0x00007ffff2004eeb in dlopen_doit () from /lib64/libdl.so.2
#6  0x00007ffff7dea704 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#7  0x00007ffff20054ed in _dlerror_run () from /lib64/libdl.so.2
#8  0x00007ffff2004f81 in dlopen@@GLIBC_2.2.5 () from /lib64/libdl.so.2
#9  0x00007ffff37d8e73 in osl_loadModule () from /opt/libreoffice6.2/program/libuno_sal.so.3
#10 0x00007ffff37b65ac in osl_loadModuleRelative () from /opt/libreoffice6.2/program/libuno_sal.so.3
#11 0x00007ffff67ef9d8 in ?? () from /opt/libreoffice6.2/program/libmergedlo.so
#12 0x00007ffff67efd0e in ?? () from /opt/libreoffice6.2/program/libmergedlo.so
#13 0x00007ffff676f0ef in InitVCL() () from /opt/libreoffice6.2/program/libmergedlo.so
#14 0x00007ffff6770c15 in ImplSVMain() () from /opt/libreoffice6.2/program/libmergedlo.so
#15 0x00007ffff574c2c5 in soffice_main () from /opt/libreoffice6.2/program/libmergedlo.so
#16 0x000000000040070b in ?? ()
#17 0x00007ffff33f43d5 in __libc_start_main () from /lib64/libc.so.6
#18 0x000000000040073f in ?? ()

Thread 1 (Thread 0x7ffff7fabac0 (LWP 6750)):
#0  0x0000000000000710 in ?? ()
#1  0x00007ffff7dea8f3 in _dl_init_internal () from /lib64/ld-linux-x86-64.so.2
#2  0x00007ffff7def4ce in dl_open_worker () from /lib64/ld-linux-x86-64.so.2
#3  0x00007ffff7dea704 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#4  0x00007ffff7deeabb in _dl_open () from /lib64/ld-linux-x86-64.so.2
#5  0x00007ffff2004eeb in dlopen_doit () from /lib64/libdl.so.2
#6  0x00007ffff7dea704 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#7  0x00007ffff20054ed in _dlerror_run () from /lib64/libdl.so.2
#8  0x00007ffff2004f81 in dlopen@@GLIBC_2.2.5 () from /lib64/libdl.so.2
#9  0x00007ffff37d8e73 in osl_loadModule () from /opt/libreoffice6.2/program/libuno_sal.so.3
#10 0x00007ffff37b65ac in osl_loadModuleRelative () from /opt/libreoffice6.2/program/libuno_sal.so.3
#11 0x00007ffff67ef9d8 in ?? () from /opt/libreoffice6.2/program/libmergedlo.so
#12 0x00007ffff67efd0e in ?? () from /opt/libreoffice6.2/program/libmergedlo.so
#13 0x00007ffff676f0ef in InitVCL() () from /opt/libreoffice6.2/program/libmergedlo.so
#14 0x00007ffff6770c15 in ImplSVMain() () from /opt/libreoffice6.2/program/libmergedlo.so
#15 0x00007ffff574c2c5 in soffice_main () from /opt/libreoffice6.2/program/libmergedlo.so
#16 0x000000000040070b in ?? ()
#17 0x00007ffff33f43d5 in __libc_start_main () from /lib64/libc.so.6
#18 0x000000000040073f in ?? ()
A debugging session is active.

	Inferior 1 [process 6750] will be killed.

Quit anyway? (y or n) [answered Y; input not from terminal]
Comment 1 Julien Nabet 2019-06-17 14:50:50 UTC
Could you give a try to https://wiki.documentfoundation.org/QA/FirstSteps ?
Comment 2 Julien Nabet 2019-06-17 17:52:02 UTC
Orly: please comment directly on bugtracker by using this link:
https://bugs.documentfoundation.org/show_bug.cgi?id=125966#

About your remark perhaps a module installed in 6.2.3 doesn't work on 6.2.4.
As I indicated, it's just a test.
- rename your LO profile
- try to start LO
-> if it works, there's something in the profile which causes this.
-> if it doesn't work, you can remove the brand new LO profile which will be automatically created by LO and can rename your old LO profile in its former name.
Comment 3 Orly 2019-06-17 23:36:18 UTC
OK.

I did follow https://wiki.documentfoundation.org/QA/FirstSteps.

I did a "parallel installation", modifying "bootstraprc" as described (defining UserInstallation=$ORIGIN/..). Just to be double sure, I also changed the name of my (previous, standard location) user profile. As a further simplification, I didn't install either a language pack or a helppack.

I started LibreOffice by invoking ./soffice from the appropriate directory in an xterm terminal, as indicated in the aforementioned document.

Same problem. Crash after splashscreen.

./soffice --safe-mode

Ditto.    :(

Here is what I get in dmesg:
"[80448.533280] soffice.bin[18927]: segfault at 710 ip 0000000000000710 sp 00007fff52be0b68 error 14 in soffice.bin[400000+1000]"
I already submitted the result of a backtrace.

I did this parallel install twice: once as root and once as a normal user.

I now two versions of LO on my system: a (working) 6.2.3.2 and two (segfaulting) 6.2.4.2. Re-running 6.2.3.2 recreated the user profile in it's standard location. 6.2.4.2 crashes before even creating a user profile.

If of interest: under 6.2.3.2 I can see "UI Render: default"
Comment 4 QA Administrators 2019-06-18 02:48:27 UTC Comment hidden (obsolete)
Comment 5 Orly 2019-06-18 15:36:30 UTC
Curiously, I installed (in parallel) 6.3.0_beta1 and launched it (./soffice in an xterm) and it worked!
Comment 6 Julien Nabet 2019-06-18 15:46:37 UTC
So perhaps a bug in 6.2 branch which has been fixed in 6.3 branch.
So you should stick to 6.2.3 for the moment unless you want to use beta 6.3.0
Comment 7 Louis Wust 2019-06-28 03:32:33 UTC
For what it's worth, I am experiencing the same issue with the same traceback. This is on RHEL 7.6 (kernel 3.10.0-957.21.3.el7.x86_64) on a Dell Precision T3620 with both GNOME 3.28.0 and the system-provided KDE, which is a mix of 4.10.5, 4.11.19, and 4.14.8. I am using the English help and language packs.
Comment 8 Xisco Faulí 2019-08-09 11:49:21 UTC
I believe this is a dupe of bug 126351 and it should be fixed in LibreOffice 6.2.6.2 and 6.3.0.4

*** This bug has been marked as a duplicate of bug 126351 ***