Bug Hunting Session
Bug 125979 - Export to .eps file format work, but unable to open
Summary: Export to .eps file format work, but unable to open
Status: RESOLVED DUPLICATE of bug 62051
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Images-EPS
  Show dependency treegraph
 
Reported: 2019-06-18 09:03 UTC by seven
Modified: 2019-10-13 17:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample origin (8.92 KB, application/vnd.oasis.opendocument.graphics)
2019-06-18 09:03 UTC, seven
Details
sample destination (made export in libreoffice) (4.96 KB, application/postscript)
2019-06-18 09:04 UTC, seven
Details

Note You need to log in before you can comment on or make changes to this bug.
Description seven 2019-06-18 09:03:07 UTC
Description:
Libreoffice can export, but can`t open it is bug or not exist feature.

Steps to Reproduce:
1. Open .odg and .eps files to compare

Actual Results:
If libreoffice support open .eps it must show correct document and objects in it. If not - must show object in document with test "object not support or can`t show correctly"

Expected Results:
If libreoffice support open .eps it must show correct document and objects in it. if not i hope sometime it will be implement


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 seven 2019-06-18 09:03:31 UTC
Created attachment 152265 [details]
sample origin
Comment 2 seven 2019-06-18 09:04:01 UTC
Created attachment 152266 [details]
sample destination (made export in libreoffice)
Comment 3 Tomaz Vajngerl 2019-06-21 02:22:26 UTC
I don't think we'll ever support eps reading, it's just a horrible format and a reason that pdf exists. PostScript is actually a language, which means we would need a language parser and interpreter just to read and draw the damn thing. To make it editable is pretty much out of the question.
Comment 4 seven 2019-06-23 08:29:23 UTC
Ok. I think need close this ticket

I think in feature if somebody want release this function may be need converter to pdf or other format to open in libreoffice draw by using module like this: https://www.ghostscript.com/
Comment 5 V Stuart Foote 2019-10-13 17:18:33 UTC
Reviewing meta.xml of attachment 152265 [details] 'sample origin' shows OP is on MS Windows with 64-bit build of LO 6.2.4.2

As noted in bug 62051 on Windows some set [1] of helper files are needed to import EPS images--at a minimum GhostScript and Imagemagik for working with EPS as raster; and pstoedit to work with vector (but need the paid version for full resolution rendering).

Users of Windows builds need to take care of these helpers if they want/need to work with EPS graphics.

The see also bug 67464 details project effort to implement our own native ps/eps handling.

As a side note: when exporting to EPS from Draw, you'll have cleaner handling if you select portion of the graphic rather than exporting the full drawing canvas. Then check the 'Selection' box on the Export dialog.

=-ref-=
[1] https://bugs.documentfoundation.org/show_bug.cgi?id=62051#c8

*** This bug has been marked as a duplicate of bug 62051 ***