Download it now!
Bug 126016 - falla en la ayuda de la estructura función "SI" al usar paréntesis en la zona de valor si verdadero
Summary: falla en la ayuda de la estructura función "SI" al usar paréntesis en la zona...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-19 22:11 UTC by jhon
Modified: 2019-06-21 11:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The test file. (10.50 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-06-21 11:06 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jhon 2019-06-19 22:11:10 UTC
Description:
si anido alguna función comparativa como "Y" o la función "O"o "XOR" como condición lógica en la función "si", y si abro un paréntesis en el valor "si verdadero", vuelve a entrar en la función de comparación, la fórmula funciona, pero se visualiza como si estuviera dentro de la función comparativa, probé con las funciones "Y" "O" "XOR", no he probado con otras funciones pero asumo tienen el mismo problema

Steps to Reproduce:
1.escribir por ejemplo esta función =si(y(a1>0,b1>0),(10*20),"")
2.al dar click dentro de (10*20) que debería ser la zona de "si verdadero" en la estructura de la fórmula aparece como si estuviera dentro de la función "Y"
3.el funcionamiento está bien de la fórmula, pero la ayuda o la estructura que aparece a modo de ayuda es como si estuviese dentro de la función "Y"

Actual Results:
el funcionamiento está bien de la fórmula, pero la ayuda o la estructura aparece como si estuviese dentro de la función "Y"

Expected Results:
si uso paréntesis en "valor si verdadero" a pesar de usar paréntesis debería mantenerse en esa parte de la estructura de  la función "si", no debería aparecer de nuevo la función "Y" porque ya está cerrada


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: es
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Julien Nabet 2019-06-20 18:54:31 UTC
Google translate (I don't know if it's accurate or not).
Description:
if I nest some comparative function like "Y" or the function "O" or "XOR" as a logical condition in the "if" function, and if I open a parenthesis in the value "if true", it re-enters the comparison function , the formula works, but it is visualized as if it were inside the comparative function, I tried with the functions "Y" "O" "XOR", I have not tried with other functions but I assume they have the same problem

Steps to reproduce:
1.write for example this function = yes (y (a1> 0, b1> 0), (10 * 20), "")
2. When clicking within (10 * 20) what should be the "if true" zone in the structure of the formula appears as if it were inside the "Y" function
3. The operation is fine of the formula, but the help or the structure that appears as a help is as if it were inside the "Y" function

Actual Results:
the operation is fine of the formula, but the help or structure appears as if it were inside the "Y" function

Expected Results:
If I use parentheses in "value if true" despite using parentheses it should be kept in that part of the structure of the "yes" function, the "Y" function should not appear again because it is already closed


5.2.7 is EOL, could you give a try to a recent LO version (6.2.4)?
Also, could you explain in English for the next time.
Comment 2 Jacques Guilleron 2019-06-21 11:06:18 UTC
Created attachment 152335 [details]
The test file.
Comment 3 Jacques Guilleron 2019-06-21 11:12:56 UTC
Hi jhon, Julien,

"Y", "O" are the "AND" and "OR" functions.
This is not obvious at first glance to read that, ahd this cannot be translated. That's why you have to write your report in English. 
So, you have written: =SI(Y(A1>0,B2>0),(10*20),"") in English
=IF(AND(A1>0,B2>0),(10*20),"")
To work, you have to change all the "," by ";"
=SI(Y(A1>0B2>0),(10*20),"") in Eglish 
=IF(AND(A1>0;B1>0);(10*20);"")
See the small attachment.

Jacques