Bug 126108 - WMF: Pattern fills are displayed as solid black
Summary: WMF: Pattern fills are displayed as solid black
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2019-06-26 10:12 UTC by Xisco Faulí
Modified: 2019-06-26 20:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-06-26 10:12:48 UTC
Steps to reproduce:
1. Open attachment 49139 [details] from bug 39256

-> Pattern fills are displayed as solid black. See https://bug-attachments.documentfoundation.org/attachment.cgi?id=49146 for comparison

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: fe855eda54faf6196ad9dea12d8dc090b6d6c1da
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 1 Bartosz 2019-06-26 20:16:25 UTC
The main issue is lack of pattern support (see also "Basic Fill Patterns" rectangles.
In "Background Color" and "Transparency" objects, there are pattern with stripes.
As pattern are not implemented whole rectangle is treated as solid object. 
For "Background Color" first color (color of stripes) is red and for "Transparency" it is black.
After implementing pattern support, it should work properly