Bug Hunting Session
Bug 126117 - No way to delete bad AutoComplete Words in Calc
Summary: No way to delete bad AutoComplete Words in Calc
Status: RESOLVED DUPLICATE of bug 46949
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2019-06-26 15:41 UTC by Doug
Modified: 2019-10-18 15:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Autocomplete dialog (41.12 KB, image/png)
2019-10-14 10:05 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doug 2019-06-26 15:41:55 UTC
Description:
You need to add the ability to delete or change bad entries in the AutoComplete list on Calc.

I have a location in one of my columns that has two bad entries in the word list.
Every time I try to type that location, the first entry in the list is wrong
so I have to keep using the drop down list to choose the second entry.

The programs should be consistent. I can fix a word in Writer, I should be able to do it in Calc too.

Right now the only thing I can do to stop this hassle is turn AutoComplete off
which slows down productivity even more.

Actual Results:
Type a word

Expected Results:
A bad entry from the autocomplete list


Reproducible: Always


User Profile Reset: No



Additional Info:
Allow me to delete that bad entry
Comment 1 Thomas Lendo 2019-10-11 11:01:20 UTC
This is true that the 'Word Completion' settings are missing in the AutoCorrect options in Calc and it would be the best to also have them in Calc as it's in Writer. But I don't know how this is possible technically.

Maybe this is duplicate of bug 46949.

Adding needsUXEval to have further input from UX team.
Comment 2 Heiko Tietze 2019-10-14 10:05:40 UTC
Created attachment 154991 [details]
Autocomplete dialog

What exactly is missing? You can enter new terms and you can delete it. 

(Always in favor of duplicates. And in general I agree with same to similar features across modules.)
Comment 3 Thomas Lendo 2019-10-14 10:38:10 UTC
Heiko, I'm talking about the Word Completion tab, not the Replace tab.
Comment 4 Heiko Tietze 2019-10-15 09:24:10 UTC
I cannot reproduce the issue with 6.2.7.1/stable.

I type in Writer "Lorem ipsum dolores estimus" and get these words in the word completion tab of the auto correction dialog. Now I can type "Lore" and complete per tab (or whatever I've set as shortcut). But I don't get a suggestion in Calc when typing "Lore". There is no "word completion" tab in the dialog, there is no effective completion of words, likely no list and ultimately no deletion possible (and needed). Could you please explain the workflow, Doug.

off-topic: For some reason word completion doesn't work in my self-build master; guess I omit some needed libraries.
Comment 5 Doug 2019-10-15 18:28:19 UTC
I don't quite understand why certain functions are not universally available  across all the modules. 

Spell Check, Auto Complete, et.....
With the same abilities in each module.
If I can delete a bad complete entry in Writer, I should be able to do it in Calc too.

Generalized code libraries of these functions could solve the issue.

and no, I have not looked at the source code to see the overall design.
But as a user, it seems like each module has been created and coded independently with no common ground.

The same would apply for the common general functions like print, sort,
Query, et.....

I started this thread because I had no way to delete bad entries in the Calc
Quick Entry.  I am dyslexic do I have things I need to fix. OFTEN.

On a side note: Until it is possible to import all Microsoft file types
into this product, it will  never become a 100% alternative.

I don't want to work in the Microsoft cloud. So I want to be able to import my Access .MDB databases and move forward. Instead of having to try to get Access 2000 to work with Windows 10. Which I did achieve after several hiccups. 

Is Libre going to become Great? Or will it just remain slightly better than Open Office.
Comment 6 QA Administrators 2019-10-16 02:31:15 UTC Comment hidden (obsolete)
Comment 7 Heiko Tietze 2019-10-16 08:23:05 UTC
(In reply to Doug from comment #5)
> I don't quite understand why certain functions are not universally available
> across all the modules. 

Absolute right, we continuously improve in this regards.
 
> If I can delete a bad complete entry in Writer, I should be able to do it in
> Calc too.

Yes, but if word completion isn't working at all you don't need to manage the list of words to complete. Maybe I'm wrong and you were able to get to completion to work. So my question is: What is working for you and how did you manage it?
Comment 8 Doug 2019-10-16 13:31:41 UTC
My goodness you folks need to learn to read and comprehend.

I never said word completion was not working in Calc. It works fine.

What I said was, in Calc, you can't go in and delete bad entries it is trying to complete with. In Writer you can!

Example:

I write an address that is supposed to have Apple.

I had previously typed in Appl and Apple

Word complete keeps putting in Appl unless I use the drop down and
choose the correct Apple.  

In Writer, I could go in and delete Appl, In Calc I can't.

With a common list available in all appropriate modules with a common delete ability this would NOT BE AN ISSUE. Plus it would cut down on code bloat
to call a common code library and list from multiple modules.
Comment 9 Timur 2019-10-16 14:02:05 UTC
A duplicate of Bug 46949.

*** This bug has been marked as a duplicate of bug 46949 ***
Comment 10 Heiko Tietze 2019-10-17 10:24:12 UTC
Tools > Auto Input suggests previously entered text from the same column. It's not  the same as word completion in Writer.
Comment 11 Doug 2019-10-17 16:49:04 UTC Comment hidden (abusive)
Comment 12 Eike Rathke 2019-10-17 17:48:59 UTC
(In reply to Doug from comment #11)
Please calm down and behave. Heiko made a valid point in that the Calc auto-completion list of entries within the same column is a different thing than the word completion feature in Writer and completely unrelated.
Comment 13 V Stuart Foote 2019-10-17 18:00:00 UTC
Doug -- ease up dude! Heiko, who chairs our UX-advise committee, is an expert in user interface design puts a tremendous amount of effort into LibreOffice. He is not dumb and is definitely 'not a troll'.

Folks often don't understand the distinction being made here as AutoInput completion in Calc is a spreadsheet function (performed by an 'sc' module editengine) its scope is the currently selected sheet column. 

It makes no use of the AutoCorrection lists which _are_ implemented as common code cross modules--you use that in the Writer module.

Bug 46949 was opened to develop UI to manipulate the AutoInput list. Which of course can actually be manipulated now--by correcting the entries in the column. That is when the offending entry is removed--it is removed from the AutoInput processing.

But, in a large gnarly sheet--visual scanning of rows is cumbersome. Providing a GUI for selection/editing and possibly bulk correction of AutoInput strings in current column would improve work flows. But it would be new feature development.

This is correctly resolved a duplicate.
Comment 14 Doug 2019-10-17 18:15:22 UTC
This is exactly the point I have tried to make.

Two modules with two different functions doing similar tasks is bad coding.

Auto correct should be one of many universal functions. 

Or if Auto Input is going to be the separate norm for Calc, then it needs a way
to edit bad entries. 

It only works on a per column basis?  Again, bad coding.
That demands a list for each column which is wasteful.

Sound like Libre inherited a lot of poorly thought out code from Open Office.
One of the major deficiencies of GNU projects.
Comment 15 V Stuart Foote 2019-10-17 20:23:37 UTC
(In reply to Doug from comment #14)
> It only works on a per column basis?  Again, bad coding.
> That demands a list for each column which is wasteful.
> 

Uh, Doug -- that is _exactly_ the way Microsoft Excel implements Auto Input completion, by the active columns. Except MS screws it up and the Auto Input breaks when there are empty cells intervening on the column--the column cells have to be contiguous to continue Auto Input from above cells.

> Sound like Libre inherited a lot of poorly thought out code from Open Office.
> One of the major deficiencies of GNU projects.

Don't know that I'd go that far--there were some pretty functional things worked out to implement an ODF compliant office suite for OpenOffice. And, most of us respect that legacy--moving LibreOffice forward in ways that make sense.

Frankly conflating a Calc spreadsheet field input aid--AutoInput-- with our general autocorrection mechanism (which handles string replacements and now Emoji entry) would not make much sense.
Comment 16 Doug 2019-10-17 23:27:58 UTC Comment hidden (no-value)
Comment 17 Eike Rathke 2019-10-18 15:54:55 UTC
(In reply to Doug from comment #14)
> Or if Auto Input is going to be the separate norm for Calc, then it needs a
> way
> to edit bad entries. 
The way to edit bad entries in Calc's column auto-completion is to edit the entry in the cell where it is pulled from.