Download it now!
Bug 126185 - Calc Hangs Opening the Attached XLSX File
Summary: Calc Hangs Opening the Attached XLSX File
Status: RESOLVED DUPLICATE of bug 105036
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx, perf
Depends on:
Blocks: XLSX
  Show dependency treegraph
 
Reported: 2019-07-02 02:42 UTC by Kevin Suo
Modified: 2020-10-12 06:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test xlsx file (87.32 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-07-02 02:42 UTC, Kevin Suo
Details
perf flamegraph (288.45 KB, application/x-bzip)
2020-10-10 15:31 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2019-07-02 02:42:19 UTC
Created attachment 152496 [details]
test xlsx file

Steps to Reproduce:
1. Open the attached xlsx file in Calc

Current Result:
Hang

Expected:
No hang.

版本: 6.2.5.1
Build ID: 9a940173fab1747f02322bc89779759d52b3a086
CPU 线程: 4; 操作系统: Linux 5.1; UI 渲染: 默认; VCL: gtk3; 
区域语言: zh-CN (zh_CN.UTF-8); UI 语言: zh-CN
Calc: threaded

fedora 30 x64
Comment 1 Mike Kaganski 2019-07-02 03:23:00 UTC
Couldn't repro with Version: 6.2.5.2 (x64)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

(although it took some time to open)
Comment 2 Julien Nabet 2019-07-02 07:57:52 UTC
On Win10 with master sources updated some days ago, the file is very long to open.
+ I noticed a lot of these:
warn:svx.uno:1556:9480:svx/source/unodraw/unoshape.cxx:1625: Unknown Property: GraphicColorMode

+ even when opened it takes several seconds to just select a cell.

There's indeed a pb here.
Comment 3 Kevin Suo 2019-07-02 08:04:00 UTC
(In reply to Julien Nabet from comment #2)
This file is a real-world document from my daily work. I cleared all the cell data, so the document is empty, but due to unknown reason, this file contains a lot of shapes in it.

Excel can open this document in one second.
Comment 4 Kevin Suo 2020-10-10 10:15:58 UTC
The interesting thing is, I DO NOT reproduce this on master build which is compiled on Fedora 32 by myself. However, I DO reproduce with the build which was compiled on Fedora 30 some time ago. Also, I DO reproduce with 6.4.6 release.
Comment 5 Julien Nabet 2020-10-10 15:31:18 UTC
Created attachment 166254 [details]
perf flamegraph

Here's a Flamegraph retrieved on pc Debian x86-64 with master sources updated today + gen rendering.
Comment 6 Timur 2020-10-12 06:51:26 UTC
Windows LO 6.2.8 very slow to open or hangs, I didn't wait so long, so repro (I change OS to All)
Windows and Linux LO 7.1+ somewhat slow to open, which is expected due to many AutoShapes, so no repro for hang, repro for perf. 

XLSX is small but looking inside it has large drawing.xml of 9 MB which makes this bug a possible duplicate of bug 105036.
I'lll mark so. If someone has better explanation, please do and set New.

(Note there was a bug with shapes in LO, so if this XLSX was once saved in LO, it would make bug invalid. Shapes need to be deleted.)

*** This bug has been marked as a duplicate of bug 105036 ***
Comment 7 Timur 2020-10-12 06:55:16 UTC
Let me add also this: I don't see a point of "meta XLSX" which says nothing, except it sends many mails. 
AFAIK, we have filter:xlsx.
Meta should be used only for specific similar bugs that need to be connected if pattern is recognized.