Download it now!
Bug 126199 - Screen goes black during slideshow on Raspberry Pi
Summary: Screen goes black during slideshow on Raspberry Pi
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-02 16:47 UTC by rptr
Modified: 2019-12-03 10:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (148.62 KB, application/vnd.oasis.opendocument.presentation)
2019-07-03 16:04 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rptr 2019-07-02 16:47:56 UTC
Description:
When displaying some ODP presentations on my Pi, I get a black screen. I suspect it might be due to my LCD screen, but I can't be sure since I have only one screen available at the moment.

Here is one of the files which are currently completely black for me, I made it myself: https://github.com/LibreOffice/libresign/blob/master/presentations/test.odp

Steps to Reproduce:
1. Install Arch Linux ARM on e.g. Raspberry Pi
2. pacman -S libreoffice-fresh
3. Start LibreOffice and open the provided file
4. Start slideshow
5. On some (always the same one) slides, you get a black screen.

Actual Results:
There's a black screen!

Expected Results:
There shouldn't be a black screen!


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Julien Nabet 2019-07-02 17:24:09 UTC
On pc Debian x86-64 with master sources updated today, I got an error when trying to open test.odp.

Throwing InvalidHeaderException
Throwing InvalidHeaderException
WPSDocument::isFileFormatSupported()
warn:oox.storage:29694:29694:oox/source/helper/zipstorage.cxx:67: ZipStorage::ZipStorage exception opening input storage com.sun.star.io.IOException
Throwing InvalidHeaderException
WPSDocument::isFileFormatSupported()
Throwing InvalidHeaderException
AbiDocument::isFileFormatSupported
Comment 2 Julien Nabet 2019-07-02 17:25:17 UTC
The odp seems corrupted since trying to unzip it gives:
Archive:  test.zip
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of test.zip or
        test.zip.zip, and cannot find test.zip.ZIP, period.
Comment 3 rptr 2019-07-02 19:01:10 UTC
That's extremely odd. I will try to open the file myself on my system installation (debian testing) and git build. I believe I made it on the Pi (6.2.4-1).

Using unzip on the Pi doesn't give me any errors.

On my laptop (debian testing again):

rpj@boswell:~/Downloads$ unzip test.odp -d test
Archive:  test.odp
 extracting: test/mimetype           
 extracting: test/Thumbnails/thumbnail.png  
  inflating: test/styles.xml         
  inflating: test/settings.xml       
   creating: test/Configurations2/accelerator/
   creating: test/Configurations2/progressbar/
   creating: test/Configurations2/popupmenu/
   creating: test/Configurations2/statusbar/
   creating: test/Configurations2/toolpanel/
   creating: test/Configurations2/menubar/
   creating: test/Configurations2/floater/
   creating: test/Configurations2/images/Bitmaps/
   creating: test/Configurations2/toolbar/
 extracting: test/Pictures/100000000000055600000300BB0EE136FA0CFB63.png  
  inflating: test/content.xml        
  inflating: test/meta.xml           
  inflating: test/META-INF/manifest.xml
Comment 4 rptr 2019-07-02 19:02:11 UTC
It also opens alright on my installation (6.1.5.2).
Comment 5 Julien Nabet 2019-07-02 19:04:57 UTC
I also got Debian testing updated today (x86-64)
Linux debianamd 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5 (2019-06-19) x86_64 GNU/Linux

julien@debianamd:/tmp/jul$ unzip test.odp -d test
Archive:  test.odp
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of test.odp or
        test.odp.zip, and cannot find test.odp.ZIP, period.

julien@debianamd:~$ unzip --v
UnZip 6.00 of 20 April 2009, by Debian. Original by Info-ZIP.

With LO Debian testing package 6.1.5.2, I also got the error.
Comment 6 Julien Nabet 2019-07-03 07:11:09 UTC
Let's put this one to ASSIGNED since you assigned yourself.
Comment 7 Xisco Faulí 2019-07-03 16:04:54 UTC
Created attachment 152541 [details]
sample file
Comment 8 Xisco Faulí 2019-07-03 16:10:29 UTC
The presentation doesn't go full screen for me

Versión: 6.2.4.2
Id. de compilación: 2412653d852ce75f65fbfa83fb7e7b669a126d64
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

something is wrong with that file...
Comment 9 Xisco Faulí 2019-07-03 16:14:27 UTC
Same in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

I don't think this is a problem on raspberry but a general one...
Comment 10 rptr 2019-07-03 19:23:36 UTC
(In reply to Xisco Faulí from comment #8)
> The presentation doesn't go full screen for me

That's because it's set to window mode in settings, apparently. I didn't notice that until now, not sure why I saved it as such.

Slide Show > Slide Show Settings > Presentation Mode > Full screen [x]

File still is okay for me.
Comment 11 Thorsten Behrens (CIB) 2019-07-04 19:00:45 UTC
No repro on the described setup (Pi3, Arch, 6.1.6.3, with the attached file).

Neither in fullscreen, nor in windowed mode. VCL plug is gtk3, in case that could be a difference.
Comment 12 Xisco Faulí 2019-12-03 10:30:04 UTC
Dear rptr,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.