Download it now!
Bug 126212 - Remote file access
Summary: Remote file access
Status: RESOLVED DUPLICATE of bug 101630
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-03 13:42 UTC by kvoz123
Modified: 2019-07-04 04:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kvoz123 2019-07-03 13:42:35 UTC
Description:
I am using LibreOffice (6.1.3.2, 6.2.4) that has the "remote files" dialogue with GoogleDrive as a supported service. After entering my Google credentials, it asks me on "6 digits PIN code" (manual has mentioned API v2), so, where can I find this code for my GoogleDrive?

Steps to Reproduce:
1. Open Libreoffice
2. Open "remote files" dialogue
3. Add service and select "GoogleDrive" with filled credentials
4. You will see the dialogue, asking to enter "6 digits PIN code"

Actual Results:
I couldn't find any "PIN" in my GoogleDrive ==> I couldn't enter it ==> I couldn't access the content of my GoogleDrive


Expected Results:
Opened acces to my GoogleDrive


Reproducible: Always


User Profile Reset: Yes



Additional Info:
It should show me the content of GoogleDrive and I should be able select the one of my files for editing.
Comment 1 Oliver Brinzing 2019-07-03 17:08:19 UTC
i think this issue is a duplicate of:
Bug 101630 - Google Drive two-factor authentication (2FA) not working again

*** This bug has been marked as a duplicate of bug 101630 ***
Comment 2 kvoz123 2019-07-04 04:48:49 UTC
An answer from Google support:

I understand that you are inquiring about a 6 digit PIN code required to access Google Drive with LibreOffice. I am sorry that this is causing confusion, but I am glad that you emailed us immediately so we can clarify it right away.

To clarify,  we don't generate 6 digit code for LibreOffice. Based on my research I found out that this is an already known issue with LibreOffice.

Here are some articles from LibreOffice that might resolve the issue:

    Google Drive doesn't send SMS codes
    LibreOffice access to Google Drive asks for authentication 6-digit pin