Bug 126215 - Page borders not showing in Draw v6.2.4 on MacOS
Summary: Page borders not showing in Draw v6.2.4 on MacOS
Status: RESOLVED DUPLICATE of bug 121241
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-03 15:26 UTC by aiki_1000
Modified: 2019-07-03 15:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot A - missing page border/boundary rectangle (v6.2.4.2; MacOS Mojave) (52.21 KB, image/png)
2019-07-03 15:30 UTC, aiki_1000
Details
Screenshot B - Page border/boundary rectangle visible (v.6.0.5.2; MacOS Sierra) (52.11 KB, image/png)
2019-07-03 15:34 UTC, aiki_1000
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aiki_1000 2019-07-03 15:26:51 UTC
Description:
In Draw 6.2.4.2 (MacOS) there is a cosmetic issue where the printable page boundary rectangle is not displayed on either existing documents or new documents.  The page boundary/border rectangle is normally shown in the normal document view and in other views such as the Master View.  The grid is shown correctly, but not the page boundary.

It is not clear in exactly which version this issue appeared, but on one MacOS (Sierra) machine running 6.1.5.2 the display operated correctly and on the same machine with 6.2.4.2 it has the observed problem.

I will attach two files showing the errored screenshot (A) and the correct screenshot(B).

This error report follows an ask.libreoffice.org question: 
  https://ask.libreoffice.org/en/question/199838/page-borders-not-showing-in-draw-v624/

Steps to Reproduce:
1. Open Libreoffice application
2. Create a new Draw file (or open an existing one)
3. Look for the bounding box that indicates the edge of the printable page region.

Actual Results:
In the failing version of LO (at least 6.2.4.2 but possibly earlier) this bounding rectangle is missing. 

Expected Results:
In versions of LibreOffice up to and including 6.1.5.2 this bounding rectangle is present.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 aiki_1000 2019-07-03 15:30:45 UTC
Created attachment 152539 [details]
Screenshot A - missing page border/boundary rectangle (v6.2.4.2; MacOS Mojave)

This shows the display with missing rectangle for the printable area page boundary.
Comment 2 aiki_1000 2019-07-03 15:34:04 UTC
Created attachment 152540 [details]
Screenshot B - Page border/boundary rectangle visible (v.6.0.5.2; MacOS Sierra)

This screenshot shows the expected correct display for previous versions (up to and including v6.1.5.2), with the page boundary rectangle shown as expected.
Comment 3 Xisco Faulí 2019-07-03 15:45:58 UTC
Thanks for reporting this issue.
This is a duplicate of bug 121241 and it's fixed in LibreOffice 6.2.5.2 due to be released tomorrow.

*** This bug has been marked as a duplicate of bug 121241 ***