Bug 126267 - [VIEWING] Incorrect rendering of SVG image while in normal mode but not in slideshow mode
Summary: [VIEWING] Incorrect rendering of SVG image while in normal mode but not in sl...
Status: RESOLVED DUPLICATE of bug 128088
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:svg, regression
Depends on:
Blocks:
 
Reported: 2019-07-07 14:31 UTC by zigazou
Modified: 2019-12-19 08:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The files showing the problem (6.02 MB, application/zip)
2019-07-07 14:31 UTC, zigazou
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zigazou 2019-07-07 14:31:51 UTC
Created attachment 152619 [details]
The files showing the problem

Hi !

My SVG image is incorrectly rendered when it is shown in normal view.

When the image is rendered in slideshow mode, it is correctly rendered.
It is also correctly rendered when exporting to PDF.

The bug-affichage.zip file contains the following files:

- bug-affichage.odp, a 1 slide file
- rendu-vue-normal.png, what it looks like in normal mode on my computer
- rendu-vue-slideshow.png, what it looks like in slideshow mode on my computer
- schema.svg, the original SVG file created with Inkscape.

In normal mode, the lens misses the circle and the cells have bigger frames (the grid looks bolder).

Hope it helps!
Comment 1 William Gathoye 2019-07-09 08:27:39 UTC
I can confirm the issue.
The bug is present as well for 6.3.
Comment 2 Roman Kuznetsov 2019-12-18 07:04:15 UTC
no problem in

Version: 6.5.0.0.alpha0+ (x64)
Build ID: ff566c67d67e96c97bcf4064b39df6998733c84e
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Can you update your LibreOffice to 6.3.4 version and retest your problem?
Comment 3 zigazou 2019-12-18 18:33:45 UTC
(In reply to Roman Kuznetsov from comment #2)
> no problem in
> 
> Version: 6.5.0.0.alpha0+ (x64)
> Build ID: ff566c67d67e96c97bcf4064b39df6998733c84e
> CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
> Locale: ru-RU (ru_RU); UI-Language: en-US
> Calc: threaded
> 
> Can you update your LibreOffice to 6.3.4 version and retest your problem?

It does not work for me on 6.3.4.2 and 6.4.0.0.beta1.

Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.0.0.beta1
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-12-19 08:45:55 UTC
I can't reproduce it in

Version: 6.5.0.0.alpha0+
Build ID: fb1eac64df88baae9f211d052793773686c0e180
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-12-19 08:47:35 UTC
oh, after re-reading the description, I can reproduce it, the problem is the lens misses the circle
Comment 6 Xisco Faulí 2019-12-19 08:52:01 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9fa01a8d1137a95af9865a3e47995734c40da6e.
Closing as duplicate of bug 128088

*** This bug has been marked as a duplicate of bug 128088 ***