Bug 126277 - Writer Character Styles are not intuitive to read
Summary: Writer Character Styles are not intuitive to read
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Sidebar-Styles Writer-Styles-Character
  Show dependency treegraph
 
Reported: 2019-07-07 20:45 UTC by andreas_k
Modified: 2019-08-15 09:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
writer styles sidebar with character styles (16.10 KB, image/png)
2019-07-07 20:46 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2019-07-07 20:45:12 UTC
Description:
if you open the Character Styles in writer there is no Treeview like in Paragraph Styles and the names are not very intuitive at all.

It's very difficult to understood which style is used for which result. In addition Character Styles combine internal used styles like Page Number, Line Numbering with styles with strange names like Example, Definition and styles that should be used from the user like Source Text, Strong Emphasis.

Steps to Reproduce:
1. Writer open Styles Sidebar
2. Character Styles

Actual Results:
Not ready for the enduser

Expected Results:
Treeview and separate between styles that should be selected by the user and styles that are needed for internal stuff. Styles with strange names should be deleted.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 andreas_k 2019-07-07 20:46:07 UTC
Created attachment 152631 [details]
writer styles sidebar with character styles
Comment 2 Thomas Lendo 2019-07-07 21:08:15 UTC
I like your discussions in Telegram, but no or few knowledge about something doesn't mean there is something wrong.

Treeview is only useful if there is inheritance which isn't the case for character styles.

There were a vast number of bugs and issues since two decades that dealt with character styles.

This bug is too vague to be valid. I think it's better to comment on existing character styles/sidebar bugs that are about UX/UI improvements.
Comment 3 Heiko Tietze 2019-07-12 11:28:04 UTC
Thomas mention the inheritance, character styles are not related to each other like emphasis with the children soft emphasis and string emphasis. However, we started to talk about nested character styles in bug 115311.

When you check the Show Preview checkbox you get a limited WYSIWYG preview.

So what exactly do you suggest/request?
Comment 4 andreas_k 2019-07-15 23:38:00 UTC
good point. I open also BUG 126278 where the issue will be described better. The styles sidebar show by default an  mix between styles that will be used for software internal stuff and styles the user should select from.

with treeview it's possible to separate between character styles that are software specific like Bullets, Rubies, Endnote Anchor and strong emphasis, ...
Comment 5 QA Administrators 2019-07-16 02:47:03 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2019-07-16 07:24:21 UTC
(In reply to andreas_k from comment #4)
> good point. I open also BUG 126278 where the issue will be described better.

Okay, let's continue there. But a treeview is only appropriate for hierarchical data (and not recommended as the first choice).
Comment 7 andreas_k 2019-07-16 07:27:15 UTC
all I want is that the default setting (there are different filters via dropdown menu available) should be ready for every user and you don't have to know the LibreOffice, StarOffice internals to understood where the style is comming from.
Comment 8 Cor Nouws 2019-07-17 16:03:58 UTC
(In reply to andreas_k from comment #1)
> Created attachment 152631 [details]
> writer styles sidebar with character styles
So what would the proposal look like?

(In reply to andreas_k from comment #7)
> all I want is that the default setting (there are different filters via
> dropdown menu available) should be ready for every user and you don't have
> to know the LibreOffice, StarOffice internals to understood where the style
> is comming from.
The opposite perspective is valid too: People using styles and the side bar for that, are not the typical newbies and may be well served by seeing more stuff, that will bring some ideas up to them, maybe..
Comment 9 Heiko Tietze 2019-07-18 05:44:23 UTC
We talked about this topic in the design meeting. While more organization is always welcome, the drawback of another levels is the unclear relevance of this new style. In case of Character styles it could be "Standard" (Emphasis, Strong Emphasis, Source Text...), "Annotation" (Endnote, Footenote...), "References" (Links...). While users can inherit manually (and we can do programatically) it's absolutely not clear if properties are taken.

So as long we do not get more clear opinions to change we keep the status quo (REOPENED for more input).

As alternative solution Bogdan suggested to introduce a new filter type, let's say "Simple Hierarchical", and just filter out the not so frequently used styles.

This applies also to bug 126258 and bug 126257.
Comment 10 Heiko Tietze 2019-08-15 09:27:15 UTC
No further opinions so closing now as WF.