Bug 126289 - Broken slide preview on Slide pane with enabled OpenGL
Summary: Broken slide preview on Slide pane with enabled OpenGL
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2019-07-08 20:00 UTC by Roman Kuznetsov
Modified: 2019-07-15 18:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
presentation (10.12 MB, application/vnd.oasis.opendocument.presentation)
2019-07-08 20:02 UTC, Roman Kuznetsov
Details
screenshot with a problem (1.69 MB, image/png)
2019-07-08 20:02 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-07-08 20:00:52 UTC
Description:
Broken slide preview on Slide pane with enabled OpenGL

Steps to Reproduce:
1. Open file from attach (make sure OpenGL is enabled)
2. Look at Slide pane (2 slide)
3. Try disable OpenGL and reopen file
4. Slide preview on Slide pane looks good

Actual Results:
Broken slide preview on Slide pane with enabled OpenGL

Expected Results:
slide preview on Slide pane with enabled OpenGL looks good


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.3.0.1 (x64)
ID сборки: 41ac97386aba908b6db860cfb4cfe2da871886ae
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded

but not in 6.1 -> regression
Comment 1 Roman Kuznetsov 2019-07-08 20:02:11 UTC
Created attachment 152648 [details]
presentation
Comment 2 Roman Kuznetsov 2019-07-08 20:02:59 UTC
Created attachment 152649 [details]
screenshot with a problem
Comment 3 Telesto 2019-07-08 20:31:18 UTC
No repro with:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 849b837d1a3b185a8dd893a8f6eaed53605bcab1
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-05_03:53:49
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 4 Roman Kuznetsov 2019-07-08 21:00:29 UTC
(In reply to Telesto from comment #3)
> No repro with:
> Version: 6.4.0.0.alpha0+ (x86)
> Build ID: 849b837d1a3b185a8dd893a8f6eaed53605bcab1
> CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
> TinderBox: Win-x86@42, Branch:master, Time: 2019-07-05_03:53:49
> Locale: nl-NL (nl_NL); UI-Language: en-US
> Calc: CL

Telesto, can you try on Windows 10?
Comment 5 Mike Kaganski 2019-07-10 22:36:09 UTC
Repro with Version: 6.3.0.1 (x64)
Build ID: 41ac97386aba908b6db860cfb4cfe2da871886ae
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 6 Mike Kaganski 2019-07-10 23:08:40 UTC
But not repro with Version: 6.4.0.0.alpha0+ (x64)
Build ID: 5583ee37101a748d901fae1da315aeb453278ecd
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

So likely fixed somewhere in master toward 6.4; needs reverse-bibisecting to find what needs backporting.
Comment 7 Xisco Faulí 2019-07-12 16:35:22 UTC
@Roman, @Buovjaga, any chance you could reverse-bisect it ?
Comment 8 Roman Kuznetsov 2019-07-15 18:29:11 UTC
(In reply to Xisco Faulí from comment #7)
> @Roman, @Buovjaga, any chance you could reverse-bisect it ?

I see the bug in bisect win64 repo in oldest and in master too >_<