Bug Hunting Session
Bug 126306 - Doesn't work Top 10 item in Autofilter
Summary: Doesn't work Top 10 item in Autofilter
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.2
Keywords: bibisected, bisected, regression
: 126367 (view as bug list)
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2019-07-09 11:06 UTC by Roman Kuznetsov
Modified: 2019-07-29 22:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example with Autofilter (9.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-07-09 11:08 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-07-09 11:06:55 UTC
Description:
Doesn't work Top 10 item in Autofilter

Steps to Reproduce:
1. Open file from attach
2. Open Autofilter in A1
3. Try use Top 10 for filtering
4. It nothing happens

Actual Results:
Doesn't work Top 10 item in Autofilter

Expected Results:
Top 10 item in Autofilter works fine


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.3.0.1 (x86)
ID сборки: 41ac97386aba908b6db860cfb4cfe2da871886ae
Потоков ЦП: 4; ОС:Windows 6.1; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded

but not in 6.1 -> regression
Comment 1 Roman Kuznetsov 2019-07-09 11:08:41 UTC
Created attachment 152673 [details]
Example with Autofilter
Comment 2 Xisco Faulí 2019-07-09 12:04:59 UTC
Regression introduced by:

author	Serge Krot <Serge.Krot@cib.de>	2019-03-05 17:03:31 +0100
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-04-12 11:46:58 +0200
commit	4e7e3670c31329d60f5cc782abc4568c2aba33a7 (patch)
tree	0e962c50607a049634400d32c0d96871427c9fc9
parent	0342562261beede5d3bb2e43c08f6d0f216ff97c (diff)
tdf#117276 sc: autofilter was unexpected reset with OK pressed

Bisected with: bibisect-linux64-6.3

Adding Cc: to Serge Krot
Comment 3 Xisco Faulí 2019-07-09 13:42:58 UTC
proposed fix: https://gerrit.libreoffice.org/#/c/75304/
Comment 4 Mike Kaganski 2019-07-12 14:27:17 UTC
*** Bug 126367 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2019-07-16 17:32:55 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/9bd7e2cdf7d2b247ae99a2ce71449d9f265032d1%5E%21

tdf#126306: ignore Top10, Empty and NonEmpty in fix for tdf#117276

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-07-16 19:53:18 UTC
oh, yep, indeed commit 4e7e3670c31329d60f5cc782abc4568c2aba33a7 ins master and 6.3. Eike, thanks for adjusting that.
Comment 7 Xisco Faulí 2019-07-16 19:55:49 UTC
Adding needUITest just in case someone know how to test it.
I tried but 'Empty', 'Not empty' and 'Top 10' buttons are not among the float window's children -> ('cancel', 'check_list_box', 'check_list_menu', 'ok', 'search_edit', 'select_current', 'toggle_all', 'unselect_current')
As a reference, you can use the UItest added in https://gerrit.libreoffice.org/plugins/gitiles/core/+/4e7e3670c31329d60f5cc782abc4568c2aba33a7%5E%21
Comment 8 Commit Notification 2019-07-16 22:37:49 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/5f48428533e928868c11ddd00cc449a54d0cdfd9%5E%21

tdf#126306: ignore Top10, Empty and NonEmpty in fix for tdf#117276

It will be available in 6.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-07-29 22:59:50 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6f8a1b6736b4a79778fd222c7adabb2f6a12ca0a%5E%21

tdf#126306: Add UItest

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.