Download it now!
Bug 126307 - Edits to complex tables are lost upon closing LibreOffice Writer when font embedding is enabled
Summary: Edits to complex tables are lost upon closing LibreOffice Writer when font em...
Status: RESOLVED DUPLICATE of bug 124470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: File-Properties Fonts-Embedded
  Show dependency treegraph
 
Reported: 2019-07-09 12:03 UTC by Jeroen Hoek
Modified: 2020-03-17 13:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Reduced version of cursed document. (1.74 MB, application/vnd.oasis.opendocument.text)
2019-07-09 12:10 UTC, Jeroen Hoek
Details
What the document looks like after closing and opening it. (19.18 KB, application/pdf)
2019-07-09 12:11 UTC, Jeroen Hoek
Details
What the document looks like after applying the table styling. (19.23 KB, application/pdf)
2019-07-09 12:12 UTC, Jeroen Hoek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Hoek 2019-07-09 12:03:25 UTC
Description:
I have a document that contains a few tables with some styling applied directly. This document lost all manual page breaks and all manual styling after updating LibreOffice to version 6.2.5.2.

I've re-edited the document to redo the styling, thinking this might be an issue with the slightly older document. This works, and I have successfully exported the document to a PDF. However, when I close the document and reopen it, all the styling is discarded again.

So now I appear to have a cursed document that will accept changes, but discard styling (including borders, column widths) on tables, and discard all manual page breaks when I close Writer.

There appear to be no errors; at least none that are reported to me.

Steps to Reproduce:
1. Open specific document.
2. Add styling to tables, reintroduce page breaks.
3. Save document.
4. Open document: styling gone.

Actual Results:
Styling gone from tables. Page breaks removed.

Expected Results:
A working document; not the loss of hours of work. :(


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.2.5.2
Build ID: libreoffice-6.2.5.2-snap1
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Jeroen Hoek 2019-07-09 12:10:14 UTC
Created attachment 152674 [details]
Reduced version of cursed document.

This is the broken document that discards styling on the one table remaining.
Comment 2 Jeroen Hoek 2019-07-09 12:11:05 UTC
Created attachment 152675 [details]
What the document looks like after closing and opening it.
Comment 3 Jeroen Hoek 2019-07-09 12:12:39 UTC
Created attachment 152676 [details]
What the document looks like after applying the table styling.

This is what the document looks like after (re)applying the styling on the table. The PDF export works as you can see. Saving the document, and then reopening it means these edits are gone, and the document is back to the state shown in actual-state.pdf.
Comment 4 Jeroen Hoek 2019-07-09 12:39:55 UTC
Additional testing trying to reproduce this bug seem to point to the font embedding feature as a possible culprit.

I was rebuilding the complex document part by part, and when I enabled font embedding, the bug was triggered.

I don't know if font embedding as such causes this bug, but it seems possible to trigger this bug by enabling it (and is indeed a requirement for reproduction).
Comment 5 Dieter 2019-07-11 17:48:11 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 2f2f4767089512c34514896bc37823f9310e9dd4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-10_02:13:57
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Steps to reproduce
1. Open document from comment 2
2. Add border at the top of the table
3. File => Properties => Font ("Only embed fonts that are used in the document" is enabled
4. Save and reopen document

Result: Border get's lost (doesn't happen, if option is disabled)
Comment 6 Timur 2020-03-17 13:24:15 UTC

*** This bug has been marked as a duplicate of bug 124470 ***