Bug Hunting Session
Bug 126325 - Exhibition of Headings sub levels are allowed
Summary: Exhibition of Headings sub levels are allowed
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-10 13:20 UTC by ricky.tigg
Modified: 2019-07-17 11:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ricky.tigg 2019-07-10 13:20:25 UTC
Description:
Exhibitions of heading sub-levels are allowed even when their main heading (Heading 1) is not applied to any content.

Steps to Reproduce:
1. On a blank document, add at least one character then apply to it any heading style superior to one  –known as sub-levels– from the available range (example Heading 2);
2. Not required – Apply chapter numbering to the level 1 and to the level applied in document; Tools ==> Chapter Numbering..., then apply to them a number style (example: "1,2,3...").

Actual Results:
Such headings are allowed to be created. Step 2 is also allowed.

Expected Results:
Such headings not allowed to be created. It seemed to me eligible as an enhancement while it can be as well interpreted as an issue.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.4.2.0+; Build ID: 6.2.4.2-4.fc30; CPU threads: 2; OS: Linux 5.1; UI render: default; VCL: gtk3; Locale: en-US (C); UI-Language: en-US; Calc: threaded
Comment 1 Dieter Praas 2019-07-10 15:04:26 UTC
I don't agree, because for example heading 2 is a heading style and it is not related to a specific chapter level, so style "heading 2" is not a sub-level of style "heading 1".

So for me NOTABUG, but let's ask design team.
Comment 2 Heiko Tietze 2019-07-13 07:33:09 UTC
Let's ask the OP: Why should H2 forbidden without H1? Have you seen any office suite or text processor that works like this?
Comment 3 ricky.tigg 2019-07-13 16:56:47 UTC
That must be me that "OP" then, since status is now as NEEDINFO. Fantastic question indeed. How do I see things? To be accurate how do you want me to see things to please one's view? You are here the one that shoud know since you asked me. Would any things have to be seen as good if they could be seen also the same way in an other suite?
Comment 4 hpsetup07 2019-07-17 09:11:01 UTC Comment hidden (spam)
Comment 5 Heiko Tietze 2019-07-17 11:00:43 UTC
I follow Dieter's opinion then. => NAB/WF

The question with the scenario is important. Changing things for one user might negatively affect others. So we have to balance carefully if a well-known behavior needs to get updated.