Bug Hunting Session
Bug 126334 - Crash in: SvxNumberFormat::GetAbsLSpace()
Summary: Crash in: SvxNumberFormat::GetAbsLSpace()
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All All
: high major
Assignee: Gülşah Köse
URL:
Whiteboard: target:6.4.0 target:6.3.0
Keywords:
Depends on:
Blocks: Impress-Bullet-Numbering-Dialog
  Show dependency treegraph
 
Reported: 2019-07-10 21:16 UTC by Roman Kuznetsov
Modified: 2019-07-29 09:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["SvxNumberFormat::GetAbsLSpace()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-07-10 21:16:14 UTC
This bug was filed from the crash reporting server and is br-cdbb19f1-88eb-4d43-9534-6dca5aadad39.
=========================================

Steps:

1. Open Impress
2. Open Format->Bullets & Numbering
3. Check Relative option
4. Try select any level in left list

=> Crash

Версия: 6.3.0.1 (x64)
ID сборки: 41ac97386aba908b6db860cfb4cfe2da871886ae
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded

and 6.3.0.1 in Kubuntu with vcl:kde5 crashes also
Comment 1 Aron Budea 2019-07-10 23:12:47 UTC
Confirmed using LO 6.4.0.0.alpha0+ (3f009ab4e767000da299fe222184efea29942173) / Windows 7.
Comment 2 Xisco Faulí 2019-07-11 08:58:48 UTC
it crashes since the dialog was introduced in https://cgit.freedesktop.org/libreoffice/core/commit/?id=e3015d7021e689c71c2ed8e5dd01a74d832c84f0
Comment 3 Commit Notification 2019-07-19 10:14:31 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1f6c4328bfa00da5cf351dd050a80b75e0f1acde%5E%21

tdf#126334 Fix number format array  in init controls.

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2019-07-22 07:09:54 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/95308943748bd650ee52e6e7570090f9c6a940b1%5E%21

tdf#126334 Fix number format array  in init controls.

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-07-29 09:08:05 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-0":

https://git.libreoffice.org/core/+/45e5be4d0cbd7a31fa9b32c729611b4afca7bcba%5E%21

tdf#126334 Fix number format array  in init controls.

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-07-29 09:12:37 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 140b070bb187e3d5e35a588a1d187e3a40e11547
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES-valencia (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Gülşah Köse, thanks for fixing this issue!