Bug Hunting Session
Bug 126387 - Unsymmetrical fonts for quotation marks in mixed western and Asian text
Summary: Unsymmetrical fonts for quotation marks in mixed western and Asian text
Status: RESOLVED DUPLICATE of bug 66791
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.6.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-14 11:26 UTC by zh_CN User Community Liaison
Modified: 2019-07-15 11:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zh_CN User Community Liaison 2019-07-14 11:26:18 UTC
LO Writer allows the user to specify different fonts for western and Asian text within a single style.  This is a very useful feature, but for some charaters that are used in both western and Asian text, it causes some undesired effects.

This bug is about the curly quotation marks, which are used frequently in both English and Chinese texts.  Currently Writer seems to choose fonts by a simple rule - the quotation mark just uses the font of the text it follows.  So obviously in pure English text, the quotation marks use the Western font; while in pure Chinese text they use Asian font.

For mixed English-and-Chinese text, however, this simple rule produces some ugly results.  In text like 中文“English”中文 the opening quotation mark uses Chinese font, and the closing one uses Western font.  On the other hand, in text like English“中文”English, the opening quotation mark uses Western font and the closing one uses Chinese font.

I'm not sure what the best result is, but the current unsymmetrical result is probably the least desired one.  It would be nice if there is an option for this, but I'll settle for any symmetrical solution.

I reproduced this bug in LO 6.1.6 on Windows 10, but it's quite independent on versions and platforms, and has been reproduced by others on LO 6.1.5/6.2.3/6.3.0 RC1 on Linux.
Comment 1 zh_CN User Community Liaison 2019-07-14 11:29:18 UTC
This is a report forwarded from a Chinese LO user forum.  The original discussion thread (in Chinese) is
https://bbs.libreofficechina.org/thread-2301-1-1.html
Comment 2 Volga 2019-07-15 11:21:03 UTC

*** This bug has been marked as a duplicate of bug 66791 ***