Bug 126396 - PRINTING: LibreWriter cant handle landscape orientation like portrait (wrong print preview and print result)
Summary: PRINTING: LibreWriter cant handle landscape orientation like portrait (wrong ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Preview
  Show dependency treegraph
 
Reported: 2019-07-15 08:38 UTC by reikenberg
Modified: 2021-06-10 20:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshots (113.21 KB, application/vnd.oasis.opendocument.text)
2019-07-15 08:39 UTC, reikenberg
Details
portrait vs landscape (229.62 KB, application/vnd.oasis.opendocument.text)
2019-07-17 14:25 UTC, reikenberg
Details
master (71.32 KB, application/vnd.oasis.opendocument.text)
2019-07-18 14:31 UTC, reikenberg
Details
print preview (94.28 KB, image/jpeg)
2019-07-25 06:33 UTC, Dieter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description reikenberg 2019-07-15 08:38:56 UTC
Description:
Printing a user defined paper size on portrait gives the expected result, change to landscape the pring goes wrong.

If the size of the sheet for example 10,16mm x 15,24mm fits 100% to the paper of the printer there is no problem for portrait and landscape.

If the size is a bit lower, for example 10,16mm x 15,00mm, protrait works, but landscape goes wrong.

If the print goes right for portrait it should be also right for landscape but it does not. But bot orientation fits on the paper, so it should give in both cases the right print.



Steps to Reproduce:
1. Create a userdefined page for example 10,16mm x 15,24mm
2. Printing works in portrait and landscape
3. Change 15,24 to 15,00
4. Printing works in portrait but fails in landscape

Actual Results:
Printing in landscape goes wrong.

Expected Results:
Printing in landscape should fit on the page like protrait.



Reproducible: Always


User Profile Reset: No



Additional Info:
This behavior, that protrait works and landscape not is confusing.

A normal user dont figure it out that the size of the page in librewriter dont exactly is the same as the printer page size. If he created a custom size at it works all the time for protrait in the past, and now he want to print in landscape, and it does not work is annoying.

Both page orientation should work the same,
or there should be a warning for the user that the page must fit 100% on the target.
Comment 1 reikenberg 2019-07-15 08:39:52 UTC
Created attachment 152772 [details]
screenshots
Comment 2 Dieter 2019-07-16 11:47:20 UTC
Thank you for reporting the bug. It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 3 reikenberg 2019-07-16 12:16:13 UTC
Yes, 6.2.5.2 still has the same problem.

Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 4; BS: Windows 6.1; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 4 Dieter 2019-07-16 12:38:54 UTC
(In reply to reikenberg from comment #0)
> Actual Results:
> Printing in landscape goes wrong.

Please describe the result. What does "goes wrong" mean exactly?
Comment 5 reikenberg 2019-07-17 14:25:50 UTC
Created attachment 152833 [details]
portrait vs landscape

Portrait is printed like in the preview/printer preview.
Real print is ok.

Landscape is printed wrong, preview is ok. Printer preview is wrong.
Real print is not ok. It is not centered, the output is shifted right.
Comment 6 reikenberg 2019-07-17 14:27:54 UTC
It is the same for example with FreePDF, so you can reproduce with it.
Comment 7 Dieter 2019-07-18 06:22:27 UTC
I can see, that you used a docx-file. So is it a docx-specific problem, or does it also happen with odt-files?
I just recognized, that the printing dialog is renewed in master. So perhaps you can try it with a master build from http://dev-builds.libreoffice.org/daily/master/ ? You can install it alongside the standard version.
Comment 8 reikenberg 2019-07-18 14:24:49 UTC
(In reply to Dieter Praas from comment #7)
> I can see, that you used a docx-file. So is it a docx-specific problem, or
> does it also happen with odt-files?
> I just recognized, that the printing dialog is renewed in master. So perhaps
> you can try it with a master build from
> http://dev-builds.libreoffice.org/daily/master/ ? You can install it
> alongside the standard version.

It happens with odt-files too.
I try the master build and report the result.
Comment 9 reikenberg 2019-07-18 14:31:09 UTC
Created attachment 152861 [details]
master

It is wrong in master to, but the preview has some changes and the sizes are corrected in the preview.
Comment 10 Dieter 2019-07-20 04:55:33 UTC
I can't reproduce it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 2f2f4767089512c34514896bc37823f9310e9dd4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-10_02:13:57
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Perhaps it it printer specific? I use Brother MFC-J491.
Comment 11 reikenberg 2019-07-22 10:56:21 UTC
Perhaps it comes from custom paper sizes.
Can you reproduce it when create a custom paper size of 10,16mm x 15,24mm?

I installed the Brother MFC-J491DW Printer if i have the same problem and assign the custom paper size. In portrait look fine and preview has 102x150mm.
In landscape it goes wrong and preview has 127x150mm and a centered text is no more centered.
Comment 12 Dieter 2019-07-25 06:32:54 UTC
(In reply to reikenberg from comment #11)
> Perhaps it comes from custom paper sizes.
> Can you reproduce it when create a custom paper size of 10,16mm x 15,24mm?

I tred to reproduce it as follows:

1. I opened new document and typed some text (like in your example) to make result more visible
2. Format => Page => Page format User (10,16 cm x 15,24 cm) => O. K.
3. File => Print => Paper size 102 x 152 / orientation: portrait (looks fine)
4. Changed orientation to landscape

Result: preview and print are cropped at the top of the page (see attachment)
Comment 13 Dieter 2019-07-25 06:33:34 UTC
Created attachment 152973 [details]
print preview
Comment 14 Dieter 2021-06-10 20:27:39 UTC
Still present in

Version: 7.1.4.2 (x64) / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL