Bug 126400 - LibreOffice math does not get focus back after using the 'elements' panel when floating
Summary: LibreOffice math does not get focus back after using the 'elements' panel whe...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Elements-Pane
  Show dependency treegraph
Reported: 2019-07-15 10:56 UTC by Daniel MOYNE
Modified: 2020-12-10 03:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

screenshot of bug (31.50 KB, image/png)
2020-02-24 01:23 UTC, Daniel MOYNE

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel MOYNE 2019-07-15 10:56:31 UTC
example when using division/fraction component from component window to create a fraction between 2 components: the most efficient way to process is to select the numerator component by selection and select the division component from the tool window ; it works fine as we can see the numerator filled correctly and the denominator that appears with <?> (question mark colored in black) ready to be edited BUT WITH THE FOCUS STILL ON TOOL WINDOW RATHER THAT ON MAIN EDIT WINDOW. This bug appeared recently as it worked fine before. A picture is attached

Steps to Reproduce:
1.select a field for numerator
2.select division (fraction) component
3.try to enter data in denominator field with keyboard

Actual Results:
to get data need to reset focus on main window
this of course is the same with all other tool window components

Expected Results:
automatic focus set on main window after use of tool window

Reproducible: Always

User Profile Reset: No

OpenGL enabled: Yes

Additional Info:
left focus on tool window to put it on main window
Comment 1 V Stuart Foote 2019-07-24 13:55:49 UTC
Can not confirm on Winndows 10 Home 64-bit en-US (1903) with
Version: (x64)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

Focus after selection from the elements pane shifts back to the input window. I didn't check with (experimental) visual mode--but that is not likely relevant here.

What os/DE distro are you using? And, have you tried using a different VCL plugin?
Comment 2 QA Administrators 2020-01-21 03:32:37 UTC Comment hidden (obsolete)
Comment 3 Daniel MOYNE 2020-01-31 14:59:51 UTC
One way to solve this problem is to select a layout with the tool window included in the left panel of the main window. In this case the focus is properly handled. If the tool window is outside of the main window then a click on the main window is necessary first to recover the focus.
Comment 4 V Stuart Foote 2020-01-31 16:52:58 UTC
Can not confirm on Windows builds with or current master/7.0.0

Detaching the Elements pane does not have any affect. After a selection is made from an Elements panel category, edit cursor and focus is returned to the Input window.

Redocking the Elements pane (with <Ctrl>+<Shift>+<F10>) has exactly same behavior on making selection from the Elements pane and focus and edit cursor reactivating in the Input window.

So, on Windows builds at least => WFM

@Regina, Jim your takes? Is edit cursor focus behaving in the sm GUI?
Comment 5 Jim Raykowski 2020-02-01 02:05:54 UTC
No repro with gtk3 using current master and many versions tested using bibisect repositories.
Comment 6 Daniel MOYNE 2020-02-24 01:10:59 UTC
The simplest way to solve the problem is to execute the following command on the "Element window" when it gets the focus:
It will then reinstall the "Element window" in the right panel of the main window. In this case there is no further problems with the focus issue. The same method can be applied on the "Formule editor window" when it is separated from the main window.
Comment 7 Daniel MOYNE 2020-02-24 01:23:35 UTC
Created attachment 158127 [details]
screenshot of bug

Comment 8 Daniel MOYNE 2020-02-24 01:28:08 UTC
as shown on the screenshot one formula "f(x)=2x^2+3x-5" has been substituted to the original one. It appears with another font and corresponds to another existing on probably copied once
Comment 9 Buovjaga 2020-05-10 14:11:10 UTC
(In reply to V Stuart Foote from comment #1)
> What os/DE distro are you using? And, have you tried using a different VCL
> plugin?

Daniel: please reply to this. Also, test with 6.4.x. An easy way is to use an appimage: https://libreoffice.soluzioniopen.com/

Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 10 Daniel MOYNE 2020-05-12 11:34:27 UTC
I am using Kubuntu 20.04. I do not know what you mean by VCL
Comment 11 Buovjaga 2020-05-12 11:40:15 UTC
(In reply to Daniel MOYNE from comment #10)
> I am using Kubuntu 20.04. I do not know what you mean by VCL

You did not respond to my suggestion about trying with an appimage.

"Visual Class Library is responsible for the widgets (windowing, buttons, controls, file-pickers etc.), operating system abstraction, including basic rendering (e.g. the output device)."

You can the see VCL backend in use from Help - About.

You can launch libreoffice from the command line with the different backends by
SAL_USE_VCLPLUGIN=gtk3 libreoffice
SAL_USE_VCLPLUGIN=gen libreoffice
SAL_USE_VCLPLUGIN=kf5 libreoffice

In case of appimage, you would replace libreoffice above by the path to the appimage file.
Comment 12 QA Administrators 2020-11-09 04:17:42 UTC Comment hidden (obsolete)
Comment 13 QA Administrators 2020-12-10 03:48:13 UTC
Dear Daniel MOYNE,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team