Download it now!
Bug 126401 - Base: Data corruption in Firebird migration
Summary: Base: Data corruption in Firebird migration
Status: RESOLVED DUPLICATE of bug 126268
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-15 11:28 UTC by Lars Jødal
Modified: 2019-07-15 13:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Jødal 2019-07-15 11:28:32 UTC
Description:
Testing out LO 6.3.0.1 on attachment 135786 [details] (originally created for bug 112023), I am asked if I want to migrate embedded HSQL data to Firebird. If answering yes, the file opens, but the data are corrupted. No warning or other indication is given.

The original file contains these data:

    MyTimestamp            MyDouble
    01-01-2015 00:00:01    1.2345
    01-01-2015 00:00:15    3.1415

which in standard viewing is shown as (correctly, just shown in lower precision):

    MyTimestamp       MyDouble
    01-01-15 00:00    1.23
    01-01-15 00:00    3.14

However, after migration to Firebird, the view is

    MyTimestamp       MyDouble
    31-12-14 23:00    0
    31-12-14 23:00    1.10E+227

I.e., the timestamp has lost one hour (thereby moving just past midnight 2015 to one hour before midnight 2014), while the numerical data are completely corrupted.

Steps to Reproduce:
1. Open the attachment in LO 6.3.0.1
2. Click on tables and answer "Later" to migration
3. Open Table1 and note results
4. Close file
5. Re-open, answer "Yes" to migration
6. Open Table1 and note results

Actual Results:
Data are corrupted after migration.

Expected Results:
Data should be unchanged after migration.


Reproducible: Always


User Profile Reset: No



Additional Info:
Problem found in:

Version: 6.3.0.1 (x64)
Build ID: 41ac97386aba908b6db860cfb4cfe2da871886ae
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: da-DK (da_DK); UI-Language: en-GB
Calc: threaded

Current "fresh" version does not suggest migration and opens the file without problems::

Version: 6.2.5.2 (x64)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: da-DK (da_DK); UI-Language: en-GB
Calc: threaded
Comment 1 Xisco Faulí 2019-07-15 13:04:31 UTC
This is fixed in

Version: 6.4.0.0.alpha0+
Build ID: ed2107f0488887528d8e49135d3270705f389ed5
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Dupe of bug 126268

*** This bug has been marked as a duplicate of bug 126268 ***