Download it now!
Bug 126405 - FILEOPEN DOCX Rotated text misses last letters (Open GL enabled) in tables and textbox
Summary: FILEOPEN DOCX Rotated text misses last letters (Open GL enabled) in tables an...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 129791 (view as bug list)
Depends on:
Blocks: DOCX-Tables Text-Direction-Unification VCL-OpenGL
  Show dependency treegraph
 
Reported: 2019-07-15 14:31 UTC by NISZ LibreOffice Team
Modified: 2020-08-28 13:04 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Word (22.03 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-07-15 14:32 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer with GL enabled (116.68 KB, image/png)
2019-07-15 14:33 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer with GL disabled (49.00 KB, image/png)
2019-07-15 14:33 UTC, NISZ LibreOffice Team
Details
Screenshot of the document in current Writer master (75.39 KB, image/png)
2020-04-16 10:42 UTC, NISZ LibreOffice Team
Details
The document from comment #5 in Word and Writer (38.11 KB, image/png)
2020-04-16 10:49 UTC, NISZ LibreOffice Team
Details
Example documents in 7.1 (183.69 KB, image/png)
2020-08-28 13:00 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-07-15 14:31:26 UTC
Description:
Attached document contains a simple table in a docx/rtf file from Word. When it is opened in Writer with GL enabled the last character is not visible. Turning off GL solves this problem.

Steps to Reproduce:
1.	Open attached file in Word / Writer

Actual Results:
In Writer the last characters in the cells with rotated text direction are not visible.

Expected Results:
In Writer the last characters in the cells with rotated text direction are not visible.


Reproducible: Always


User Profile Reset: No



Additional Info:

LibreOffice details:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 49422a469646ad8be43ba828ca24c2484c26b9e8
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-08_00:50:19
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2019-07-15 14:32:40 UTC
Created attachment 152784 [details]
Example file from Word
Comment 2 NISZ LibreOffice Team 2019-07-15 14:33:00 UTC
Created attachment 152785 [details]
Screenshot of the original document side by side in Word and Writer with GL enabled
Comment 3 NISZ LibreOffice Team 2019-07-15 14:33:16 UTC
Created attachment 152786 [details]
Screenshot of the original document side by side in Word and Writer with GL disabled
Comment 4 Dieter 2019-07-17 07:53:06 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 2f2f4767089512c34514896bc37823f9310e9dd4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-10_02:13:57
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 5 Luke 2019-09-27 13:26:11 UTC
Textboxes are also affected. See attachment 142426 [details]

In addition, this affects both btLr and tbRl modes. See attachment 142413 [details]

Miklos,
Since you added btLr writing mode to writer and have fixed many OpenGL issues, do you have any thoughts on this?
Comment 6 NISZ LibreOffice Team 2020-01-06 07:44:23 UTC
*** Bug 129791 has been marked as a duplicate of this bug. ***
Comment 7 NISZ LibreOffice Team 2020-04-16 10:42:44 UTC
Created attachment 159623 [details]
Screenshot of the document in current Writer master

Looks to be fixed in:

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 94a7ceae287a7967e8f013d012673e26637c6bb5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

Bibisection shows it's good since this commit: 

https://git.libreoffice.org/core/+/a8d26a0bb40c101394ded8061d1b58048153631b

author
Miklos Vajna <vmiklos@collabora.com> Mon Apr 06 21:02:30 2020 +0200 
committer
Miklos Vajna <vmiklos@collabora.com> Tue Apr 07 09:04:09 2020 +0200 

tdf#131490 sw btlr: fix handling of vertical text
Comment 8 NISZ LibreOffice Team 2020-04-16 10:49:39 UTC
Created attachment 159624 [details]
The document from comment #5 in Word and Writer

The second document from comment #5 shows the problem is still there for TBLR direction :(.
Comment 9 Buovjaga 2020-08-28 12:36:23 UTC
NISZ: can you test with Skia/Vulkan? It doesn't make sense to invest in OpenGL anymore after Skia's success.
Comment 10 NISZ LibreOffice Team 2020-08-28 13:00:26 UTC
Created attachment 164803 [details]
Example documents in 7.1

Looking good in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: a486fd929d4b3e915f928ef495b6cb2b96d74a3a
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 11 NISZ LibreOffice Team 2020-08-28 13:02:12 UTC
(In reply to Buovjaga from comment #9)
> NISZ: can you test with Skia/Vulkan? It doesn't make sense to invest in
> OpenGL anymore after Skia's success.

This seems to be OpenGL-only. With Skia/Raster (I have no access to Skia/Vulkan capable hardware at work) both the original document and the one from comment #5 look good.

Can be put to WF.
Comment 12 Buovjaga 2020-08-28 13:04:51 UTC
Thanks for the quick response. Let's close and be happy.