Bug 126448 - Writer: Insert Hyperlink dialogue: accessibility issues - can't tab through fields, can't close with "escape", can't add URL with "enter" (GTK3)
Summary: Writer: Insert Hyperlink dialogue: accessibility issues - can't tab through f...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
Whiteboard: target:6.4.0
Depends on:
Reported: 2019-07-17 19:54 UTC by David Gerard
Modified: 2019-07-18 12:56 UTC (History)
0 users

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description David Gerard 2019-07-17 19:54:21 UTC
Since recent changes, the "Hyperlink" dialogue has accessibility issues.

You can't tab through the fields.
You can't close the dialogue with "escape".
The URL comes up highlighted, so you can paste into it - but you can't then hit "enter" to close the dialogue.

Steps to Reproduce:
1. Open "Hyperlink" dialogue (ctrl-K).
2. Try to tab through fields.
3. Hit "escape".
4. Hit "enter".

Actual Results:
Can't tab through fields.
Escape doesn't close the dialogue.
Enter doesn't close the dialogue.

Expected Results:
"Tab": tab through fields.
"Escape": close the dialogue without saving changes.
"Enter": close the dialogue and save changes.

Reproducible: Always

User Profile Reset: Yes

Additional Info:
Works in GTK2.
This is an accessibility issue.

Compiled from git master, on Lenovo X250 running Xubuntu 18.04.

Build ID: ebd82c33c1a5867e8f46035b344c6fff6e6c389b
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Workaround: use GTK2.

Possibly related: bug 126202.
Comment 1 Caolán McNamara 2019-07-17 20:39:52 UTC
https://gerrit.libreoffice.org/#/c/75818/ for the enter to activate default and the focus on tab fixes. I don't see a problem with esc though. Lets revisit that when the other changes are merged to see if there's still a problem outstanding there.
Comment 2 David Gerard 2019-07-17 20:56:03 UTC
just tested in a2601800845c6500f833684f5e09bf324ac8af09, as it just finished compiling - escape works (maybe I was wrong before!), enter still doesn't work, tab still doesn't work.
Comment 3 Commit Notification 2019-07-18 08:57:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":


Resolves: tdf#126448 set activates_default and correct focus settings

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2019-07-18 08:58:11 UTC
that should complete it
Comment 5 David Gerard 2019-07-18 12:56:11 UTC
verified working for me in build 1291a6f9684144d2a1902ffeec3f9ac361c06efb under GTK3 - tabbing between fields, hitting escape to exit without saving, hitting enter to exit and save. Thanks :-)