Bug 126455 - Ribbon menu button icons default icons NOT contrasted.. in KDE with Breeze dark theme
Summary: Ribbon menu button icons default icons NOT contrasted.. in KDE with Breeze da...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-18 08:03 UTC by swipe650
Modified: 2020-02-14 19:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (14.15 KB, image/png)
2019-07-18 08:05 UTC, swipe650
Details
LO icons breeze (default) (21.59 KB, image/png)
2019-10-07 17:33 UTC, swipe650
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swipe650 2019-07-18 08:03:06 UTC
Description:
Menu button icons not showing but appear when selecting a button e.g. 'Save' for the duration of the mouse click

Steps to Reproduce:
1. Open any Libreoffice app e.g.Writer, Calc, Draw etc
2. 
3.

Actual Results:
Ribbon button icons now showing

Expected Results:
Button icons should be present


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Screenshot of the issue:

https://i.imgur.com/UeFNOAz.png
Comment 1 swipe650 2019-07-18 08:05:49 UTC
Created attachment 152844 [details]
Screenshot
Comment 2 swipe650 2019-07-18 08:14:23 UTC
Additional info:

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.16.3
KDE Frameworks Version: 5.60.0
Qt Version: 5.13.0

Actual Results should read :
Ribbon button icons NOT showing (rather than now showing)
Comment 3 BogdanB 2019-07-18 09:06:22 UTC
You have a dark theme. That's why you not see the icons.
Change the icon theme to a light one.
Comment 4 BogdanB 2019-07-18 09:08:58 UTC
Another thing to do is to reset LibreOffice to factory settings:
Help - Restart in Safe Mode - "Yes" - Check Reset Factory Setting  and check the 2 checkboxes below and Restart and Aply.
Comment 5 Xisco Faulí 2019-08-19 09:52:21 UTC Comment hidden (obsolete)
Comment 6 swipe650 2019-08-19 11:31:10 UTC
(In reply to Xisco Faulí from comment #5)
> A new major release of LibreOffice is available since this bug was reported.
> Could you please try to reproduce it with the latest version of LibreOffice
> from https://www.libreoffice.org/download/libreoffice-fresh/ ?
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the bug is still present in the latest version.

Now on 6.3.0.4 and no change
Comment 7 Xisco Faulí 2019-08-20 13:45:28 UTC
Does it work if you disable OpenGl ? -> https://wiki.documentfoundation.org/OpenGL

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 8 Timur 2019-10-07 08:54:38 UTC Comment hidden (obsolete)
Comment 9 swipe650 2019-10-07 17:32:10 UTC
The icons are fine when using the LO breeze dark icon theme. 

When setting the LO icon scheme back to defaults, the icons are now somewhat visible (unlike when I originally logged the bug when they were completely transparent) but still not very contrasting. (see attachment)

No change to icons when disabling OpenGL
Comment 10 swipe650 2019-10-07 17:33:23 UTC
Created attachment 154803 [details]
LO icons breeze (default)
Comment 11 Timur 2019-10-08 06:32:50 UTC
We can only confirm reproducible issue. SO I change the title from "icons NOT showing.." to "default icons NOT contrasted..".
Which exact dark theme are you using in OS? Did you try with some other dark theme? 
Do you have some option such as "Use a dark theme variant when available in certain applications"?
What is default icon style in your LO? Elementary? Apart from Breeze, how other icon styles behave? 
In Options-Application Colors, what is the Scheme? Did you try with others (to be installed)?
Comment 12 Timur 2019-10-08 06:49:28 UTC
I tested in Mint with some dark theme Mint-Y with Controls also dark themed. 
Contrast OK: Breeze (dark), Colibre, Elementary ,Sifr (dark), Tango.
Contrast NOK: Human (but style-human is not even installed in Mint due to conflict).
So I cannot confirm. Needinfo. So far Trivial.
Comment 13 swipe650 2019-10-08 07:04:09 UTC
I'm using Breeze Dark theme (OS) and Numix-icon-theme. Other non dark LO themes show OK apart from sifr which also lacks contrast. I agree, it's trivial so not worth pursuing as selecting and different LO icon theme addresses the issue.
Comment 14 QA Administrators 2019-10-09 02:30:17 UTC Comment hidden (obsolete)
Comment 15 Timur 2019-10-09 11:36:44 UTC
You didn't write what is LO default icons from Options-View.
This looks like with dark OS theme not dark icons are used.
Comment 16 swipe650 2019-10-09 11:51:36 UTC
That's correct, OS breeze-dark theme and LO breeze (default/light)
Comment 17 Timur 2019-10-09 13:07:52 UTC
Not sure if we understand ourselves (you say Breeze default/light) but LO Options-View-Icon Style set to Breeze (dark) works fine. 
You need to have and set this Breeze (dark).
I close the bug.