Bug 126535 - 'Find' doesn't show number of matches
Summary: 'Find' doesn't show number of matches
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium enhancement
Assignee: Jim Raykowski
URL:
Whiteboard: target:7.5.0
Keywords:
Depends on:
Blocks: Find-Search Writer-Enhancements
  Show dependency treegraph
 
Reported: 2019-07-25 08:31 UTC by david.cortes.rivera
Modified: 2022-09-17 05:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
findbar display of search key found times (145.69 KB, image/png)
2022-09-14 21:10 UTC, Jim Raykowski
Details
[placeholder for message] (153.71 KB, image/png)
2022-09-14 21:11 UTC, Jim Raykowski
Details
video (2.84 MB, video/mp4)
2022-09-16 09:41 UTC, BogdanB
Details
Search key found times demo (11.84 MB, video/mp4)
2022-09-16 19:56 UTC, Jim Raykowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description david.cortes.rivera 2019-07-25 08:31:05 UTC
In other software such as MS Office, web browsers, PDF viewers, and simple text editors, when I use the 'find' functionality to search for some keyword (usually Ctrl + F in a default US-English install of most software), I get the number of matches in the search bar.

In LO Writer however, it doesn't show this piece of information.
Comment 1 m.a.riosv 2019-07-25 11:19:50 UTC
Found keywords are selected, so you can see words/characters number in the status bar.
Comment 2 david.cortes.rivera 2019-07-25 13:08:37 UTC
(In reply to m.a.riosv from comment #1)
> Found keywords are selected, so you can see words/characters number in the
> status bar.

But that's only when you click 'Find all', and will not show you which match number (e.g. match 3 out of 8) you are browsing when you click next or previous.
Comment 3 BogdanB 2019-07-25 19:36:42 UTC
Confirm. 
For example in a document I have the sentence: "This is a paragraph."
And I am searching for how many "a" are there. I get "Selected: 1 word, 1 character"

If I click on "Find All" I get "Selected: 4 words, 4 characters". 
Just now I get the real answer, but only about characters, not about words. There are only 2 words containg "a", not 4.
Comment 4 BogdanB 2019-07-25 19:37:20 UTC
Tested with
Version: 6.2.5.2
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Oliver Brinzing 2019-07-26 11:34:29 UTC
> For example in a document I have the sentence: "This is a paragraph."
> And I am searching for how many "a" are there. I get "Selected: 1 word, 1
> character"

already reproducible with:

Version: 4.4.7.2
Build-ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Gebietsschema: de_DE(In reply to BogdanB from comment #3)
Comment 6 BogdanB 2020-09-21 06:06:09 UTC
Retested in 
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded

The same problem.
Comment 7 juergenkohler23 2020-11-03 08:45:56 UTC
For blind and visually impaired users it is very important that after a search the number of hits can be displayed directly and can also be accessed. Unfortunately, the solution via the status bar does not work because the status bar cannot be read out by the screen reader NVDA (see https://bugs.documentfoundation.org/show_bug.cgi?id=137075 and https://github.com/nvaccess/nvda/issues/11698).
It would be best if the hits were displayed in a list that can be operated with the arrow keys and that the hit is displayed including its sentence context so that it is easier to orientate oneself in the text.

Windows
Edition	Windows 		10 Home
Version				1909
Installed on			17.02.2020
Operating system build		18363.1016

LibreOffice
Version: 	7.0.2.2 (x64)
Build ID:  8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 	4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: 	de-DE (de_DE); UI: de-DE
Calc: 		threaded
Comment 8 Peter Franke 2020-11-03 10:12:54 UTC
A similar idea has also been discussed here: https://bugs.documentfoundation.org/show_bug.cgi?id=113754
Comment 9 BogdanB 2021-01-29 20:47:53 UTC
Retested with example from comment 3.

Also in
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: f2389a70da606768a39ee599de6a5b24058734aa
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 10 juergenkohler23 2021-05-31 08:21:34 UTC
The problem still occurs.
Comment 11 Jim Raykowski 2022-09-10 00:07:34 UTC
Hi All,

Here is an enhancement patch to show number of matches in Find and Replace dialog and Findbar:
https://gerrit.libreoffice.org/c/core/+/139745
Comment 12 Commit Notification 2022-09-11 05:14:06 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/218624bdf176010e18afc06b453b4535d7a00a04

tdf#126535 show search key found times in find and replace dialog

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Adolfo Jayme Barrientos 2022-09-12 18:12:05 UTC
As a further enhancement we should probably change “search key” for “search term”
Comment 14 BogdanB 2022-09-14 12:38:06 UTC Comment hidden (obsolete)
Comment 15 Jim Raykowski 2022-09-14 21:10:08 UTC
Created attachment 182451 [details]
findbar display of search key found times

(In reply to BogdanB from comment #14)
> This bug was about "Find" toolbar, and this is resolved just in Find and
> Replace.
[placeholder for message] must be check in the Find toolbar popup menu under the Visible Buttons submenu.
Comment 16 Jim Raykowski 2022-09-14 21:11:22 UTC
Created attachment 182452 [details]
[placeholder for message]
Comment 17 BogdanB 2022-09-15 04:46:34 UTC
Yes, I didn't know that thing about placeholder. But in my case is checked, but it is not showing the results. Please test this bug on a Windows machine. I disable and enabled again, and nothing. I tried also reset to factory settings and nothing. The only message is "Reached to the end of the document".

Version: 7.5.0.0.alpha0+ (x86) / LibreOffice Community
Build ID: 2ea790200f5d915f88c6f78014d978ce8d91e33f
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded
Comment 18 BogdanB 2022-09-15 04:59:49 UTC Comment hidden (obsolete)
Comment 19 Jim Raykowski 2022-09-15 22:58:59 UTC
WFM on Windows using daily build Win-x86_64@tb77-TDF 2022-09-15 19:12:01
Comment 20 BogdanB 2022-09-16 09:40:59 UTC Comment hidden (obsolete)
Comment 21 BogdanB 2022-09-16 09:41:35 UTC Comment hidden (obsolete)
Comment 22 BogdanB 2022-09-16 11:16:48 UTC Comment hidden (obsolete)
Comment 23 BogdanB 2022-09-16 18:36:13 UTC Comment hidden (obsolete)
Comment 24 Jim Raykowski 2022-09-16 19:56:06 UTC
Created attachment 182505 [details]
Search key found times demo

The number of times the search key is found message is only displayed after 'Find All' is pressed.
Comment 25 BogdanB 2022-09-17 04:50:12 UTC
Ok, sorry for the noise. It's ok then.

I will mark this as verified after is marked as resolved.
Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: e46f9cc4b506c325cbe1060777bbc81fd1630f49
CPU threads: 16; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 26 Jim Raykowski 2022-09-17 05:01:51 UTC
No worries! Thank you for the QA work :-)
Comment 27 BogdanB 2022-09-17 05:10:14 UTC
Verified. It is working to show number of matches when pressing "Find all".
Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: e46f9cc4b506c325cbe1060777bbc81fd1630f49
CPU threads: 16; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded